Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
3 problems that i hope you can solve.
#1
Hello,
I was on here a few months ago about a Macbook, and fast foward today, and i have the Macbook, with PCSX2 0.9.8 on Windows 7, and everything is running perfect, except for 3 things:
Tekken 4 - Only hair is showing, i've seen on emuforums.com that if 'Alpha Testing' (i think) is disabled, then the full player models will show? But i havent found the option anywhere, unless i'm using a wrong plugin..
Metal Gear Solid 3 - Runs full speed to my surprise, but it always flickers, and previous images run overlap too. 5 minutes longer and i reckon i could get a seisure from it, is there any way of removing this?
Gridlines, this usually shows in Tekken 4 and 5, and i've tried different resolutions, PS2 Native too, but still nothing..

If there's any solutions to this, i'd really appreciate the help Smile
Reply

Sponsored links

#2
Soooo-- You're using Windows on that Mac? Or are you using the Max OS version of PCSX2?

What are the specs of said Macbook?
Reply
#3
I'm using Windows 7 64bit, it's a Intel Sandy Bridge 2.7GHZ Dual Core, the Graphics is an Intel 3000.
I did try out PCSX2 Mac but as that's based on an older version for now it only runs Tekken 5 at a good speed.

By the way, long as i can get any solutions to this, i'd appreciate it, not pointless rants on how i should 'get a gaming/better/windows laptop' or any other childish post.

Cheers Smile

EDIT: Conveniently, i've had a play round with Gsdx, and the gridlines have gone, so just 2 problems really Smile
Reply
#4
Hey, no worries, bud. Smile

- "Gridlines" -
You're getting thin black vertical lines with Tekken? Native resolution should not show them, as well as a custom resolution. I know 1024x1024 worked, and I think 1200x1200 works, too. I think the trick was not raising the second axis beyond a certain point (I think that was 1200), because I remember 1080p reversed worked.

- "Only hair is showing" -
This one confuses me. Are you saying that characters do not show, but their hair does...? Could you post a screen shot?

- "MGS3" -
I wonder if your Intel GPU is behind this. Maybe not, though.
With that flicker: Have you tried pausing, then resuming emulation (under the System menu)?
Could you post a screen shot of the "images run overlap" thing? Just curious to see, because I don't recall the issue right now.
Reply
#5
(08-25-2011, 10:32 PM)Rezard Wrote: Hey, no worries, bud. Smile

- "Gridlines" -
You're getting thin black vertical lines with Tekken? Native resolution should not show them, as well as a custom resolution. I know 1024x1024 worked, and I think 1200x1200 works, too. I think the trick was not raising the second axis beyond a certain point (I think that was 1200), because I remember 1080p reversed worked.

- "Only hair is showing" -
This one confuses me. Are you saying that characters do not show, but their hair does...? Could you post a screen shot?

- "MGS3" -
I wonder if your Intel GPU is behind this. Maybe not, though.
With that flicker: Have you tried pausing, then resuming emulation (under the System menu)?
Could you post a screen shot of the "images run overlap" thing? Just curious to see, because I don't recall the issue right now.

This is what it looks like in Tekken 4.

Metal Gear 3, i've definitely tried that, and once i resume the emulation, or even pausing the game and resuming, it flickers to the image and a black screen rapidly.

Thanks for the mature help so far Smile


Attached Files Thumbnail(s)
   
Reply
#6
Wow, that is messed up (Tekken 4). I'm definitely not getting that on my end.

Try some things in the Video (GS) settings.
  • Try software rendering. This will probably show everything, but may be slower.
  • Try switching to Direct3D9 if you're using Direct3D10 (or 11).
  • Maybe even give the hidden hacks a try. Not sure if the Alpha Hack or Offset Hack will fix it, but worth a try.

Beyond that, I'm not sure what to say right now. I do wonder if your GPU is some part of the issue (Intel's have been known to have some trouble in the past), but I can't be certain. Never seen this problem before (have you tried searching the forums?). See if any of those settings do anything for you. Smile
Reply
#7
(08-25-2011, 10:43 PM)Mirai89 Wrote: Attached File(s)

Hit F5 while in game to cycle between interlace modes.
Reply
#8
If the above doesnt help, try this for your hair problem http://forums.ngemu.com/showthread.php?t=91024

however i suspect putting your clamps on full for VU's will help this.

Failing that, use ZeroGS and configure it, ticking the box labelled "Disable Alpha Testing"
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
I was just about to add trying clamping 'n such. Laugh

So, Mirai89, is yours the PAL region then?
Reply
#10
I can't believe it, i just changed the plugin to Direct X 11 (software), and after changing the Threads to '2', everything works brilliantly now. Even in Metal Gear 2 where you have to sneak through the presentation on the tanker taking photos, full speed and graphics are perfect.
Metal Gear 3, flickering gone, if i go to turbo, it returns, but i'm happy with 42fps!
You sir, are a saviour! And not a 'Get a good graphics card lol' post anywhere!
Many thanks Laugh
And while i'm here, many thanks to the people making this emulator, you're all legends, through and through!
I look forward to the Mac port of this in good time!

Sorry for the double post, i've just seen the above 3 posts.
I've switched to hardware mode to try it out, and pressing f5 does nothing. Still the same moving wig from Kazuya and nothing else.

I've changed clamping to 'Extra' but still nothing.

And while using this mode, the flashing of MGS 3 returns.

I'm using USA BIOS and all games are also NTSC.
Reply




Users browsing this thread: 1 Guest(s)