Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
360 controller causing slowdown
#1
As the title says, when I play with a 360 controller, the emulator says I am getting 50-60 fps in various games (KH 1 and 2, God of War 1), but it plays very slow and looks like frames are skipping, and the audio is skipping. When I unplug the controller and use my keyboard, it runs very smooth and fast. I am using PCSX2 9.6.0 (however the same thing happens in the newest beta as well).

Here are my specs:
Windows Vista Home Premium 64 bit
8 gb DDR2 Ram
1 gb nVidia GeForce 120 (with latest drivers)
Intel Core 2 Quad
DirectX 10

Here are my settings: (Everything I'm using was included with the emulator)
Gsdx (SSSE3) - Direct3D10 Hardware, Native Resolution, No Interlacing, 4:3
SPU2-X - All default settings
Lilypad - Using 360 controller
Linuz ISO - All my games are in iso format
Bios - USA 2004 bios.

I would assume the other categories do not matter to simply play games.
Can anyone please help? Thanks in advance.

I really don't like playing games with a keyboard, and I simply don't understand how a controller is causing slowdown. It did this once when I played Fallout 3 as well, but its only done that once.
Reply

Sponsored links

#2
Scanario 1:
if you're playing on a keyboard the emulator runs at full speed?

Scanario 2:
(07-10-2009, 03:05 AM)Shadow2222 Wrote: Windows Vista Home Premium 64 bit----n/a
8 gb DDR2 Ram---That's too much
1 gb nVidia GeForce 120 (with latest drivers)----Fair
Intel Core 2 Quad----what speed???
DirectX 10---n/a

we lacking info a little about your CPU on what model of the C2Q and speed
and that video card is not quite strong it's a DDR2 video card....a GF 150 GTS or GF 250 GTS could be better as a GDDR3 video card.
in addition w/ Vista try disable windows aero(Control Panel-->[Switch to Classic view(upper left)]--->System--->Advanced settings[Upper Left]--->in performance category click "Settings"--->highlight the radio button "Adjust for best performance"
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
Thanks for your post, but I have now changed my topic title and post as I have discovered the true cause. Now could anyone help with that problem?
Reply
#4
(07-10-2009, 03:28 AM)Shadow2222 Wrote: Thanks for your post, but I have now changed my topic title and post as I have discovered the true cause. Now could anyone help with that problem?

well i'm getting a fast reply now that your main topic title has changed all a sudden.
and i'm sorry i can't analyse what reason of the 360 controller knock down your framerate.
could be the controller plug-in...did you try the SSXPAD plug-in??
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply




Users browsing this thread: 1 Guest(s)