Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
60 fps, but sometimes feel like 30
#1
Hello, I'm having this weird "issue" where games that run at full speed (without speedhacks, before anyone asks, I know some speedhacks tend to cause frame skipping and such), sometimes feel like they are running at 30, it's not constant, for instance, I did notice this more on Nightshade, every once in a while, around every 2-3 minutes, I get a period of choppiness, for a couple of seconds, then turns back to normal.

It also happens in software mode apparently, and as I said, the FPS and VPS always stay at 60, but they feel choppy. I've heard that my ati card could probably be causing this. I'm going to upgrade soon so I might go the nvidia route again..

My rig:

2500k
z68 extreme3 gen3
8gb ripjaws
hd 4870 (catalyst 12.6, tried with 12.4b, didn't change a thing)
Win7 Ultimate x64

Temps of every piece of hardware are alright, too, so you can rule that out.

Note: Weirdly enough I'm also experiencing the same problem with Dolphin (specially noticeable in Metroid Prime), obviously not related to this forum but might be good to write it here anyway.
Reply

Sponsored links

#2
It sounds like you have a background process kicking in for some reason. Have you tried turning it off?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Well I have actually tried with a "blank" windows installation, meaning I tried pcsx2 as soon as I set up the drivers. Unless it's something from Windows, but I have most of the "intrusive" stuff disabled, like firewall, defender and some other services too. I'm running MSE as my antivirus now, but it happens without it anyway.
Reply
#4
I've found that this user had the same problem http://forums.pcsx2.net/Thread-Choppy-fr...n-at-60fps

Unfortunately it seems that a solution was never found... I'm wondering if some of the onboard controllers on my motherboard might be causing this, namely the Realtek Onboard Audio and Realtek LAN.
Reply
#5
Check your CPU temperature.
Reply
#6
I'm having the same problem, I notice it the most in Tales of the Abyss.
Intel Core i5 3570k @ 4.4 Ghz
Asrock Z75 Pro3
Samsung 30nm 8GB DDR3
Radeon HD 6850
CM Hyper 212 Evo
Reply
#7
(12-26-2012, 08:20 AM)tuanming Wrote: Check your CPU temperature.

(12-25-2012, 03:29 PM)Mahrahia Wrote: Temps of every piece of hardware are alright, too, so you can rule that out.

...anyway, my temps are 33 idle low 50s load.
I have a 212+ with AC MX2 on the chip so temperature isn't a problem.
Reply
#8
Interesting. Just to make sure, try with preset 1 (leftmost), and if that doesn't work, uncheck 'Preset' and choose SuperVU for both VU0 and VU1 at the VU tab (all speedhacks still disabled).

Also, where did you see VPS on PCSX2?
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#9
I was told that the fps displayed by pcsx2 were actually the vps, so I kept dxtory around to watch the fps. I might be wrong though.

I'll try that.

Edit: The same happens with SuperVU and Preset 1.

I can record a video of the issue but I don't think it will be noticeable since youtube's 30 fps, unless I upload it elsewhere.
Reply
#10
(12-26-2012, 01:05 PM)Mahrahia Wrote: I was told that the fps displayed by pcsx2 were actually the vps, so I kept dxtory around to watch the fps. I might be wrong though.

I'll try that.

Edit: The same happens with SuperVU and Preset 1.

Indeed, the fps display in pcsx2 is actually vps.

Do the games play slower when it happens? or just lower fps but (relatively) same game speed? Also, did you see the real fps go below 30? Not all games render at 60fps - some games can get lower framerates sometimes, some render at 30fps, and some can even get lower than 30 occasionally (shadow of the colossus does that, for instance, on a real PS2).

So if the real fps generally doesn't go below 30, and the vps is at 60, that's probably just how the game works.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply




Users browsing this thread: 1 Guest(s)