Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A Problem with sound on Shadow Hearts.
#1
Specs:
Windows 7 64-Bit
AMD Phentom II x4 Black Edition - 3.22 GHz
4 GB of DDR3 Ram
ATI Radeon HD 5850 1 GB vram

Problem:
I have a small problem with the sound, on the first Cinematic video it shows the sound is not in sync with the video, the sound comes last after seeing the scene. How do I solve this problem, the video itself it's not slow or having any graphic problem, just the sound not keeping up.

PCSX2 Plugin:
PCSX2 0.9.7.3876
GSdx 3693 (MSVC 15,00, SSE2) 0.1.16
LilyPad svm (r3878) 0.10.0
SPU2-X r3702m 1.4.0
cdvdGigaherz (r3429) 0.8.0

Other:
I have search for my problem but did not get the right answer for my question, hence the reason why I made this topic.
Reply

Sponsored links

#2
If using speedhacks try reducing the EE cyclerate and/or VU cycle stealing since some games don't like them.
Shadow Hearts is one those games that may run better and even smoother under software rendering and your CPU has enough power to cope with this.
You can try tinkering with the "Synchronizing Mode" on the Sound Plugin configuration, but as far as I recall I didn't have problems with it.

Notice the above, about the software rendering, is not true for Shadow Hearts 2.
Imagination is where we are truly real
Reply
#3
(03-16-2011, 09:11 AM)nosisab Ken Keleh Wrote: If using speedhacks try reducing the EE cyclerate and/or VU cycle stealing since some games don't like them.
Shadow Hearts is one those games that may run better and even smoother under software rendering and your CPU has enough power to cope with this.
You can try tinkering with the "Synchronizing Mode" on the Sound Plugin configuration, but as far as I recall I didn't have problems with it.

Notice the above, about the software rendering, is not true for Shadow Hearts 2.

I forgot to point out that I was not using any type of game fix or Speed hacks, I've hardly don't need them unless it's required.

I've also search some threads that talk about that software rendering and I've done so already but however the sound is still not in sync with the video when i run though that, also I did set it to DirectX11 mode then DirextX9 software rendering.

i'll try messing with the synchronizing mode if it's available.

edit: Synchronizing Mode is useless, it didn't do no affect at all and still having sound not in sync to the video.

this is Shadow Hearts 1 that i'm talking about not 2 or 3.
Reply
#4
What is the FPS you're getting? what are the EE and GS loading values?

Are you running from a ISO or directly from the physical disc?



Imagination is where we are truly real
Reply
#5
(03-16-2011, 11:12 AM)nosisab Ken Keleh Wrote: What is the FPS you're getting? what are the EE and GS loading values?

Are you running from a ISO or directly from the physical disc?

i'm running from an iso, 50-65 fps, EE 60-75% GS 5-10% UI 0-5%

Edit: After messing around, I got the sound in sync for a second, but now it's a bit too fast, i've decrease the FPS by 59.00 instead of 60.94, but halfway on the video, the sound gone a bit to fast, trying to figure out how to make it all in sync without problems.
Reply
#6
One thing you could try is tweaking the latancy slider in the spu2x settings, this is set to a reasonably high value to cope with poor sound cards, if you have a reasonable card you should be able to move the slider to the left a bit without experiencing any crackling. Have a play, it should help
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(03-16-2011, 01:33 PM)refraction Wrote: One thing you could try is tweaking the latancy slider in the spu2x settings, this is set to a reasonably high value to cope with poor sound cards, if you have a reasonable card you should be able to move the slider to the left a bit without experiencing any crackling. Have a play, it should help

my sound card is mostly on board when I got my computer, and it's one of those AMD High Definition Audio devices, and don't have a problem with most new and modern games with that sound card. I've been testing it, and usually right now it's around 77 on the latency bar.
Reply
#8
Comparing PC apps with the emulator is a bad idea. Unfortunately, unlike proper PC games, we cant get the information early enough, not without causing sound glitches anyway, so we need to have a latancy slider in there.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
your FPS is varying too much. The other thing that takes apart PC games from console is in this last the FPS must be steady at least and closer the adopted TV standard as possible.

NTSC games should run a 59.94 FPS and PAL at 50

tick off (unmark it) the "Disable Frame limiting" under the GS tab at "Emulation settings"
Disable frame skipping if being used. If after all the FPS becomes low you should try the recommended speed hacks.

PS: Tinkering with defaults other than speedhacks must be the last thing to try, when despair got the better over us, since is too much game dependent to be left as constant setup.

Finally, do not rely on the synch coming by miracle from a sstate too... you must restart the game from the beginning or from the memcard.
Whatever error or corruption is made "eternal" in sstates (which is a sample of the memory at the given instant).
Imagination is where we are truly real
Reply
#10
(03-16-2011, 07:37 PM)nosisab Ken Keleh Wrote: your FPS is varying too much. The other thing that takes apart PC games from console is in this last the FPS must be steady at least and closer the adopted TV standard as possible.

NTSC games should run a 59.94 FPS and PAL at 50

tick off (unmark it) the "Disable Frame limiting" under the GS tab at "Emulation settings"
Disable frame skipping if being used. If after all the FPS becomes low you should try the recommended speed hacks.

PS: Tinkering with defaults other than speedhacks must be the last thing to try, when despair got the better over us, since is too much game dependent to be left as constant setup.

Finally, do not rely on the synch coming by miracle from a sstate too... you must restart the game from the beginning or from the memcard.
Whatever error or corruption is made "eternal" in sstates (which is a sample of the memory at the given instant).

my saves are in the memcards, i've always save originally from the memcards. I sometimes do get a drop of FPS rating, my usual rating is usually around a 60 fps like normal, and sometimes I get a fps drop of 40 fps, and it rise back up. It happen to me alot when I was playing .hack//G.U. Vol 1, 2 and 3. I figured that it might be related to graphics cause it will ease if I don't look at the most heavy graphical area like mac anu front entrance or looking at one of the news capture bulletin that FPS drops in the middle of most page. I might use those speed hacks as long as it don't go above 65 fps.

Reply




Users browsing this thread: 1 Guest(s)