Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A few problems
#1
Basically, I've been having a lot of issues with the PCSX2 and Suikoden IV.

Thankfully, the amazing search button helped me figure out and solve all of the major problems and all but two minor problems.

One of the problems is shadow rendering. As you can see in the picture, the graphics plugin renders the shadow like an aura surrounding characters and stretching to the ground in a triangular fashion.

[Image: SuikodenIVShadow.jpg]

In any case, I tried using other plugins, but I still encounter similar problems. A few other plugins remove shadows in their entirity; which is not what I want. Perhaps I'm being too picky, but I've seen other PS2 games with amazing visuals and normal shadows, so if this is solvable why not.

The second minor issue has to do with the sound. Every few moments the sound would fuzz up; making character voices, backround music sound electronic.

Here are the relevent plugin details and the cpu configuration.

[Image: Plugins.jpg]

[Image: CPU.jpg]

I tried a few things including switching the output audio module around, but nothing really helped. I'm stumped.
Reply

Sponsored links

#2
a) Try turning off VU0 under CPU setting and see if it helps. If not - nothing you can do about shadows

b) if changing audio plugins did not help - most likely nothing you can do too, but I'm not sure.
Reply
#3
(05-01-2009, 07:58 AM)Cain Wrote: a) Try turning off VU0 under CPU setting and see if it helps. If not - nothing you can do about shadows

b) if changing audio plugins did not help - most likely nothing you can do too, but I'm not sure.

(a) didn't work. =/

(b) also didn't really help.

I appreciate your input. Worst case scenario, I'll live with it. Hopefully someone else can think of something that hasn't been mentioned.
Reply
#4
Hi,

Quote:In any case, I tried using other plugins, but I still encounter similar problems. A few other plugins remove shadows in their entirity; which is not what I want. Perhaps I'm being too picky, but I've seen other PS2 games with amazing visuals and normal shadows, so if this is solvable why not.

What plugins did you use to entirely remove the shadows?
I tried different versions of gsdx (hardware mode) but the shadows problem still exists.
However in gsdx software mode there are no shadows but the game does not look good.
Also, ZeroGs doesn't display shadows but the game is slower than with gsdx.

Is there a way to remove shadows (a patch maybe?) and still stay with gsdx in hardware mode?
Reply
#5
It probably doesn't matter, but did you try using Xaudio instead of direct sound?
http://www.twitch.tv/krazytrumpeter05
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
Reply
#6
Hi,

(05-24-2009, 06:26 PM)KrazyTrumpeter05 Wrote: It probably doesn't matter, but did you try using Xaudio instead of direct sound?

I already use XAudio mode in SPU2-X 1.1.0 sound plugin.
Using ZeroSPU2 causes the sound to be static.

Anyway, changing the sound plugin or sound settings didn't help but thanks for the reply.
Reply
#7
just change renderer setting in gsdx from direct3D(hardware) into direct3D(software).
Reply
#8
i tested it yesterday and got the same problem as you. if you used software mode, it's gone but the game becomes unplayable with 20-40 fps. i tried the latest zerogs and the shadow is gone, but it's a bit slow compared to gsdx. with gsdx i could get about 90-100 fps if i wanted to speed things up, but with zerogs i could only get 60-70 fps.
CPU: Intel Core2Duo E7400 @ 2.8GHz
GPU: ATI Radeon HD 4670 512MB
RAM: 2GB DDR-2
OS1: Windows XP Professional (x86) SP3
OS2: Windows Vista Ultimate (x86) SP1
Reply




Users browsing this thread: 1 Guest(s)