Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A slight graphical issue with Dot hack GU Vol 1
#1
I am having rather odd graphical issue with dot hack GU vol 1, while it doesn't really interfear with gameplay its semi annoying here is a screenshot, i'll circle in red what I mean. Before you say it, no its not the shadow. Mind you pcsx2 seems to have massive issues when it comes to rendering shadows, they never seem to work properly in any game.

[Image: pcsx2r46002011110611314.jpg]

Uploaded with ImageShack.us

Its like.. they are triple shadowed or something, and this shadow thing is always on the left side of every npc, object etc. I've messed with settings to try to fix it but I haven't figured out a fix yet. Speed Hack's are off, Res is 3x native, tried dx10 and dx9 plugins it happens on both, tried using ps2-like filtering, and then the normal one. Anything else I can try? It doesn't interfear with gameplay but it does tend to make my eyes water after a while.
Reply

Sponsored links

#2
One of the following may fix that:
  • Software rendering
  • Native resolution
  • the Alpha hack
  • the Offset hack
  • Skipdraw set to 1, 2 or 3
The last three are hidden hacks in GSdx.
To enable them, add the following to the bottom of your GSdx.ini file:

allowhacks=1
Reply
#3
Skipdraw did nothing, alpha hack did nothing, Offset hack makes that shadow thing come out from the center insted of from the left side. I guess thats a bit better. Native res doesn't fix it either. Neither did software rendering. Skipdraw doesn't seem to effect it I tried from 1 to 15. Oh well i'll just have to get used to it I guess.
Reply
#4
Did you try the GSDX in latest SVN. or the one from pcsx2 0.9.7 r3113
[Image: recodersignature2.png]
Reply
#5
It's just a post-processing effect in the game, the particular error you show is from using a high resolution than the game is supposed to and moves it to a side, both native resolution and software res show as it is in the PS2 (software mode the only one that has the shadows showing right at it) and as you said "offset hack" simply puts the post-procces effect closer to the right place when using high resolution.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
Looks a bit like Bloom, which there was a way I could possibly shut it off using pcsx2. Its really annoying me. I usually shut bloom off in pc games as well because all it seems to do to me is make everything go blurry.
Reply
#7
use skipdraw.

Edit gsdx.ini i think add the line "Userhacks=1" and "Skipdraw=1"

Actually I can't remember but its in one of the guides.

oh if skipdraw did nothing, then chances are you haven't enabled userhacks.

edit: skipdraw should always do something, because it will skip an entire layer of drawing, usually it starts at the layer which adds shadows and reflections, then it moves to some other layers but if you skipdraw up high enough you can remove entire textures too. People will have black faces and so on. So overall skipdraw should never do "nothing".
Reply
#8
Well if it does something in dot hack GU I don't notice it, I know in fronmt mission 5 I had to set skipdraw to 2, in order to get this horrible texture off the screen that looked like someone puked brown stuff all over my screen. Well I tried skipdraw hack 0-15 and none removed it. I know skipdraw works because it worked with just Userhacks=1 in front mission 5 and another game. Hrmm I guess I am just stuck with this I guess. Maybe it won't be on vol 2, I am almost done with vol 1
Reply
#9
you have to write

allowhacks=1

to get it working.
[Image: recodersignature2.png]
Reply
#10
(11-08-2011, 10:57 AM)skythra Wrote: use skipdraw.

Not all games are affeced by that setting, this being one of them apparently.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)