Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A story about a DualShock dual-adapter with a bit of trouble mixed in

So one sunny day I ordered this DualShock -> USB adapter (and controllers) from Ebay and today they arrived. I was so excited that I'd finally be able to play Crash Bandicoot with my... friend, who loves these kind of games. So I plugged it in and what do you know, it installed without giving me any trouble. Incredible, I know. But then... I opened the settings panel. And tried fiddling with the controller keys. Well... you can't have everything I guess.

The controllers seem to be polled only every 1-20 seconds, which makes playing games with them... shall we say... challenging?

When I press any key or direction quickly, it doesn't register at all. When I hold a key down, it takes a long time before it is registered by software (Windows / PCSX2 settings). And when I release it, the same. The input is not queued, but just polled very slowly.

The adapter is Shenzen Dilong PU203
Motherboard is Asus M3A32-MVP Deluxe

These are the things I've tried so far:

- 64-bit Windows 7 and 32-bit Windows XP
- Both built-in drivers and manufacturer provided
- Different BIOS settings
- Taking all other USB devices out and using PS/2 keyboard

but the behaviour is still the same.

I'm making an educated guess saying that the motherboard is at fault here. You may prove me wrong if you like.

It does work properly on my laptop, which has an Intel-board.

Anyone know what is going on? Help is appreciated.

Sponsored links

Users browsing this thread: 1 Guest(s)