Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AMD Athlon 64 X2 4800+ FFX Performance
#1
Hi. Tongue

I have about two days trying to configure PCSX2 to get decent framerates playing Final Fantasy X

Specs:
Processor: AMD Athlon 64 X2 4800+
Ram: 4GB (Mushkin 4x1GB DDR2 800)
Graphics: Nvidia 8800 GT Supercloked
Motherboard: Biostar

My real question is: Can I play Final Fantasy X and X-2 with this specs at normal speed?. I have FFX NTCS US (SLUS 20312) and FFX-2 PAL (SLES 51815) using the lastest version of pcsx2.

I'm experiencing FFX-2 slow cut-scenes with a big black stripe (sometimes white) (bottom of the screen)

Thanks in advance
Reply

Sponsored links

#2
FFX there should be no problem, I ran it on a 3600+ x2 at 2.3ghz at full speed.

X-2 on the other hand will probably NOT run full speed.

Make sure you're using the latest beta PCSX2 for both games and try enabling several speed hacks (including cycle rate x2, INTC, and Idle Loop Fast Forward)
[Image: 2748844.png]
Reply
#3
you will be able to get good speeds with speedhack x2
[Image: 1454055.png]
Reply
#4
(09-04-2009, 06:34 PM)Koji Wrote: FFX there should be no problem, I ran it on a 3600+ x2 at 2.3ghz at full speed.

what? when i still had 5600+ overclocked to 3.1ghz i was getting avarage 70-80% speed and it was unplayable due to crazy sound effects and slow gameplay ;p
Check my profile for hardware/software and games i played on PCSX2.
Reply
#5
o_O You had that problem in FFX? I think the community is in agreement that FFX is one of the easiest 3d games to emulate, and indeed it ran perfectly fine before and after my processor upgrade.
[Image: 2748844.png]
Reply
#6
(09-04-2009, 08:52 PM)nataq01 Wrote:
(09-04-2009, 06:34 PM)Koji Wrote: FFX there should be no problem, I ran it on a 3600+ x2 at 2.3ghz at full speed.

what? when i still had 5600+ overclocked to 3.1ghz i was getting avarage 70-80% speed and it was unplayable due to crazy sound effects and slow gameplay ;p
Using beta 1474, dx10 hardware mode,without using any speedhacks my 7850 @3.07 ghz also ran the game around 7-80%, but when I turned on only the Idle Loop Fast-Forward, I got 99%.
AMD Athlon II 245 @ 3.55ghz, 9600GT @730mhz 1115mhz, vista sp2 32bit
Reply
#7
hey thanks for the replies, I was doing some testing with the latest beta and I'm able to play FFX at 50-60 fps most of the time with the speed hack, and seems to do fine.

I still have some kind of troubles in FFX-2. When I'm inside the bridge of Celsius with the rest of the crew, the fps drops to 30-35 fps (slow), the other sections of the airship are normal speed 50-60 fps, and when I'm triying to go back to the bridge, approaching... and you are 4 feet from the door, you get a huge slowdown and I'm not even inside de bridge (I guess it loads all the bridge data in that coordinates Wacko before you enter. well, I'm going to tweak and tweak... and see what happens.
Reply




Users browsing this thread: 1 Guest(s)