Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ATV Offroad Fury 2 issues
#1
I did a lot of research before deciding to come here, as nothing I found solved my problem.

Now I know about the issue with water and polygons being messed up in hardware rendering, so switch to software rendering, simple. Except that doing that causes the game to run extremely slowly, about half speed. Now I can fix that by changing the EE Cyclerate to 3 and the VU Cycle Stealing to 3, and the game will then run at the proper speed, but the problem is that doing this severely kills my FPS in game. It will say I'm hitting 60 FPS but looking at it, it seems to be running at about 15 FPS, very choppy.

I'm hoping someone may have an alternate solution. I love this game and used to play this with my parents all the time as a kid. I've tried so many different combinations of settings with no effect so far. Also great work on PCSX2, it's working wonders for all my other PS2 games so far.

My Specs:

Windows 7 Home Premium 64bit
i7-950 4.0Ghz
GTX 680
16 GB's DDR3 1600Mhz RAM

Using the latest PCSX2 1.2.1
Reply

Sponsored links

#2
go to config>video>plugin settings and set 2 or 3 extra rendering threads. Also, turn down the speedhacks as they can cause false fps readings.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
What are the ee and gs values during slowdowns ? And, make sure to set windows power plan to high performance to use the full potential of your processor
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#4
(01-04-2015, 10:27 PM)Nobbs66 Wrote: go to config>video>plugin settings and set 2 or 3 extra rendering threads. Also, turn down the speedhacks as they can cause false fps readings.

Turning the speedhacks down only causes the game to run too slow again. Tried setting 2 to 3 extra rendering threads but little or no effect.

(01-05-2015, 06:13 AM)ssakash Wrote: What are the ee and gs values during slowdowns ? And, make sure to set windows power plan to high performance to use the full potential of your processor

I'm not on a laptop, I'm on a desktop. If I have all the speedhacks off (causing the slow down), EE is around 90% while GS is around 50%

If it matters, in freestyle mode the game is much smoother since it's only me driving around. But if I do a race, all the other vehicles cause the game to get super choppy/low FPS (this is with speedhacks on). with speedhacks off, the game runs very smoothly indeed, just at half the speed, and my framerate says 30 FPS.



EDIT:

Ok, setting the extra rendering threads to 3 allows me to drop the EE Cyclerate hack to 1 and the VU Cycle Stealing hack to 1, and achieve proper game speed with a much smoother FPS, looks to be about 30 now which is definitely more playable. Not 60 FPS unfortunately but at least this is much more playable now. EDIT 2: only 3 extra rendering threads would cause the game to freeze for a second every now and then, so I just maxed out rendering threads at 16 and the freezes seem to be gone. Probably overkill but playing it safe =P
Reply
#5
(01-05-2015, 02:59 PM)Shivaxi Wrote: Turning the speedhacks down only causes the game to run too slow again. Tried setting 2 to 3 extra rendering threads but little or no effect.


I'm not on a laptop, I'm on a desktop. If I have all the speedhacks off (causing the slow down), EE is around 90% while GS is around 50%

If it matters, in freestyle mode the game is much smoother since it's only me driving around. But if I do a race, all the other vehicles cause the game to get super choppy/low FPS (this is with speedhacks on). with speedhacks off, the game runs very smoothly indeed, just at half the speed, and my framerate says 30 FPS.




EDIT:

Ok, setting the extra rendering threads to 3 allows me to drop the EE Cyclerate hack to 1 and the VU Cycle Stealing hack to 1, and achieve proper game speed with a much smoother FPS, looks to be about 30 now which is definitely more playable. Not 60 FPS unfortunately but at least this is much more playable now. EDIT 2: only 3 extra rendering threads would cause the game to freeze for a second every now and then, so I just maxed out rendering threads at 16 and the freezes seem to be gone. Probably overkill but playing it safe =P

The extra rendering threads are useful only in sofware mode. I can't say for sure but that may be one those hard to emulate games,

You may want try VU cycle stealing 2 notches (observe if no lag is introduced). On the other hand you can try toggling MTVU (disable it if active or disable it otyerwise and test).

Finally you have a good video card, what may be the actual "problem", I mean, relying in the card power and experience with PC games the user may abuse the upscale and other video options and make the emulation very sluggish. Make sure there is no fancy thgings as MSAA and such active while tuning the emulator.
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)