Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Abnormal speeds when starting and choppy sound need help :(
#1
Hey guys wondering if i could get some assistance.

My specs:
RAM: 3GB DDR2
CPU: Intel Core 2 Duo E6600 2.40Ghz
GPU: GeForce 8600 GTS
OS: Windows XP Home edition SP2

PCSX2
Graphics: GSdx 890 (MSVC Graphics 15.00 SSE2) 0.1.14
Sound: P.E.Op.S. SPU2 1.9.0
Game: Shin Megami Tensei: Persona 4

I've tried throwing around a few things and some how manage to get a decent frame rate of 40+ but problem is that when i did that the sound was so choppy and screwed up that it was unplayable. Now sometimes when i load the game it loads at 60Fps normally and then when i try changing the settings it jumps to 300Fps or more. I'm really new to this stuff so if you can have some mercy on me that would be great.

Sponsored links

#2
Well, there's no magic rule to get the best of PCSX2 with every game, but there's some things to try.

First, some games works better with ZeroGS rather than GSdx so you may try both to check what's better for that game emulation. In these plugins setup try the default settings to check graphic performance before tuning settings.

What else? In the CPU side you should enable MTGS to improve the performance with a dual core processors like yours and choose to limit the frames per second (0=auto) to avoid the emulation could go too much fast.

PEOPS audio plugin should work fine with every kind of game but you can try ZeroSPU 0.4.6 if you think the first one isn't working properly. By the way, is very usual that sound isn't going perfect when the game has slowdowns because it must be slowed to keep up the emulation and that generate some weird sounds. A slowdown is anything under 60fps in NTSC or PAL60 games and 50fps in PAL games.
#3
(02-03-2009, 07:43 PM)Dr_X Wrote: Well, there's no magic rule to get the best of PCSX2 with every game, but there's some things to try.

First, some games works better with ZeroGS rather than GSdx so you may try both to check what's better for that game emulation. In these plugins setup try the default settings to check graphic performance before tuning settings.

What else? In the CPU side you should enable MTGS to improve the performance with a dual core processors like yours and choose to limit the frames per second (0=auto) to avoid the emulation could go too much fast.

PEOPS audio plugin should work fine with every kind of game but you can try ZeroSPU 0.4.6 if you think the first one isn't working properly. By the way, is very usual that sound isn't going perfect when the game has slowdowns because it must be slowed to keep up the emulation and that generate some weird sounds. A slowdown is anything under 60fps in NTSC or PAL60 games and 50fps in PAL games.

Hmm I found another post about a person having the same problem as me on Persona games and I tried out the playground and my FPS is a lot better now im doing 51-57 FPS but when I'm on the menu or a screen with not that much activity like entering my name or saving it runs at 200+ fps

here's the thread: http://forums.pcsx2.net/thread-3442.html

I didnt do the Speedhacks because my game runs fine with out it. problem is trying to get it not to run crazy speeds above normal.
#4
Just enable the frame limiter in the CPU config.
Reading the OFFICAL GUIDE can answer 90% of your newbie questions
SEARCHING the forums can answer 90% of your advanced questions.
#5
(02-03-2009, 08:02 PM)VeaaC Wrote: Just enable the frame limiter in the CPU config.

awesome there we go that fixed that here's another problem I'm getting with the graphics. I've been trying to look over how to configure my settings to the right specifications but like i mentioned i don't much about setting these kind of things up. I posted a screen shot of what it looks like so far.


Attached Files Thumbnail(s)
   
#6
(02-03-2009, 08:13 PM)Rollen Wrote:
(02-03-2009, 08:02 PM)VeaaC Wrote: Just enable the frame limiter in the CPU config.

awesome there we go that fixed that here's another problem I'm getting with the graphics. I've been trying to look over how to configure my settings to the right specifications but like i mentioned i don't much about setting these kind of things up. I posted a screen shot of what it looks like so far.

yeah we got same prob here, i think i dont have a lot of RAM/video card.
i guess ill have to buy one. but if the prob is still the same, i dunno whats wrong anymore.
***********************************************

-=FLESH IS WEAK=-
RF Online: w/c side are you on?
Accretia. - Accretian Empire
Bellato. - Union of Bellato Federation
Cora. - Holy Alliance of Cora

***********************************************
core2dou




Users browsing this thread: 2 Guest(s)