Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ace Combat series 4, 5, and Zero low performance
#1
I have the latest pcsx2 1.2.1 and I was wondering why my computer can't handle Ace Combat 4, 5, Zero. Before I had a Intel Core 2 Duo and an old Nvidia Card (which only had Black Lines in the screen) and it lagged badly.I avg about 32 FPS (Hardware mode: 50 for PAL 60 for NTSC). Frameskipping in turbo mode (if enabled) helps but I get really annoyed by how laggy it feels. Below are My Specifications and Configurations ( everything not listed is left on default settings)

Computer Specifications:
Processor: AMD FX 8350 @ 4.0GHz non OC'd
Ram: 8 GB
Graphics Card: MSI AMD HD6670-MD1GD5
Hard Drives: Western Blue 300GB @ 7200RPM

Enabled Speedhacks:
EE Cyclerate at 1
VU Cycle Stealing at 0
INTC Spin Detection
Wait Loop Detection
mVU Flag Hack
MTVU

(Might Help) FrameSkipping Options:
Enabled only when in Turbo Mode
Frames to Draw: 2
Frames to Skip: 1

Video Plugin Settings:
Renderer: DX11 Software
Extra Rendering Threads: 7
Enabled Edge Anti-Aliasing (AA1)
Reply

Sponsored links

#2
As far as I know there are innate problems with the Ace Combat games with PCSX2 where they require very high end CPUs to run at full speed. Also, AMD CPUs are sadly not ideal for getting the best performance on PS2/GCN/Wii emulation, although I'm not sure this matters in this case since you're using software mode.

Perhaps someone else can point out the level of CPU needed to run them at full speed.
Reply
#3
(07-25-2014, 06:33 PM)BlackTelomeres Wrote: As far as I know there are innate problems with the Ace Combat games with PCSX2 where they require very high end CPUs to run at full speed. Also, AMD CPUs are sadly not ideal for getting the best performance on PS2/GCN/Wii emulation, although I'm not sure this matters in this case since you're using software mode.

Perhaps someone else can point out the level of CPU needed to run them at full speed.

Software mode uses CPU to render apposed to Hardware whereas that uses GPU. There is a shocking difference in graphics card between Nvidia and AMD. Nvidia has black lines across the emulation and AMD has Corrupted textures at a far distance. Anyways I can agree that AMD cpu's aren't the best for emulation but just being able to use the full power of it in pcsx2 would make performance alot better (pcsx2 officially supports 2 cores, not really using more than to 2 cores for emulation)
Reply
#4
Wait wait wait wait, this thread is loading with too much BS

1) Black lines in the screen are due to custom resolutions. Use Native one to get perfect image Fixed!
2) Corrupted textures in the distance are due to mipmaps not implemented in the hardware render. It's absolutely no AMD fault Implemented!

3.1) Ok.. My crappy dual core just do 22FPS in software mode.. my -big- bad

Did you tried to disable edge AA?

EDIT: and don't forget to check (test?) the allegedly progressive patch
There's still only a single bug left afaik.
Reply
#5
(07-25-2014, 08:47 PM)mirh Wrote: Wait wait wait wait, this thread is loading with too much BS

1) Black lines in the screen are due to custom resolutions. Use Native one to get perfect image
2) Corrupted textures in the distance are due to mipmaps not implemented in the hardware render. It's absolutely no AMD fault
3) I get 40 FPS (PAL) with my crappy core 2 duo @3ghz with software renderer... (games is perfectly smooth then with hardware one) why your 8 core should perform worse?

Did you tried to disable edge AA?

Yeah I tried turning that off, not much a difference.

EDIT: Maybe my configuration is messed up, also PCSX2's performance is based off of single core performance, not multi-core
EDIT 2: Also Intel has better performance over AMD anyways
Reply
#6
set your number of extra software threads to 6 or 7 and try the MTVU speedhack for extra speed.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(07-25-2014, 08:50 PM)FQuimson23 Wrote: Yeah I tried turning that off, not much a difference.

EDIT: Maybe my configuration is messed up, also PCSX2's performance is based off of single core performance, not multi-core
EDIT 2: Also Intel has better performance over AMD anyways

It would even be better when it matters of VU and clamping performance and so on... but rendering is a really parallelized task, and 8 cores should do it very well
Reply
#8
(07-25-2014, 09:58 PM)refraction Wrote: set your number of extra software threads to 6 or 7 and try the MTVU speedhack for extra speed.

Just tried it and without turbo enabled for frameskipping: 35 FPS (7 extra rendering threads) and with turbo enabled for frameskipping: 50 FPS With screen shaking and sluggish controls + gameplay
Reply
#9
(07-25-2014, 11:29 PM)FQuimson23 Wrote: Just tried it and without turbo enabled for frameskipping: 35 FPS (7 extra rendering threads) and with turbo enabled for frameskipping: 50 FPS With screen shaking and sluggish controls + gameplay

Well... screen shaking can be fixed with deinterlacing (F5) whilst sluggish controls.. well adjust them
They are perfect imo, with a DS3... then if you are using the keyboard I would suggest:
WASD for throttle and yaw
Arrows for pitch and rudder
Space for machine gune
NUM 0 for missiles
Mouse as right analog stick (view)
And what's then? Radar and change view button? as you wish
Reply
#10
(07-26-2014, 12:52 PM)mirh Wrote: Well... screen shaking can be fixed with deinterlacing (F5) whilst sluggish controls.. well adjust them
They are perfect imo, with a DS3... then if you are using the keyboard I would suggest:
WASD for throttle and yaw
Arrows for pitch and rudder
Space for machine gune
NUM 0 for missiles
Mouse as right analog stick (view)
And what's then? Radar and change view button? as you wish

I use DS4 mostly and any frame rate under 40 gives the game sluggish controls just like it is in Ace Combat Assault Horizon. All controls are fine in Hardware mode, no need for turbo mode and controls feel responsive and fast. Anyways I think I'll just deal with messed up textures (for now) and see if it'll be fixed soon (yes, I know its hard work to fix this issue)
Reply




Users browsing this thread: 1 Guest(s)