Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Analog controls not working
#1
so, i was messing around with the lilypad config and the analog controls don't work. i dont have any controllers except a fight-stick (which is kind of awkward to use on fps games). every key functions normally. the only problem is the analog controls don't work. for example, i bound W A S D as the left analog stick and J N M , as the right analog stick. all the other keys function normally, the triangle, square, circle, cross, d-pad, etc.

at one point, i actually got the analog controls working. once it started working properly, i didnt even touch the configurations after. then, on restart, i tried to play socom but the analog keys stopped working. the configurations never change. i'm already running pcsx2 as an administrator. i've already tried the analog button and still it doesnt work. i've searched online and couldnt find the solution

my friend said he also had this problem, where the analog keys worked fine at one point, and then it stopped working.
Reply

Sponsored links

#2
Try to change the keyboard's API in the lilypad settings, see if it makes a difference. Try both Raw Input and Direct Input (you'll have to rebind your keys for each API).
Reply
#3
press the "analog" button
Reply
#4
(04-17-2012, 10:42 AM)Saiki Wrote: press the "analog" button
better yet, assign a key for the "analog" button, like "]"="analog", that way you don't have to go into config to turn it off or on+^_^+
Signature purposefully left blank.
Reply
#5
(04-17-2012, 04:01 PM)ChikTikka Wrote: better yet, assign a key for the "analog" button, like "]"="analog", that way you don't have to go into config to turn it off or on+^_^+

that's what I meant..

mine's M
Reply
#6
yea i guess i forgot to mention that. backspace is my analog button and it doesn't help.

i also tried changing the raw and direct input, etc.

i'm not sure what i did that fixed it, but it was working for one session only. then it stopped.
Reply
#7
(04-17-2012, 10:44 PM)armand Wrote: yea i guess i forgot to mention that. backspace is my analog button and it doesn't help.

i also tried changing the raw and direct input, etc.

i'm not sure what i did that fixed it, but it was working for one session only. then it stopped.
i tried having stuff on backspace (i don't know why backspace failed me), but it didn't work so i moved mouse to "=" and analog to "]" so try that and let us know+^_^+
Signature purposefully left blank.
Reply




Users browsing this thread: 1 Guest(s)