Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Another Kingdom Hearts II/FM+ Configuration Thread
#1
Alrighty, please listen. I've had this game run perfectly fine in HD w/ shade boosting/3-4x native resolution in the past, but today seems to be quite different. No matter what I do, I CANNOT get KH2 to run at the perfectly playable speed that I once had it at before. My PC is updated, Direct X is latest, and I'm almost positive that my setup is good enough to run this game (did I mention I've done it before?). I hadn't played it in a while, so I decided to download a more recent SVN (PCSX2 1.3.0.5907) and then the problems began to happen. Yes, I've tried rolling back to previous SVNs and other builds of the emulator, and yes, I've tried virtually every combination of speedhacks I know of, but to no avail. I want to make this as easy for you guys to figure out as possible. My rig specs are as follows:

------------------------------------
OS: Windows 7 Ultimate 64-bit (6.1, Build 7600)
CPU: AMD Phenom II X4 B55 (4CPUs), ~3.6GHz (OC'd from 3.3GHz)
GPU: EVGA/NVIDIA GeForce GTX 660 SC (SuperClocked) 2GB GDDR5
RAM: 8192MB/8GB Hyper X (Kingston)
Direct X: DirectX Version 11


-------------------------------------

I'm running out of options. My main benchmarks right now are the Sephiroth Battle (his Meteor Shower attack used to never hitch, and ran at full speed with no stutters-- better than the PS2), and the 1000 Heartless Battle. I even tried running the emulator with complete default emulation configuration @ native resolution and STILL, I get stuttering and framerate drops that should not be there. I am running no other programs in the background other than CPU-Z when I wanted to see my CPU's performance during play. Below you will find pictures of my settings. I have EE Cycle and VU Cycle set to 1 & 0 respectively, since they seem to make no difference what so ever. I also have the default, recommended speedhacks turned on. You may notice that the 'custom window size' is at 1280x720. It just says that from when I previously configured it, because I'm clearly not running the game at that resolution.

-------------------------------------

[Image: bLAou2v.png]

[Image: eMq7g5k.png]

[Image: zpCN3vH.png]

[Image: TlQ3o9T.png]

[Image: DRjmqPK.png]

[Image: XVIZDYH.png]

[Image: uCxXeS8.png]

[Image: LWPBwbB.png]

And, a basic startup log:
[Image: d76eKt2.png]

------------------------------------------------


I honestly can't figure it out. I've ticked just about every setting that's available to tick (one-by-one), tried all sorts of different speedhack combinations, EE/IOP/VUs changes, etc. What frustrates me is knowing that I've had it working FLAWLESSLY in the past. Audio isn't an issue unless the stuttering/lag/framerate drops begin. Last time I played it, I'm pretty sure I was running it in 1280x720 3x native resolution via VGA. I'm on VGA currently, as well. What leads me to believe there's something more wrong than the power of my computer is the fact that it acts just as silly in native as it does in higher resolutions. I can get up to at least 50~55FPS, but it rarely goes higher, and goes much lower at seemingly random moments (small groups of enemies, jumping around, etc). It tends to bog down the most when I'm walking around in the Marketplace (Hollow Bastion), and against Sephiroth's Meteors (or even simply standing behind Sephiroth prior to the actual fight).

I think what pisses me off the most is the basic, inescapable frame stuttering. It's constant when Sora just walks around or if I piddle the camera in circles. I've tried enabling/disabling vsync, too. Makes no difference. I have no individual graphical glitches, nor sound bugs; it's all related to the FPS and the accompanied stuttering.

Whoever can figure out why the hell this is going on, and help me get the game back to full 100% speed, I commend you, and will bake you cookies.

I wish I was joking.

(Thanks for those who can help, or at least attempt to try~)
Reply

Sponsored links

#2
First of all use direct3d11 hardware.

Also what are your cpu and gpu temps while playing
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
(08-06-2014, 12:15 AM)Nobbs66 Wrote: First of all use direct3d11 hardware.

Also what are your cpu and gpu temps while playing

[Image: dm4UQjj.jpg]
Reply
#4
Try updating graphics drivers, check fans for dust, check for background memory hogs, both ram and vram ones, try the latest official release as they tend to be slightly faster than svns
Reply
#5
Were you running at 3x native in that screenshot
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#6
(08-06-2014, 12:32 AM)Rassane Wrote: Try updating graphics drivers, check fans for dust, check for background memory hogs, both ram and vram ones, try the latest official release as they tend to be slightly faster than svns

My graphics drivers are up to date, I dusted my computer yesterday, I've tried using GameBooster to eliminate any useless background processes, and no difference. I've also tried playing on the latest official release. Done all that.

(08-06-2014, 12:37 AM)Nobbs66 Wrote: Were you running at 3x native in that screenshot

Not at all. You can even tell it's not 3x native. It's in PS2 native, as the pictured settings show. I simply changed to D3D11, like you said, which made no difference.
Reply
#7
Did anything change since it stopped working fluently? Also try checking for malware/viruses, Gamebooster can't stop those
Reply
#8
(08-06-2014, 12:42 AM)Rassane Wrote: Did anything change since it stopped working fluently? Also try checking for malware/viruses, Gamebooster can't stop those

Nothing's changed, and my PC is as clean as I can get it. I clean it once every two weeks via Nod32, Malwarebytes, etc.
Reply
#9
The stuttering fps leads me to believe it's an issue with memory speed (please do take what I write here with a grain of salt, I'm not an expert). As it didn't stop when you lowered the resolution, I'd say your ram is to blame. OR it is something much simpler that is just currently escaping my mind.
Reply
#10
Are you running from a disc or iso
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply




Users browsing this thread: 1 Guest(s)