Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Another of those "Black screen but I can hear stuff" threads...
#1
Hey, I've been fiddling around with PCSX2 the past little while try to get it to run, but all I can manage to get is a black screen with audio in the background. I scoured the forums a bit reading similar posts and tried some solutions suggested from those threads. More often than not it seemed like directx was the culprit. But before I go into detail, here's the necessary information you guys might need:

PCSX2 1.0.0.r5350 - compiled on Aug 1 2012
Savestate version: 0x9a080000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 4087 MB
CPU name = Intel® Core™ i5 CPU 650 @ 3.20GHz
Vendor/Model = GenuineIntel (stepping 02)
CPU speed = 3.199 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0298e3ff
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\PS2\Plugins\gsdx32-sse2-r5350.dll
Windows 6.1.7601 (Service Pack 1 1.0)
ATI Radeon HD 5700 Series (8.17.10.1124)
Binding PAD: C:\PS2\Plugins\lilypad-r4600.dll
Binding SPU2: C:\PS2\Plugins\spu2-x-r4600.dll
Binding CDVD: C:\PS2\Plugins\cdvdGigaherz.dll
Binding USB: C:\PS2\Plugins\USBnull.dll
Binding FW: C:\PS2\Plugins\FWnull.dll
Binding DEV9: C:\PS2\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9640 games on record (loaded in 173ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
ATI Radeon HD 5700 Series (8.17.10.1124)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\PS2\FINAL_FANTASY_12.ISO
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1985600 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Steven\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Steven\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
Bios Found: USA v02.20(10/02/2006) Console

Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
ATI Radeon HD 5700 Series (8.17.10.1124)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\PS2\FINAL_FANTASY_12.ISO
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1985600 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Steven\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Steven\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
Bios Found: USA v02.20(10/02/2006) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.70, ctm:393Mhz, cpuclk:295Mhz detected)

PlayStation 2 ======== Hard reset boot
ROMGEN=2006-0210, IOP info (CPUID=1f, CACH_CONFIG=14000200, 2MB, IOP mode)
<20060210-142424,ROMconf,PS20220WC20060210.bin:11824>
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Apr 7 2005 21:09:14
CPUID=2e20, BoardID=0, ROMGEN=2006-0210, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_209.63;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_209.63;1) Game CRC = 0x0779FBDB, EntryPoint = 0x00180008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_209.63;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC


IOP Realtime Kernel Ver.0.9.1

Copyright 1999 © Sony Computer Entertainment Inc.

Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLUS_209.63;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLUS_209.63;1
1 00180000 002f4a58 ................................................
2 00474a80 000d31bb ..............
3 01780000 0002eff0 ....
4 01780000 00007140 ..
Loaded, cdrom0:¥SLUS_209.63;1
start address 0x180008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init


IOP Realtime Kernel Ver. 2.2

Copyright 1999-2002 © Sony Computer Entertainment Inc.

Reboot service module.(99/11/10)
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
cdvd driver module version 0.1.1 ©SCEI
loadmodule: fname cdrom0:¥SIO2MAN.IRX;1 args 0 arg
loadmodule: id 25, ret 0
loadmodule: fname cdrom0:¥SIO2D.IRX;1 args 0 arg
loadmodule: id 26, ret 0
loadmodule: fname cdrom0:¥DBCMAN.IRX;1 args 0 arg
loadmodule: id 27, ret 0
loadmodule: fname cdrom0:¥PAD2¥DS2O.IRX;1 args 0 arg
loadmodule: id 28, ret 0
loadmodule: fname cdrom0:¥PAD2¥DS2O.IRX;1 args 0 arg
loadmodule: id 29, ret 0
loadmodule: fname cdrom0:¥LIBSD.IRX;1 args 0 arg
loadmodule: id 30, ret 0
loadmodule: fname cdrom0:¥IOPSOUND.IRX;1 args 0 arg
loadmodule: id 31, ret 2
loadmodule: fname cdrom0:¥MCMAN.IRX;1 args 0 arg
loadmodule: id 32, ret 2
loadmodule: fname cdrom0:¥MCSERV.IRX;1 args 0 arg
loadmodule: id 33, ret 2
IOP-Sound:
IOP-Sound:IopSoundDriver Start.
IOP-Sound:
IOP-Sound:IopFreeMemory : Max Continuous
IOP-Sound: : 000DA600 000DA600
IOP-Sound:IopStackAddress : Init Start
IOP-Sound: : 001FECD0 001EBD18

So, I have only been able to achieve the black screen with audio result by running the GPU plugin in only the DX9 modes. When I try to use the DX11 the emulator just crashes, this applies to both hardware, software, full and fast. Therefore, I cannot get a copy of the console because of the crash. I've tried SSE2, SSE41 and SSSE3 with similar results.

So I went ahead and decided to try and update Directx. Regardless of what I do, the installation fails every time. I get this message:

Quote:An internal system error occurred.
Please refer to DXError.log and DirectX.log in your Windows folder to determine problem.


Then It'll say installation failed. So I tried redownloading the run dxwebsetup file again from the Microsoft website and the same thing happened (I always run as administrator before someone asks). I can post the logs if anyone wants, but the jist I get from them is that

1) It tries to overwrite a file and access is denied
2) The files are already installed and it doesn't deem it necessary to replace them

So, has anyone encountered this type of situation before, and if so what was your solution? And what type of solutions should I try short of reformatting or reinstalling Windows?
Reply

Sponsored links

#2
right-click the DX updater and run as admin
Reply
#3
(10-30-2012, 01:52 AM)Mystah Wrote: So I tried redownloading the run dxwebsetup file again from the Microsoft website and the same thing happened (I always run as administrator before someone asks)

I've also tried installing via redistribution and still no luck
Reply
#4
try reinistalling directx11 again then select directx11 hardware in the graphics plug in. hopefully pcsx2 won't crash

also look at the windows updates that are available. there may be something there that helps u. do a windows update then try putting directx

try completely removing the directx before putting it back
Reply




Users browsing this thread: 1 Guest(s)