Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Another thread about lag when I *think* I have a computer that can handle it.
#1
I'm just trying to play Battle For Bikini Bottom, man... (and also Jak II later on). My FPS drops to 20-30 every time I try to start it up even though I meet the requirements to run it. Here's a picture of it: http://i.imgur.com/HEnOuFQ.png The audio is especially horrifying when they start singing the theme song.

here are my specs: http://i.imgur.com/1RlPX3J.png

I am using PCSX2 v 1.4.0, default settings (http://i.imgur.com/2ETnePH.png) (http://i.imgur.com/8MUe5AE.png), and the game's are ISOs.

Any help is appreciated.
Reply

Sponsored links

#2
Your CPU has a single thread rate of 850, 1600 is recommended for PCSX2. You can check it out for yourself here: http://www.cpubenchmark.net/singleThread.html

You might be able to improve the performance for B.F.Bikini Bottom with some speedhacks(Config > Emulation Settings > Speedhacks, try moving the EE and VU sliders one at a time to see if it improves the framerate), but Jak II will be out of the question. That game struggles on powerful CPU's. Wink
Reply
#3
(05-18-2016, 05:10 PM)FlatOut Wrote: Your CPU has a single thread rate of 850, 1600 is recommended for PCSX2. You can check it out for yourself here: http://www.cpubenchmark.net/singleThread.html

You might be able to improve the performance for B.F.Bikini Bottom with some speedhacks(Config > Emulation Settings > Speedhacks, try moving the EE and VU sliders one at a time to see if it improves the framerate), but Jak II will be out of the question. That game struggles on powerful CPU's. Wink

ah, darn! Thank you!! I finally know why it's not working, hahaha. I'll mess with the sliders and see what happens. Thank you so much!
Reply




Users browsing this thread: 1 Guest(s)