Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Any MGS2 performance tips?
#1
Hi guys, I've been following PCSX2 with excitement since its inception years ago and watched as it went from strength to strength.
With 0.9.7 the emulator really seems to be approaching that pick-up-and-play level of performance and ease, so I thought I'd finally try to actually play some of my PS2 games through fully instead of just fiddling around for curiosity's sake.

Here are my specs and settings:
Core i7 920 @ 4GHz
6GB DDR3
nVidia GTX 275

PCSX2 0.9.7.3119 (according to the downloaded archive, though the exe reports 3113)
GSdx 3068 SSE41 0.1.16 (D3D11(Hardware), 1200x1200, Blend tff)
SPU2-X using AudioX2

I've got MGS2 SoL (PAL, SLES 503.83, non-Substance version) working in 0.9.7 now and it plays fantastically most of the time so far.
In some areas though, particularly during busy cutscenes, the framerate drops from a steady 50 fps right down to 26-30fps. When this happens I can hear the audio slowing right down to match as everything goes into slow-motion.
Right now I'm at the fight with Olga on the tanker and the framerate is fluctuating between 26-47fps, making it quite hard to play with first-person aiming etc.

Gameplay stats when things are running smoothly (during typical gameplay in the tanker etc, not boss battles or cutscenes):
fps: 50 (steady)
EE: 40-50%
GS: 20-30%

Gameplay stats when things are struggling (Olga boss battle, some cutscenes):
fps: 26-47
EE: 30-50%
GS: 60-70%

Switching audio to null and GSdx to native resolution make no difference whatsoever, so I can only assume it's a CPU issue.
I've tried all of the SpeedHacks and they make a difference of only 1-4fps at best.

Is there anything else I can try? Has anyone managed to get MGS2 running smoothly for the whole game?

Thanks in advance for any tips. Smile
               
Reply

Sponsored links

#2
Try reducing the internal resolution in GSdx or simply try ticking "native".
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(07-02-2010, 07:02 PM)Shadow Lady Wrote: Try reducing the internal resolution in GSdx or simply try ticking "native".

As I mentioned in my first post, using native res in GSdx or reducing other settings makes no difference Sad
I don't think I'm GPU-bound or pushing my GPU hard with my GSdx settings, it just seems that the CPU is struggling during certain scenes.

Thanks for the response anyway. Smile
Reply
#4
also try using NONE in both clamps (its on the 1st 2 tabs of emulation settings) it will give some speed but maybe create problems so put it back to normal if you have any probs.
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#5
(07-02-2010, 07:05 PM)iakoboss7 Wrote: also try using NONE in both clamps (its on the 1st 2 tabs of emulation settings) it will give some speed but maybe create problems so put it back to normal if you have any probs.

Thanks for the response!
I tried setting the clamps to 'none' but it made no aprpeciable difference. Sad

Here is a shot from when the game is playing perfectly:
   

And when it's slow, during the Olga fight:
   

Common sense suggests that it's slower in the Olga fight because of the wider, open area with far more geometry and effects to render on-screen, but it plays fine when the game is outside on the Tanker at other times in the heavy rain effects. It just seems to crawl during the boss battle.
Apart from this problem, PCSX2 0.9.7 is just incredible. I can't get over how smooth and fast it is the rest of the time, and how accurately it emulates things!
FFX, FFXII, Tekken 5 - All working flawlessly for me at full speed.
MGS2 and MGS3 both working perfectly apart from these specific slowdowns.
Incredible program. Laugh
Reply
#6
(07-02-2010, 07:05 PM)Zurechial Wrote: As I mentioned in my first post, using native res in GSdx or reducing other settings makes no difference Sad

Oh my bad, try checking if Vsync is enabled in either the emulator or the graphics card's control panel and try forcing them off. Also try checking if the CPU/GPU speeds remain the same while playing.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
(07-02-2010, 07:17 PM)Shadow Lady Wrote: Oh my bad, try checking if Vsync is enabled in either the emulator or the graphics card's control panel and try forcing them off. Also try checking if the CPU/GPU speeds remain the same while playing.

No problem, I appreciate the tips! Smile

I had suspected VSync was involved because of how close to 30fps the rate was dropping, since VSync tends to clamp framerates at multiples of 30 in other games/programs but alas forcing VSync off made no difference either. Sad
Reply
#8
try using supervu (not recommended cause microvu is more stable but maybe its a bug in microvu and supervu doesnt have it)

it maybe can be a problem in the emulator or something its not yet fixed in general also (you have a very fast pc so you should be able to play that game easy), maybe also it has to do with the region of the game, ntsc games kinda tend to work better overall
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#9
(07-02-2010, 07:24 PM)iakoboss7 Wrote: try using supervu (not recommended cause microvu is more stable but maybe its a bug in microvu and supervu doesnt have it)

it maybe can be a problem in the emulator or something its not yet fixed in general also (you have a very fast pc so you should be able to play that game easy), maybe also it has to do with the region of the game, ntsc games kinda tend to work better overall

I tried the SuperVU but the performance is exactly the same and it introduces some graphical glitches such as missing polygons and weird z-buffer issues.

The game plays with fantastic performance the rest of the time so I was surprised when this slowdown showed up.
I have an NTSC version of the game lying around in my room somewhere so I'll give that a try if I can find it. Smile

Thanks for the tips both of you, I'll keep playing around with settings to see if I can find something that works. I'll post back here if I find a solution. Smile
Reply
#10
I tried the NTSC release of the game and the performance is the exact same. Sad
In fact, the performance in terms of raw numbers is the same but the experience is worse because when it drops from the intended 60fps of NTSC to 30fps it's a 50% drop in speed, whereas dropping from the intended 50fps of PAL to 30fps is a 40% reduction.

Curiously, I haven't had any slowdowns so far in MGS3 which is said by some to be a more demanding title!

I'm fairly sure I've tried everything I can and that my system is up to it so I'll just have to wait and hope for a fix for this in future releases of PCSX2. Sad

Thankfully, the overall experience of using 0.9.7 is fantastic otherwise. Laugh
Reply




Users browsing this thread: 1 Guest(s)