Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Any good settings for Rogue Galaxy?
#1
Well, I've been playing Okami the past few days, need a second game to play on off days Smile Decided it's gonna be Rogue Galaxy, since I've never had the pleasure of playing that before.

However, I found out that making it work smoothly ain't as easy as making Okami work. Using the latest r1888 beta. I have a Core 2 Quad Q6600 2.4 Ghz and a GeForce 9600 GT, 4gb RAM. I can run FFXII full speed with few hiccups and no speed hacks, and Okami with a few speedhacks turned on.

I'm wondering if there's a specific beta or configuration that can make it run better, I've actually only tested the first ever battle and am getting 40-50 FPS with all speedhacks on, was using GSDX on D3D11 hardware.

Thanks!

Sponsored links

#2
BUMP

Also, there seems to be something weird going on with the movement. The characters 'stutter-step', like they'd run but sometimes would walk, even if I push the analog stick all the way through.
#3
Rogue Galaxy is a pretty demanding game. Especially in battles... i get around 40-60 FPS in battles with some speedhacks (i like to avoid using all of them because they will make game buggy and more likely to crash). I also use latest betas. One thing you could try other than speed hacks would be lowering internal res or using native resolution (if your using GSdx)
Okami and FF12 are much less CPU demaning games that's why you get higher FPS... Also, would you consider overclocking a bit. Not much if you don't really like it but to at least 2.6Ghz won't hurt, and 3-5 Fps is something you know. (I heard that CPU is OC friendly, especially if you have any aftermarket cooler --> go for it)

Note: GSdx on d3d11? I don't think your GPU supports dx11...
[Image: fs.png]
Q9550 @ 3,33GHz Ninja
HD 3850
#4
(01-25-2010, 12:49 PM)pedrosilvaa Wrote: Rogue Galaxy is a pretty demanding game. Especially in battles... i get around 45-60 FPS in battles with some speedhacks (i like to avoid using all of them because they will make game buggy and more likely to crash). I also use latest betas. One thing you could try other than speed hacks would be lowering internal res or using native resolution (if your using GSdx)

Note: GSdx on d3d11? I don't thinkl your GPU supports dx11...

It does. Well, at least I think it does. I can select D3D11 from the dropbox. I have Win7 x64. It seems I can't play this very well. So far, my system has only been able to play FF XII and Okami flawlessly (or almost flawlessly). It seems Rogue Galaxy isn't in that list =P Still trying to find out which of my games would work as well as the previous 2 (it's a pain ripping all my games into ISOs).
#5
As a general rule of thumb, don't use DX11 mode of GSdx. It's in VERY alpha stages, has NO difference than the DX10 mode but causes some extra crashes.
[Image: newsig.jpg]
#6
Ayt, noted. Laugh Shifted my settings to DX10. Does anyone else have any tips? Laugh
#7
well using skip mode, should help increasing the fps.. though there will be annoying glitches at some points...
my rig's way less powerful than yours, but got around as much fps as you..

@bositman
ah, it has no difference and also worse than using dx10? i didn't notice it, haha.
thx anyway. back to dx10 then Laugh
#8
And do not use Steve when given the option. He crashes PCSX2 when he tries to attack shielded enemies.
Reading the OFFICAL GUIDE can answer 90% of your newbie questions
SEARCHING the forums can answer 90% of your advanced questions.
#9
You should control Steve itself because his power attack crashes pcsx2.
So, take control and don't do power attacks with him.
He is the only one who crash pcsx2.
Games finished
Metal Saga
Rogue Galaxy
Atelier Iris 2 - The Azoth of Destiny
Atelier Iris 3 - The Grand Phantasm
Tales of the Abyss
#10
Is this still the case 2 years later?
CPU: i5 3570k @ 4.2 | RAM: 8GB DDR3 | GPU: 1GB Radeon HD5550 @ Stock
Running: 1.1.0.5764




Users browsing this thread: 1 Guest(s)