Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Any way to disable motion blur?
#1
I like taking screenshots from various parts of games, I also like them to look as close as possible to the original hardware, which is why I'm using a Software renderer (D3D11).
There are many PS2 games that have a lot of motion blur, which makes it impossible to take a clean screenshot unless everything (characters, camera) are standing still. It looks as if one frame bleeds into the next, instead of being two distinct frames, which makes screenshots look blurry or doubled.

Anyway, I've seen some emulators from other 3D systems that have options to disable that and I was wondering if this emulator might have a similar option that I'm missing?

Thanks in advance!
Reply

Sponsored links

#2
Yes, it's possible. There are three ways of doing that:

- Easiest to do, but lowest chance to make it work correctly: use the Skipdraw hardware hack from GSdx. Try some values (higher values disable more effects).

- Medium difficulty, but it will probably work: for the DX11 hardware renderer, use 3Dmigoto to dump the guilty shader and disable/modify it (https://github.com/bo3b/3Dmigoto/releases). You'll need to learn how the tool works and some HLSL knowledge if you want to know what the game is doing. Alternatively, you can use the Helixmod dll with the DX9 hardware renderer.

- Hard difficulty (from my point of view), but if done right it's the best and cleanest method: create your own cheat code to only disable that effect. You avoid using hacks and external tools. I have no knowledge about this, other than the fact that I created some GBA cheat codes to just modify numbers ten years ago.



As an example, I fixed the bloom effect in DBA Budokai Tenkaichi 3 and disabled some nasty effects using the second method, and also disabled a blurry layer in J&D and DMC. Check this thread: http://forums.pcsx2.net/Thread-DX11-shad...le-effects

Some time ago I could disable motion blur in Persona 4, but the shader was tied to the bloom effect, so the game was darker with it disabled. There are ways to compensate that, however, like using Shade Boost in the video plugin.
CPU: Intel Core i7 7700k @ 5GHz
GPU: Gainward GTX 1080 GLH
Motherboard: Gigabyte Aorus GA-Z270X-Gaming 5
RAM: G.Skill Trident Z RGB DDR4 3866MHz 16GB CL18
Monitor: Dell S2716DG
OS: Windows 10
Reply




Users browsing this thread: 1 Guest(s)