Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Any way to get FFX to run smoother?
#1
Hello,

I was looking through the other posts and I don't think my PC is fast enough to run this game but I decided to see if anybody had any ideas on ways to make it playable. I have a 2.4 GHz P4, 2 Gigs of RAM and an ATI Radeon x1650 video card. Right now the game runs really slow. I turned the sound off and it got a little better but not anywhere near playable. I don't care if the game looks good or not, I was just hoping to run it on my PC so I can skip the cutscenes. Is there anything I can do to lower the quality or something to get the frame rates up?

Thanks
Reply

Sponsored links

#2
speed hack you try to put on cyclerate ee 2 and vu cycle 1
after it's true it seems light level cpu
ffx and one of the game seems you less hungry
if I limit my fps to 47 which changes nothing in emulation but for me it seems something oddly made
if you can run PAL games would be better
i5 750 4.3 ghz
noctua nh-d14
toxic 5850 x 2
asus sabertooth
2x2 gb ddr3 g-skill pc 12800
corsair 650 tx
seagate 1 tb raid 0
Reply
#3
Turn all possible speedhacks on. Maybe use an older version of PCSX2. r1888 for example. or even older.

I play the "thing" on 2.0Ghz 1GB X800 256 on an inofficial r984 X3 mod with march 17'10 plugins. Got perfect videos, ~50-60 on the world or cutscenes and ~40-50 in battles. Only losing fps on "expensive" effects like framebuffer things, but it runs quiet well and bugfree. Offcourse the fps read may be off, but the game really is close to native speed.
Reply
#4
Changing the cycle rate, vu cycle and turning on the speed hacks seemed to help a bit but I'm still only getting ~20 in cut scenes. I have the skim MPEG hack on but I can't figure out how to skip the cut scene. I'll look around and try to install an older version of pcsx2. Maybe that will help. Thanks a lot for the help so far.

Edit: I installed r1888 and attempted to configure it but when I try to run the game it says I don't have a valid PS2 game in the drive. Did I skip a simple step during the config process? Maybe I'll just wait to try the emulator once I get around to building a better computer next year.
Reply
#5
I am fairly certain that the Skip MPEG hack is for skipping pre-rendered cutscenes. Most cutscenes are not pre-rendered (only the high quality CGI ones). I do not believe you can skip the standard cutscenes.

Also, in response to your problem, change the CDVD plugin.

EDIT: Also, what are your clamping options set to?
Reply




Users browsing this thread: 1 Guest(s)