Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Any way to improve FPS
#1
Well tittle says it all

Ive been trying different ps2 games recently such as Tenkaichi 3 kingdom hearts 2 and they both give me about 15-17FPS. Which is not really fun to play like that.

These are my PC specs, which I'm guessing why I'm getting that kind of FPS

AMD turion Dual core @ 2.4GHz
4GB of Ram
Win7 home 64bit
Radeon HD 4200

Any help greatly appreciated

Sponsored links

#2
First off, what does the EE% and GS% say on the title bar of your console?

If the EE% is very high, you might want to try enabling some speedhacks. This is because your CPU is too slow to run PCSX2 by itself. (Config>Emulation Settings>Speedhacks).


However, the reason that they are not automatically enabled is that they may cause in-game glitches or slowdowns. From what I recall, KH2 is pretty friendly towards speedhacks, but still may cause slowdown.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
#3
Well, your notebook is too weak for many games Tongue2
The onboard gpu is holding you back the most but your cpu isn't beefy enough either.
You can help speed a bit by enabling speedhacks in PCSX2 and by configuring GSdx to use
"native resolution" instead of upscaling.
#4
(05-30-2011, 05:31 PM)MyDreamName Wrote: First off, what does the EE% and GS% say on the title bar of your console?

If the EE% is very high, you might want to try enabling some speedhacks. This is because your CPU is too slow to run PCSX2 by itself. (Config>Emulation Settings>Speedhacks).


However, the reason that they are not automatically enabled is that they may cause in-game glitches or slowdowns. From what I recall, KH2 is pretty friendly towards speedhacks, but still may cause slowdown.

EE% 28
GS% 30
I'll try with the speed hack
Thanks

@Rama
Yes I know my Notebook isn't the best... It's about 3 years old
It can run some games n problems such as COD4 for PC ad other PC games as well
#5
Quote:EE% 28
GS% 30

I think it was supposed to be at 60 FPS. o.o?
Yes, lemons can be batteries. Ninja
#6
With neither EE/GS% reaching ~90%, I suspect your have your resolution too high, try enabling/disabling "allow 8-bit textures" and the "Native" checkbox in GSdx.

Also PC games and emulators are not the same, there's no point comparing them.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#7
The built in video is outright terrible for PS2 emulation... you may even get better (though still very slow) results using software rendering. I have a second laptop with similar specs, and while I can tweak it to get nearly playable results with some gamecube games, only a select few PS2 games (mostly older or 2d ones like Disgaea) work on it.
[Image: 2748844.png]
#8
Guys, I learned a way to also improve FPS, for some games at least (Nightmare of Druaga Confirmed)

under plugin/bios selector, under your GS, go to configure: where is says original PS2 resolution, UNCHECK native, and hit custom. Enter a small number like 400x400 or the like. Guaranteed you should see an increase in FPS as the price of quality (very minor in most cases) if you want me to post my entire settings I can, but this was the change that made the difference for me.




Users browsing this thread: 1 Guest(s)