Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Aspect ratio Issues (solved - GSdx Bug)
#1
[Image: imageissue.png]

i've tried changing aspect ratio in the plugin tried changing to PA:L PS2 bios (as that version of the game is PAL,)

not sure why and it keeps saying of enabling a "User configured refresh rate of 30hz" when i never set that :/


any wya to fix it? beside "Go and get the NTSC version"

the game is Gitaroo Man

it has been solved as its been found its a GSdx Bug. ZeroGS will run the PAL version just fine (but hampers performance on the NTSC Game. so ZeroGS for PAL, GSdx for NTSC!)
Reply

Sponsored links

#2
There's aspect ratio options in Emulator Settings > GS Window > Aspect Ratio. Have you tried that yet?

If not, try editing that and then going into fullscreen. My screen is 16:9 (1920x1080) but I just set mine to "Fit to window/screen" anyway.
[Image: signat11.jpg]

My Guide to PCSX2 for Windows (outdated, but still generally accurate)
Reply
#3
yea tried it w/ no luck
Reply
#4
(05-28-2012, 01:16 PM)CaelThunderwing Wrote: yea tried it w/ no luck

Okay, so what's your screen resolution (I have a feeling that you might have a strange resolution running on your computer)? Be sure to use your native resolution, and make sure that the video plugin is setup correctly.

To check your resolution (in Windows 7 and Vista), right-click your desktop and select "Personalize", and then look to the bottom right corner of the "Personalization" window you'll see under "See Also" that there is a "Display" link. Click it, and then on the next page click on "Adjust Resolution".

Try changing the GSDX resolution to custom and inputting your resolution. If that doesn't work then try a multiple of the native PS2 resolution which are available from the drop-down menu where you would choose "Custom" for inputting custom resolution. If all else fails, use the actual native PS2 resolution.

For an example, my screen resolution is 1920 x 1080. Therefore I have changed the settings in my GS Window and GSDX10 to run at 1920 x 1080. But also beware that higher resolutions take more power to run. I don't have to worry about that too often since my system is more than enough to keep up in most cases, but if you run into speed trouble then you could also tell me your hardware and I'll give your recommendations on what else to do.

Of course, be sure your GS Window settings in the Emulator Settings are correct as well.

Have you played this before on PS2 and you're sure it's not just like that? It doesn't look all too terribly stretched/squashed to me in the screenshot, though I don't have anything to compare it to. What game is this?
[Image: signat11.jpg]

My Guide to PCSX2 for Windows (outdated, but still generally accurate)
Reply
#5
the game is Gitarooman (an old Rhythm game) the main monitor's @ 1024x768 2nd is @ 1920x720

the NTSC version doesnt overstrech like that. but i do have a bit of issue w/ a steady FPS w/ the NTSC version (which is a problem with a game like this!)i've found back when i had a much older PC when i first got into N64 emulation PAL versions were easier to run. kinda figured the same applied to PS2 games. i'd have a image to compare later. but its like say for this the resolutions output at 1024x768 but the window's set to 800x600 without resizing the game display, (the opening Movie. however, isnt overstreched)
Reply
#6
CaelThunderwing Wrote:the game is Gitarooman (an old Rhythm game) the main monitor's @ 1024x768 2nd is @ 1920x720

the NTSC version doesnt overstrech like that. but i do have a bit of issue w/ a steady FPS w/ the NTSC version (which is a problem with a game like this!)i've found back when i had a much older PC when i first got into N64 emulation PAL versions were easier to run. kinda figured the same applied to PS2 games. i'd have a image to compare later. but its like say for this the resolutions output at 1024x768 but the window's set to 800x600 without resizing the game display, (the opening Movie. however, isnt overstreched)

This looks like it's just performance issues. Your computer can run the game at 50FPS but not at 59.94FPS...okay, I have an idea :

> Use the NTSC version.
> Go into your Emulation Settings, go to the GS tab.
> Adjust the frame limiter's "Base Framerate Adjust" setting. Try reducing it 5% or so at a time until you get a stable framerate.

Extra : Test it out with speedhacks too to squeeze out as much FPS as you can out of this.

Note that PAL runs at 50FPS, so if you want to get to PAL framerate well...

60 / 10 = 6, which means if you reduce the "Base Framerate Adjust" to 94% you should get around 50FPS in the NTSC version I do believe.

What this is doing is not attempting to run the game at the higher framerate anymore and therefore causes less stress on your system.

Edit : Oh, and I've never actually tried any of this. This is just me using logic to assume what your problems is, what these tools do, and how to use them to your advantage.

Edit 2 : What kind of hardware do you have btw? If you have a quad-core-or-better CPU then try the MTVU hack in addition to the already-recommended hacks.
[Image: signat11.jpg]

My Guide to PCSX2 for Windows (outdated, but still generally accurate)
Reply
#7
(05-28-2012, 01:39 PM)Alexander Moore Wrote: Okay, so what's your screen resolution (I have a feeling that you might have a strange resolution running on your computer)? Be sure to use your native resolution, and make sure that the video plugin is setup correctly.
...

No offense, but you're completely off the mark. Screen resolution and/or the GSdx resolution and/or the game's native resolution are completely unrelated to the displayed aspect ratio.

Regardless of any of these resolutions, the image will be stretched to the window/screen with an AR as configured (config -> emulation settings -> gs window -> aspect ratio), which can also be cycled through by pressing F6.

According to the screenshot, it seems to me as emulation bug at GSdx. Try pressing F9 to switch GSdx to software rendering which might fix it. If that doesn't work, tough luck.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#8
I just wanted to make sure he was using native res. Weird stuff happens when I don't use native res.

Try doing what he avih said, but if that doesn't work well...you know that NTSC works, yes? So try out what I said which is basically modifying the framerate because not having a stable framerate is why you don't use NTSC and this should eliminate that problem.
[Image: signat11.jpg]

My Guide to PCSX2 for Windows (outdated, but still generally accurate)
Reply
#9
Well I've played Gitaroo Man on a recent build and all is swell. No morphed and mutilated menu.

No idea o.O

Aspect ratio "fit to screen" and make sure you haven't got any manual game hacks on etc.

All I can say Unsure

Edit: You seem to have two monitors? I have no experiance with such a setup but perhaps that is what is dragging the image downwards(it would seem) is if that Pcsx2 is trying to "fit to screen/window" on "both" monitors maybe? Just a wild guess.
It's a weapon. It's REALLY powerful, ESPECIALLY against living things.
Reply
#10
[Image: ntscmainmenu.png]

this is how the NTSC Menu looks

@Alexander Moore
as for my build.. i know im going to get reamed but:

Gigabyte 990FXA-UD3 USB 3.0 Mobo
AMD FX 4100 (Quadcore @ 3.6GHZ)
8GB Ram (DDR3-1333)
AMD Radeon HD5750 (1GB Ram) with GPU Overclocking set from stock 500mhz to 830MHZ GPU/ Ram Speed from Stock 1135 to 1335

with alot of Games it seems to be just a scootch too slow (like if i went to the 6core AMD FX Cpu that it'd be perfect)

@fezzer:
well its not doing it under the NTSC Version. and ive been using the latest SVN Builds (as well as plugins of GSdx (currently SSE4 is selected) and Yea with you having played the game you can tell even a mere 1 fps lag can make an annoying differance if you make or miss a note.
Reply




Users browsing this thread: 1 Guest(s)