Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Assertion Failure
#1
I can imagine that you get this all the time, and I have looked elswhere for fixes. Ok, I'm playing Kingdom Hearts and on the main menu, after I set the difficulty (It works perfectly, mind you) and the vibration setting, when the game is actually supposed to start, I get an assertion faliure.

..\..\FiFo.cpp(47) : assertion failed:
Function: ReadFIFO_VIF1
Thread: EE Core
Condition: vif1Regs.stat.FQC != 0
Message: FQC = 0 on VIF FIFO READ!

Stacktrace:
[00] 0x01683434
[01] 0x017AE112
[02] 0x013C8555
[03] 0x0136D3CE
[04] 0x0141B63E
[05] 0x01394F41
[06] 0x0139566E
[07] 0x013956A6
[08] ptw32_throw
[09] endthreadex
[10] endthreadex
[11] BaseThreadInitThunk
[12] RtlInitializeExceptionChain
[13] RtlInitializeExceptionChain

No, I'm not using any game fixes or speedhacks. No I don't have a ***** copy of the game.

Any help? I honestly doubt it's because of my specs, cuz their pretty good. Do you think plugins may have something to do with it?

Thanks in advance.
Reply

Sponsored links

#2
Bump. Please, some help here?
Reply
#3
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
Specs

Processor: Pentium ® Dual-Core CPU T4500 @ 2.30GHz
RAM: 2.00 GB
Graphics Card: Mobile Intel® 4 Series Express Chipset Family.
OS: Windows 7 Starter

Game: Kingdom Hearts

Not the best, but eh, it can run things like Oblivion. I don't expect it to work fast, heck, I expect lag, but I at least want to play it.

PCSX2 Version: 1.0.0

Non Default Settings: I turned speedhacks and game fixes off.
Reply
#5
Quote:Mobile Intel® 4 Series Express Chipset Family.
I'm affraid this antique GPU isn't supported...
can you pelase post the full emulog.txt ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
PCSX2 1.0.0.r5350 - compiled on Aug 1 2012
Savestate version: 0x9a080000

Host Machine Init:
Operating System = Microsoft Windows 7 Starter Edition Service Pack 1 (build 7601), 32-bit
Physical RAM = 2010 MB
CPU name = Pentium® Dual-Core CPU T4500 @ 2.30GHz
Vendor/Model = GenuineIntel (stepping 0A)
CPU speed = 2.294 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0c00e39d
x86EFlags = 20100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\Program Files\PCSX2 1.0.0\Plugins\gsdx32-sse2-r5350.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Mobile Intel® 4 Series Express Chipset Family (8.15.10.2555)
Binding PAD: C:\Program Files\PCSX2 1.0.0\Plugins\lilypad-r5350.dll
(GameDB) 9640 games on record (loaded in 384ms)
Binding SPU2: C:\Program Files\PCSX2 1.0.0\Plugins\spu2-x-r5350.dll
Binding CDVD: C:\Program Files\PCSX2 1.0.0\Plugins\CDVDnull.dll
Binding USB: C:\Program Files\PCSX2 1.0.0\Plugins\USBnull.dll
Binding FW: C:\Program Files\PCSX2 1.0.0\Plugins\FWnull.dll
Binding DEV9: C:\Program Files\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.

Path: C:\Program Files\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
Path: C:\Program Files\PCSX2 1.0.0\Plugins\GSdx32-AVX.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files\PCSX2 1.0.0\Plugins\GSdx32-AVX.dll
Path: C:\Program Files\PCSX2 1.0.0\Plugins\ZZOgl.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files\PCSX2 1.0.0\Plugins\ZZOgl.dll

Loading plugins...
Binding GS: C:\Program Files\PCSX2 1.0.0\Plugins\gsdx32-sse2-r5350.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Mobile Intel® 4 Series Express Chipset Family (8.15.10.2555)
Binding PAD: C:\Program Files\PCSX2 1.0.0\Plugins\lilypad-r5350.dll
Binding SPU2: C:\Program Files\PCSX2 1.0.0\Plugins\spu2-x-r5350.dll
Binding CDVD: C:\Program Files\PCSX2 1.0.0\Plugins\cdvdGigaherz.dll
Binding USB: C:\Program Files\PCSX2 1.0.0\Plugins\USBnull.dll
Binding FW: C:\Program Files\PCSX2 1.0.0\Plugins\FWnull.dll
Binding DEV9: C:\Program Files\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Mobile Intel® 4 Series Express Chipset Family (8.15.10.2555)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

(GameDB) Unloading...
Reply
#7
ok.
same but AFTER getting the error, please.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
Whoops


PCSX2 1.0.0.r5350 - compiled on Aug 1 2012
Savestate version: 0x9a080000

Host Machine Init:
Operating System = Microsoft Windows 7 Starter Edition Service Pack 1 (build 7601), 32-bit
Physical RAM = 2010 MB
CPU name = Pentium® Dual-Core CPU T4500 @ 2.30GHz
Vendor/Model = GenuineIntel (stepping 0A)
CPU speed = 2.294 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0c00e39d
x86EFlags = 20100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\Program Files\PCSX2 1.0.0\Plugins\gsdx32-sse2-r5350.dll
Windows 6.1.7601 (Service Pack 1 1.0)
(GameDB) 9640 games on record (loaded in 830ms)
Mobile Intel® 4 Series Express Chipset Family (8.15.10.2555)
Binding PAD: C:\Program Files\PCSX2 1.0.0\Plugins\lilypad-r5350.dll
Binding SPU2: C:\Program Files\PCSX2 1.0.0\Plugins\spu2-x-r5350.dll
Binding CDVD: C:\Program Files\PCSX2 1.0.0\Plugins\cdvdGigaherz.dll
Binding USB: C:\Program Files\PCSX2 1.0.0\Plugins\USBnull.dll
Binding FW: C:\Program Files\PCSX2 1.0.0\Plugins\FWnull.dll
Binding DEV9: C:\Program Files\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.

HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Mobile Intel® 4 Series Express Chipset Family (8.15.10.2555)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Users\Tito\Documents\Active Stuff\My Games\Kingdom Hearts.iso
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1484928 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Tito\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Tito\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v02.00(14/06/2004) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.70;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_203.70;1) Game CRC = 0x0F6B6315, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_203.70;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(EE pc:0024A4A0) TLB Miss, addr=0x2000000 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000010 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000020 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000030 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000040 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000050 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000060 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000070 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000080 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000090 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20000a0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20000b0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20000c0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20000d0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20000e0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20000f0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000100 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000110 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000120 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000130 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000140 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000150 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000160 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000170 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000180 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000190 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20001a0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20001b0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20001c0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20001d0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20001e0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20001f0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000200 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000210 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000220 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000230 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000240 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000250 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000260 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000270 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000280 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000290 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20002a0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20002b0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20002c0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20002d0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20002e0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x20002f0 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000300 [load]
(EE pc:0024A4A0) TLB Miss, addr=0x2000310 [load]
..\..\FiFo.cpp(47) : assertion failed:
Function: ReadFIFO_VIF1
Thread: EE Core
Condition: vif1Regs.stat.FQC != 0
Message: FQC = 0 on VIF FIFO READ!

[00] 0x003E3434
[01] 0x0050E112
[02] 0x00128555
[03] 0x000CD3CE
[04] 0x0017B63E
[05] 0x000F4F41
[06] 0x000F566E
[07] 0x000F56A6
[08] ptw32_throw
[09] endthreadex
[10] endthreadex
[11] BaseThreadInitThunk
[12] RtlInitializeExceptionChain
[13] RtlInitializeExceptionChain
Reply
#9
try running it in software mode.
but I'd say your DVD is faulty. did you use imgburn to dump it ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#10
Software mode? What's that?

No, magic iso.

Thing is, I get the feeling that it would work if I skipped the first cutscene. I don't really want to but I would if I could.
Reply




Users browsing this thread: 1 Guest(s)