Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Audio Peaking in 007: Agent Under Fire
#1
When many explosion and gunfire sounds in 007: Agent Under Fire are played, those noises peak, causing unpleasant distortion. I haven't been able to find a fix for making the audio not become so unpleasantly loud.

I have tried using Hermite, Catmull-Rom, and Linear Interpolation, but the quality of the sound doesn't differ too much to my ears. Hermite/Catmull-Rom seem to be better options overall, since when I pause during loud noises with Linear interpolation, there seems to be some distorted artifact in the right channel for some reason.

Does anyone know if this can be fixed, and if so, how?
CPU: Intel® Core™ i7 4790 @ 3.6 GHz
GPU: NVIDIA GeForce GTX 745
RAM: 12GB DDR3
You see the whole country of the system is juxtapositioned by the haemoglobin in the atmosphere because you are a sophisticated rhetorician intoxicated by the exuberance of your own verbosity.
Reply

Sponsored links

#2
please post a screenshot of your audio plugin settings.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
I'm using SPU2-X r5830 2.0.0 on PCSX2 1.2.1.


Attached Files
.gif   settings.GIF (Size: 77,47 KB / Downloads: 77)
CPU: Intel® Core™ i7 4790 @ 3.6 GHz
GPU: NVIDIA GeForce GTX 745
RAM: 12GB DDR3
You see the whole country of the system is juxtapositioned by the haemoglobin in the atmosphere because you are a sophisticated rhetorician intoxicated by the exuberance of your own verbosity.
Reply
#4
Use catmull and set Latency to 150ms, then see if it improves things. If the latency is set too low it can cause audio distortions in some games.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#5
if it is a right vs left issue I would even say that it is the speakers not pcsx2... Have you tried different ones?
Reply
#6
(04-06-2015, 02:09 PM)willkuer Wrote: if it is a right vs left issue I would even say that it is the speakers not pcsx2... Have you tried different ones?

My speakers are somewhat faulty; I only pointed that issue out since I only heard the artifact with Linear interpolation.

(04-05-2015, 09:37 PM)Ryudo Wrote: Use catmull and set Latency to 150ms, then see if it improves things. If the latency is set too low it can cause audio distortions in some games.

Thanks for the suggestion, but setting Latency to 150ms kills my speed, and I don't really think that could be the issue.

Perhaps the game is more designed for television speakers rather than puny PC ones to handle loud noises.
CPU: Intel® Core™ i7 4790 @ 3.6 GHz
GPU: NVIDIA GeForce GTX 745
RAM: 12GB DDR3
You see the whole country of the system is juxtapositioned by the haemoglobin in the atmosphere because you are a sophisticated rhetorician intoxicated by the exuberance of your own verbosity.
Reply
#7
(04-06-2015, 07:30 PM)junknaut Wrote: My speakers are somewhat faulty; I only pointed that issue out since I only heard the artifact with Linear interpolation.


Thanks for the suggestion, but setting Latency to 150ms kills my speed, and I don't really think that could be the issue.

Perhaps the game is more designed for television speakers rather than puny PC ones to handle loud noises.

I mean we are talking about a PS2 game. Does it sound like that with decent headphones?

lol i cant even bbcode
Moe: [to Homer] And I'm pulling your favorite song out of the jukebox.
Homer: "It's Raining Men"?!
Moe: Yeah, not no more, it ain't. [throws the record out the window which lands into Smithers' car]
Smithers: Ow! [looks at the record] Ohhh.

what would ;e; do
Reply
#8
(04-06-2015, 07:31 PM)Marge Simpson Wrote: I mean we are talking about a PS2 game. Does it sound like that with decent headphones?

lol i cant even bbcode


Yeah, I know, but even other games I own with a lot of explosion sounds and whatnot sound crisp and clear via my speakers compared to 007: AUF. I checked with good quality earbuds and headphones and it sounds marginally better.
CPU: Intel® Core™ i7 4790 @ 3.6 GHz
GPU: NVIDIA GeForce GTX 745
RAM: 12GB DDR3
You see the whole country of the system is juxtapositioned by the haemoglobin in the atmosphere because you are a sophisticated rhetorician intoxicated by the exuberance of your own verbosity.
Reply
#9
(04-06-2015, 07:48 PM)junknaut Wrote: Yeah, I know, but even other games I own with a lot of explosion sounds and whatnot sound crisp and clear via my speakers compared to 007: AUF. I checked with good quality earbuds and headphones and it sounds marginally better.

Eh, I'm calling PC speakers. Try an older build of PCSX2?
Moe: [to Homer] And I'm pulling your favorite song out of the jukebox.
Homer: "It's Raining Men"?!
Moe: Yeah, not no more, it ain't. [throws the record out the window which lands into Smithers' car]
Smithers: Ow! [looks at the record] Ohhh.

what would ;e; do
Reply
#10
Try to wiggle (really?) on the cables/plugs. Maybe it is a broken cable not the plug. Try connecting left speaker as right speaker and right as left speaker if they are symmetric. Try to plug in headphones in the front audio connector of your boxes if available.

Is the problem less pronounced if you decrease volume? Is it much worse if you increase it?

Would be good to check that the hardware is not faulty first. Download some full frequency audio files to check.
Reply




Users browsing this thread: 1 Guest(s)