Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Audio Problems
#1
After some time of not using the PS2 emulator, I decided to download an updates version of it. So, after uninstalling the previous version I downloaded the latest one (1.2.1 (r5875)).
However, the audio doesnt work anymore.
Here is the full log when trying to boot up the bios/system menu:

PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 6135 MB
CPU name = Intel® Core™ i3 CPU 530 @ 2.93GHz
Vendor/Model = GenuineIntel (stepping 02)
CPU speed = 2.924 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3bd
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
Binding GS: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-sse4-r5875.dll
Windows 6.1.7601 (Service Pack 1 1.0)
Binding PAD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\lilypad-r5875.dll
Binding SPU2: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\spu2-x-r5875.dll
Binding CDVD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\cdvdGigaherz.dll
Binding USB: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\USBnull.dll
Binding FW: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\FWnull.dll
Binding DEV9: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 249ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
NVIDIA GeForce GTX 650 (9.18.13.4475)
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'Driver audio principale' (Windows DirectSound)
*** Device 1: 'Altoparlanti (Realtek High Definition Audio)' (Windows DirectSound)
*** Device 2: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows DirectSound)
*** Device 3: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows WASAPI)
*** Device 4: 'Altoparlanti (Realtek High Definition Audio)' (Windows WASAPI)
*** Device 5: 'Speakers (Realtek HD Audio output)' (Windows WDM-KS)
*** Device 6: 'SPDIF Out (Realtek HDA SPDIF Out)' (Windows WDM-KS)
* SPU2-X: PortAudio error: Invalid device
Opening CDVD
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Claudio Visentin\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Claudio Visentin\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe v02.00(14/06/2004) Console
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
GSdx: failed to compile external post-processing shader.
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.

Does someone know how to fix this?
Reply

Sponsored links

#2
config>audio>plugin settings

change from port audio to xaudio2
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
Thanks, it worked!
Reply




Users browsing this thread: 1 Guest(s)