Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Audio/Video hiccups/lag
#1
I've been using pcsx2 for about a week now, my thanks for this brilliant program by the way, however I've run into a small issue.

Minor lag, which is extremely irritating. It slows down the graphics to an extreme extent and the audio slows at the same time. The issue occurs whilst playing FF X and most commonly occurs when entering a battle and/or during battle. It happens during regular game play, but not as often. It has yet to happen in one of the video sequences.
>On a side note, I've noticed an increase of lag issues when I turned off my paging file. If the emulator requires the paging file, I'll have to inquire about a workaround.

PCSX2 Vers 1.0.0

My computers specifications are as follows:
Windows 7 Ultimate 64x
32GB Kingston HyperX 1660 RAM
120 GB SSD
1TB HDD
Geforce GTX 660 Twin Frozr
AMD FX-6100 CPU

The only game I have for pcsx2 use currently is FF X, because I can't be bothered spending 12 hours searching through old boxes to find my other ps2 games. >The FFX I have atm is an ISO on my HDD. Yes, I do own FF X, I just find having discs a pain the ass, especially in this day and age.
Reply

Sponsored links

#2
FFX isn't really demanding, but if you abused gsdx config and used some awfully high internal res then it can easily slowdown on your GTX660 especially if you keep other gpu abusive stuff opened while playing the game(web browser, flash addon's or other crap alike) since pcsx2 shares gpu with all of that, if that's the case then decrease internal res as much as the game doesn't have any slowdowns anymore and/or turn off those other stuff;].

Swap file shouldn't really affect anything here unless your system has some general problems, pcsx2 doesn't use much of ram to begin with and even in those rare glitched games with memory leaks it's limited to 2gb or 4gb if you manually patch the exe(and this counts only for 64 bit system ofc) ~ FFX is not one of them;p. If you keep the iso on the hdd maybe it's just so ultra slow that bottlenecks emulation?;p But that would mean it's either broken or has some abusive power saving features. You could check it by copying the iso to your sdd.
Reply
#3
I'll give the ssd role a try. See what happens.
Reply
#4
You shouldnt turn off the page file.
Even with an abundance of ram, things still get written to the page file, and turning it off, like you seen, will usually have adverse effects. Its not just emulators, but everything. Its just the way windows works (which is a terrible design i know lol).


I dont see how you can possibly be lagging on FFX on your system, unless you are like doing 3d model rendering in the background :3

Under the speedhack tab, have you enabled multi-threading? you really should as having more then 2 threads and using that, really speeds up gameplay.
Your cpu isnt the best for emulation (all amd cpus rank poorly), but it should be more then enough for "most" games.

Under your graphic plugin setting, what are you using?
you should put it to direct3d11 (hardware), and then maybe turn down your internal resolution scaling. Tho with that card you should probably be able to get 4x IR or better.
What will really lag you is enable hw hacks > configure > turning up the MSAA. (id suggest just leaving that off, atleast until you know where you stand)

Having on the hdd should never cause any lag... ps2 games or any other disc console games load off a cd/dvd which is 10x slower then your hdd lol.

You could always try using a later revision from http://pcsx2.net/download/development/svn.html
see if that fixes anything.
Reply
#5
As above, you really shouldn't turn off page files. If your SSD is your main windows drive (it should) then you should simply set your page file to be on your 1TB mechanical drive. I would recommend manually setting it though since at 32GB of ram it's going to want to set an excessive size. Just 2-4GB would be more than enough.
[Image: 2748844.png]
Reply
#6
(04-07-2013, 09:09 AM)Koji Wrote: As above, you really shouldn't turn off page files. If your SSD is your main windows drive (it should) then you should simply set your page file to be on your 1TB mechanical drive. I would recommend manually setting it though since at 32GB of ram it's going to want to set an excessive size. Just 2-4GB would be more than enough.

I have not had page file for years and never had problem. windows only needs it for system crashes dumps, and only hand full programs need pagefiles, even less on the game end. i found most game run better with no pagefile as it forces it to use memory
Reply
#7
(04-07-2013, 05:36 PM)tsunami2311 Wrote: I have not had page file for years and never had problem. windows only needs it for system crashes dumps, and only hand full programs need pagefiles, even less on the game end. i found most game run better with no pagefile as it forces it to use memory

If you set it low, games won't bother using it anyways unless you don't have enough physical ram Smile

That said, it never hurts to plan around possible compatibility issues with programs that MAY require or act abnormal without it. Especially ones that could be potentially hard to track down as causing a problem with a piece of software later on. Especially with a 1TB drive. My secondary drive is half that, 2-4GB is hardly missed.

Then again, I also disabled hibernating... but that mofo was gobbling too much SSD space Smile
[Image: 2748844.png]
Reply




Users browsing this thread: 1 Guest(s)