Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Automatic game fixes not working for star ocean 3
#1
Reading through the settings it says that it's better to leave the game fix page blank and enable automatic game fixes instead. It doesn't work for me and I always have to tick the game fix manually. Would the gamefix affect other games' performance if I just leave it there?
Reply

Sponsored links

#2
(02-28-2017, 08:13 AM)tran01hai Wrote: It doesn't work for me and I always have to tick the game fix manually.

What exactly doesn't work, and ticking exactly what fixes what?


Quote:Would the gamefix affect other games' performance if I just leave it there?


Checking only the main (top) "Enable manual game fixes" doesn't do anything on its own.

But if you have specific game fixes enabled at the list below, then checking the top checkbox enables them for all games, which is typically a bad idea because they're hacks designed to fix specific issues, and if the game you're currently running doesn't need it, then it'll probably hurt it in some way.

If you only enable "Automatic game fixes" at the main menu and leave "manual game fixes" unchecked, then it will automatically select specific fixes which are known to help the game you're currently running.

So unless you know what you're doing, which it seems you're not, leave "manual game fixes" disabled.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#3
(02-28-2017, 08:30 AM)avih Wrote: If you only enable "Automatic game fixes" at the main menu and leave "manual game fixes" unchecked, then it will automatically select specific fixes which are known to help the game you're currently running.

That's exactly what I did and the game always crashes on start up and the only way to fix it is to select the game fix manually.
Reply
#4
are you using fast boot or full boot ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(02-28-2017, 09:58 AM)jesalvein Wrote: are you using fast boot or full boot ?

fast
Reply
#6
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 14393), 64-bit
Physical RAM     =  16300 MB
CPU name         =  Intel® Core™ i7-4790K CPU @ 4.00GHz
Vendor/Model     =  GenuineIntel (stepping 03)
CPU speed        =  3.998 ghz (8 logical threads)
x86PType         =  Standard OEM
x86Flags         =  bfebfbff 7ffafbbf
x86EFlags        =  2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
(GameDB) Database Not Found! [C:\Program Files (x86)\PCSX2 1.4.0\GameIndex.dbf]
Binding   GS: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\gsdx32-avx.dll 
Windows 10.0.14393
Binding  PAD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\lilypad.dll 
Binding SPU2: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\spu2-x.dll 
Binding CDVD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\cdvdGigaherz.dll 
Binding  USB: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\USBnull.dll 
Binding   FW: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\FWnull.dll 
Binding DEV9: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\DEV9null.dll 
Plugins loaded successfully.

HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 10.0.14393
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Current Renderer: Direct3D11 (Hardware mode)
Opening CDVD
isoFile open ok: I:\Star Ocean 3 Til The End of Times.iso
Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (2292897 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0 [File]: C:\Users\Ayaaaaaa\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\Ayaaaaaa\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA     v02.20(10/02/2006)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.70, ctm:392Mhz, cpuclk:294Mhz detected)

PlayStation 2 ======== Hard reset boot
 ROMGEN=2006-0210, IOP info (CPUID=1f, CACH_CONFIG=14000200, 2MB, IOP mode)
 <20060210-142424,ROMconf,PS20220WC20060210.bin:11824>
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Apr  7 2005 21:09:14
  CPUID=2e20, BoardID=0, ROMGEN=2006-0210, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_204.88;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
found 0 symbols
ELF (cdrom0:\SLUS_204.88;1) Game CRC = 0x23A97857, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_204.88;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 © Sony Computer Entertainment Inc. 
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15) 
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLUS_204.88;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLUS_204.88;1
0 00100000 000b6400 ............
Loaded, cdrom0:¥SLUS_204.88;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 © Sony Computer Entertainment Inc. 
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15) 
iop heap service (99/11/03)
loadbuffer: addrres 4ba00 args 0 arg 
loadbuffer: id 25, ret 0
loadbuffer: addrres 4e500 args 0 arg 
loadbuffer: id 26, ret 0
loadbuffer: addrres 53e00 args 0 arg 
loadbuffer: id 27, ret 0
loadbuffer: addrres 53e00 args 0 arg 
loadbuffer: id 28, ret 0
loadbuffer: addrres 5de00 args 0 arg 
loadbuffer: id 29, ret 0
loadbuffer: addrres 6a800 args 0 arg 
loadbuffer: id 30, ret 0
loadbuffer: addrres 6a800 args 0 arg 
loadbuffer: id 31, ret 0
loadbuffer: addrres 53e00 args 0 arg 
loadbuffer: id 32, ret 0
loadbuffer: addrres 92200 args 0 arg 
loadbuffer: id 33, ret 2
loadbuffer: addrres 53e00 args 0 arg 
loadbuffer: id 34, ret 2
(EE pc:00143670) TLB Miss, addr=0x4 [load]
(EE pc:00000000) TLB Miss, addr=0x0 [load]
(EE pc:00000000) TLB Miss, addr=0x0 [load]
(EE pc:00000000) TLB Miss, addr=0x4 [load]
(EE pc:00000000) TLB Miss, addr=0x8 [load]
(EE pc:00000000) TLB Miss, addr=0xc [load]
(EE pc:00000000) TLB Miss, addr=0x10 [load]
(EE pc:00000000) TLB Miss, addr=0x14 [load]
(EE pc:00000000) TLB Miss, addr=0x18 [load]
(EE pc:00000000) TLB Miss, addr=0x1c [load]
(EE pc:00000000) TLB Miss, addr=0x20 [load]
(EE pc:00000000) TLB Miss, addr=0x0 [load]
(EE pc:00000000) TLB Miss, addr=0x4 [load]
(EE pc:00000000) TLB Miss, addr=0x8 [load]
(EE pc:00000000) TLB Miss, addr=0xc [load]
(EE pc:00000000) TLB Miss, addr=0x10 [load]
(EE pc:00000000) TLB Miss, addr=0x14 [load]
(EE pc:00000000) TLB Miss, addr=0x18 [load]
(EE pc:00000000) TLB Miss, addr=0x1c [load]
(EE pc:00000000) TLB Miss, addr=0x20 [load]
(EE pc:00143670) TLB Miss, addr=0x8 [load]
# Initialize VU0 ...
(EE pc:00143670) TLB Miss, addr=0xc [load]
# Initialize VU0 ...
(EE pc:00143670) TLB Miss, addr=0x10 [load]
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VIF0 ...
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
Reply
#8
https://www.youtube.com/watch?v=GAGXJ698...e=youtu.be
Idk if this helps
Reply
#9
I guess this is why :

Quote:(GameDB) Database Not Found! [C:\Program Files (x86)\PCSX2 1.4.0\GameIndex.dbf]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#10
Corrupted PCSX2 download? Or did you delete that file yourself? Either way, redownload PCSX2 and make sure all the files are there. The fix should work as intended then.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply




Users browsing this thread: 1 Guest(s)