Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bad FPS on good system
#1
So, I've been testing out Marvel Ultimate Alliance and I just can't seem to get a stable 60fps no matter what I try. First off, here's my specs:

CPU: AMD FX 8350 @ 4.0ghz
GPU: AMD r9 270x 2GB
RAM: 16GB DDR3 1600
MOBO: Gigabyte 970A-DS3P

I'm also running version 1.2.1 and using the SSSE3 version of GSDX 0.1.16. I'm using DirectX 11 hardware mode. I've tried enabling speedhacks, tried running software mode and countless other things, but I just can't seem to get a playable framerate. Any ideas?
Reply

Sponsored links

#2
what do the ee% & gs% say when you get slowdowns ?
can you please post your pcsx2 settings (screenshots of each tab) ?
care to post the emulog.txt too ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Sure thing. My ee% reads 100 and my GS is between 15 to 40. The screenshots are attached to the post. The emulog is in the spoiler tab.

PCSX2 1.2.1.r5873 - compiled on Feb  3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System =  Microsoft  (build 9200), 64-bit
Physical RAM     =  16341 MB
CPU name         =  AMD FX™-8350 Eight-Core Processor
Vendor/Model     =  AuthenticAMD (stepping 00)
CPU speed        =  4.017 ghz (8 logical threads)
x86PType         =  Standard OEM
x86Flags         =  178bfbff 3e98320b
x86EFlags        =  2fd3fbff

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. FMA
MMX2  .. SSE4a

Reserving memory for recompilers...

Loading plugins...
Binding   GS: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-sse4-r5875.dll
Windows 6.2.9200
Binding  PAD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\lilypad-r5875.dll
Binding SPU2: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\spu2-x-r5875.dll
Binding CDVD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\cdvdGigaherz.dll
Binding  USB: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\USBnull.dll
Binding   FW: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\FWnull.dll
Binding DEV9: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9655 games on record (loaded in 197ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.2.9200
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
* CDVD: Opening drive '\\.\D:'...
* CDVD: setSpindleSpeed success (11080KB/s)
* CDVD: IO thread started...
* CDVD: KeepAlive thread started...
* CDVD: Disk Type: Double-Layer DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 2) (1439856 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Deadpoolfan\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Deadpoolfan\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA     v02.20(10/02/2006)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.74;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_213.74;1) Game CRC = 0x960C7892, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.74;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.74;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
* CDVD: KeepAlive thread finished.
* CDVD: IO thread finished.
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Suspending single plugin: GS
Opening GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Loading GS
[wx] Failed to load shared library 'C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll' (error 1114: a dynamic link library (DLL) initialization routine failed.)
Path: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll
Saving GS
Saving PAD
Saving SPU2
Saving CDVD
Saving USB
Saving FW
Saving DEV9
Shutting down plugins...
Plugins shutdown successfully.

Loading plugins...
Binding   GS: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-ssse3-r5875.dll
Windows 6.2.9200
Binding  PAD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\lilypad-r5875.dll
Binding SPU2: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\spu2-x-r5875.dll
Binding CDVD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\cdvdGigaherz.dll
Binding  USB: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\USBnull.dll
Binding   FW: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\FWnull.dll
Binding DEV9: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\DEV9null.dll
Plugins loaded successfully.


Initializing plugins...
Init GS
Windows 6.2.9200
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

EE/iR5900-32 Recompiler Reset
Opening GS
Loading GS
Loading PAD
Loading SPU2
Loading CDVD
Loading USB
Loading FW
Loading DEV9
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Loading GS
HLE Notice: ELF does not have a path.

Opening plugins...
Opening PAD
Opening SPU2
Opening CDVD
* CDVD: Opening drive '\\.\D:'...
* CDVD: setSpindleSpeed success (11080KB/s)
* CDVD: IO thread started...
* CDVD: KeepAlive thread started...
* CDVD: Disk Type: Double-Layer DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 2) (1439856 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Deadpoolfan\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Deadpoolfan\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
Bios Found: USA     v02.20(10/02/2006)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.74;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_213.74;1) Game CRC = 0x960C7892, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.74;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.74;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC


Attached Files Thumbnail(s)
                               
Reply
#4
from the readings, your CPU is struggling.
2 things to try :
- try using recommended speedhacks, especially MTVU hack. If it's not enough, try to set ee cycle rate to 1
Or
- since you are running the game in native resolution, try setting 5 extra sw rendering threads and use gsdx software mode.

in any case, make an iso off your DVD using imgburn (http://www.imgburn.com). the reading times will be better than when you are using your physical DVD
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
The MTVU hack just causes the game to not boot. After showing the PS2 logo, it just goes black and nothing loads. In software mode (with the 5 extra threads) I experience slightly worse framerate. I'm currently creating an iso for the game now.
Reply
#6
Some games are incompatible with mtvu. You could try 3/4 extra render threads but I doubt it'll make much a difference. Try ee/vu speedhacks but don't go overboard, it will cause worse performance and false fps readings
Reply
#7
Yeah, adding extra threads made no difference, speedhacks don't help and running from an iso didn't help at all.
Reply
#8
Maybe this game is quite demnding.
from what I saw on the wiki, the guy who reported it to run full speed had a luch better CPU than yours.
taht would explain why you can't get playable speeds.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
How much do your fps dip?

You should really try we cycle rate hack if you haven't tried so far.
Reply
#10
You definitely want the default speedhacks on.
Reply




Users browsing this thread: 1 Guest(s)