Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Baldur's Gate Dark Alliance 1 slowdown?
#1
Hi all - new to the forum, but enjoying PCSX2 very much!

One question - is there anything I can do about Baldur's Gate Dark Alliance 1 slowdown?  It seems to happen any time there are flame effects on the screen, and brings me from 55-60 FPS to 15-20.  This happens whether I use Native resolution or 3x resolution.  I don't seem to have any problem at all playing at 2x resolution on Dark Alliance 2 (and not that much slowdown on 3x), and I can play at 3x resolution and 4x MSAA on Champions of Norrath without any slowdown.  I'm currently using the following:

GSdx32-AVX plugin
Direct3d11 Renderer
Large Framebuffer checked
Bilinear Texture Filtering
Full CRC Hack Level
All the recommended Speedhacks

Thanks for any help you can give me!  My specs are below.

PCSX2 Version 1.50-20160623205743
Intel i7-4790 & 3.6 GHz, 4 cores
NVIDIA GeForce GTX960
Reply

Sponsored links

#2
In the GSdx Plugin Settings windows, Enable "Allow 8-bit Textures" and "HW Hacks", then go to Configure Hacks and enable "Fast Texture Invalidation".
Reply
#3
(09-04-2016, 01:48 AM)FlatOut Wrote: In the GSdx Plugin Settings windows, Enable "Allow 8-bit Textures" and "HW Hacks", then go to Configure Hacks and enable "Fast Texture Invalidation".

Well, hell!  That worked great!  Thank you so much!
Reply
#4
Both options can cause graphical issues in some games, so it's better to keep them off generally.
Reply
#5
If there are any remaining slow areas (seems unlikely with those specs) you might be able to boost performance further by using the OpenGL renderer. If you have MTVU enabled, you might get a few extra FPS by turning it off.

Champions of Norrath seems to switch to a 30 / 25 fps progressive mode (looks sharper, but choppy/sluggish) in some intensive areas (e.g. Caves in the Lower Faydark) - if you increase the EE Cyclerate this doesn't occur. Haven't played enough to see if this causes any glitches.
Not sure if any of the other Snowblind Engine games do that.
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#6
(09-04-2016, 01:48 AM)FlatOut Wrote: In the GSdx Plugin Settings windows, Enable "Allow 8-bit Textures" and "HW Hacks", then go to Configure Hacks and enable "Fast Texture Invalidation".

First valid solution I have found trying to run this title in PCSX2 smoothly.
Reply




Users browsing this thread: 1 Guest(s)