Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Baldur's Gate: Dark Alliance 2 Fixed???
#1
Is Baldur's Gate: Dark Alliance 2 game has been fixed? i searched everywhere for the fixing.

Hardware = Smooth + half screen

Software = Lag + full screen

both ways doesn't help.

Pls share if u have the fix for these problems

Sponsored links

#2
AFAIK, software mode is the only way to get this game playable. Of course, you need a decent PC.

there have been a few "fix" diescovered latly, though. Give latest svn a try, maybe it has been fixed : http://forums.pcsx2.net/Thread-PCSX2-SVN...ilds-by-me
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#3
tried the new link u showed me, still having the same problems.
#4
(04-22-2014, 06:42 AM)Rebornz Wrote: tried the new link u showed me, still having the same problems.

then you need to use software mode + good PC
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#5
will try with my another laptop later~ will be back with feedback after i try
#6
A laptop wont cut it, you need a powerful desktop pc, preferably quad core with software rendering threads set to 3
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#7
Refraction even then I get slow downs with the game and I am running an i5 3570k at 4ghz with threads set to 3

as for recent fixes there is this thread http://forums.pcsx2.net/Thread-Baldurs-G...-explained

But I have not seen any recent changes by our resident GDSX coder Pseudonym so I don't think hes seen things yet unless he is trying to figure out how to get it working of course.
#8
(04-22-2014, 10:33 AM)refraction Wrote: A laptop wont cut it, you need a powerful desktop pc, preferably quad core with software rendering threads set to 3

You Sir are my hero.
Tried everything except overlooked the rendering threads.
Thank you!

(Settings I Changed from default)
I've installed the 4GB patch
&
Config>Video (GS)>Pluging Settings
Renderer: Direct3D11 (Software)
Extra rendering threads: 3 (quad core cpu)

Hopes this helps someone, it took me 3 hours to fix.
#9
(07-12-2014, 04:07 PM)DougBundy Wrote: You Sir are my hero.
Tried everything except overlooked the rendering threads.
Thank you!

(Settings I Changed from default)
I've installed the 4GB patch
&
Config>Video (GS)>Pluging Settings
Renderer: Direct3D11 (Software)
Extra rendering threads: 3 (quad core cpu)

Hopes this helps someone, it took me 3 hours to fix.

So did you manage to get the game to perform? I'm running the 4gb patch (i think? it doesn't crash anymore), I have it on D3D11 with the 3 threads and I have a pretty meaty PC (i7 3.5ghz) but my frames quickly drop to 10fps after taking a few steps in the tavern of DA1. Would really love to play this on my PC because of the stupid cables for the PS2 and I don't own a backwards PS3.

Also is there any word on a hardware fix since whoever it is found out why we only get half a screen in hardware mode?
#10
(07-24-2014, 06:27 PM)HammerHand Wrote: but my frames quickly drop to 10fps after taking a few steps in the tavern of DA1.
yep.
actual machines can't render those series properly.
Quote:Also is there any word on a hardware fix since whoever it is found out why we only get half a screen in hardware mode?
2 words : snowblind engine.

This engine can't be rendered properly for now, especially in hardware mode.
and a fix isn't yet to come AFAIK
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)