Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Baldurs Gate - Dark Alliance settings (too slow)
#1
Hi,

My rig isn't too bad, but i can't get Baldurs gate - dark alliance (PAL) working in full speed. I'm using OpenGL (Hardware) and the half screen bug is fixed, but the game drops down to 15-25fps in the start scene. In the tavern, fps drop to 25fps when i'm near light sources like the fireplace with GS up to 99%. 

I've tried with the default settings, and it doesn't make any difference if native or 4x native resoultion is used. 

My hardware:
core i5 3450
Sapphire ATI Radeon Vapor X R9 280
8GB Ram

I've also tried the MVTU Speedhack but also, no difference. What settings are recommended?

The wife and i are planning to play that great game again (it's one of our favourite multiplayer games) and we'd prefer to play it in "HD Resolution". If it's not playable due to performance issues, we still have our old PS2 to play it.

Edit: Btw, when i tried to save a state i got a "Out of memory error". I've read there's a 8GB Patch. Do i have to apply that? Why isn't it part of pcsx2 by default?
Or is this related to pcsx2 being a 32 bit application and the accompanied 4GB limitation?
Reply

Sponsored links

#2
did you try Gsdx11 hardware mode ?
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#3
oh... lol. actually not.

I switched to DX11 HW now and it's MUCH better. i get slowdowns to 44fps, but mainly the max of 50fps are achieved and GS utilization is at about 70-80% max during the intro but ingame it's much lower. That's what i call perfectly playable! Laugh

Thx! Reading the snowblind thread i thought that half-screen bug was only fixed in GL, so i haven't even bothered trying DirectX.

edit:

Ok, going to the left side of the tavern still slows the game down to 20-30fps.... but with gl it was worse.
Reply
#4
do you used any speedhacks ? if yes , disable it , or if not enable it and try with EE &GS Value to 1 . or so .
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#5
(09-27-2015, 09:47 AM)Brock lessner Wrote: do you used any speedhacks ? if yes , disable it , or if not enable it and  try with EE &GS Value to 1 . or so .

Just MVTU, everything else is set to default. i've tried to disable MVTU but that doesn't make any difference.

http://mars.workupload.com/image/4mQGqPWb


Edit: Now i've unchecked "enable speedhacks" and still no difference.
Reply
#6
what do the ee% & gs% say when getting slowdowns ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
I think these games mostly slowdown because of the gs-thread/gpu communication. Most speedhacks therefore don't help much. Maybe vu cycle stealing as it could reduce load on the GS thread. But with the costs or lower internal fps.

Opengl is slower for you because of your ati card and missing support for higher ogl extensions. For nvidia cards ogl should be faster most of the time.

For some people gsdx software with some extra rendering threads is faster than gsdx hardware.
Reply
#8
If you haven't yet enable 8bit in GSDX
Reply
#9
I'll try to update to ati beta drivers when i get home. Maybe the new opengl features are available there...

8bit textures are enabled but it doesn't make any difference.

ee percentage is quite low, actually, i'll post a screenshot later.
Reply
#10
Here are some screenshots. Updating to the new Beta Driver didn't help Sad

Btw, my pcsx2 git build is from 2015/09/11

http://mars.workupload.com/image/7Q5di8g9
http://mars.workupload.com/image/T8Hf3PT8
Reply




Users browsing this thread: 1 Guest(s)