Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Best settings for DQ8
#1
Been trying to Play DQ8 for the longest time, but every kind of setting i try will always give me low fps in the open areas. I will get 60fps in buildings and in building battles. But outside it'll fluctuate drastically between 45-60fps.

my specs are as follows
AMD FX 8320 @3.5Ghz
8GB ram @1600
AMD HD 7870 2Gb

if I need to list other specs please let me know, i am desperately trying to play the game as best as i can. Thanks for any help.
-Zelok
Reply

Sponsored links

#2
What current settings of pcsx2 you use now!
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#3
(02-04-2014, 12:17 PM)zelok25 Wrote: Been trying to Play DQ8 for the longest time, but every kind of setting i try will always give me low fps in the open areas. I will get 60fps in buildings and in building battles. But outside it'll fluctuate drastically between 45-60fps.

my specs are as follows
AMD FX 8320 @3.5Ghz
8GB ram @1600
AMD HD 7870 2Gb

if I need to list other specs please let me know, i am desperately trying to play the game as best as i can. Thanks for any help.
-Zelok

What version of PCSX2 are you using?

Are you playing straight from the disc or from an ISO?

Are you using any speedhacks?

Are you upscaling at all?

What are your EE and GS percentages when a slowdown occurs? It's shown in the title bar when you are running in windowed mode.

This game is very GPU heavy but you have decent hardware.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#4
Try looking here:
http://wiki.pcsx2.net/index.php/Dragon_Q...ursed_King

Someone with weaker everything than you got a full 50FPS (PAL, NTSC would be 60)

I'd say the biggest thing is to adjust the speed hacks.
Definitely enable MTVU, and see if that alone doesn't fix your issue.

Also make sure you're using the latest stable PCSX2 release (free 10% performance boost and all)
Intel Core i5-4690k @4.5ghz
Samsung 16GB DDR3 @2000mhz
GeForce GTX 1080 8GB
Windows 10 x64
Reply
#5
using the build 1.2.1

I am using ISO

after testing when it drops down to 50fps, EE is around 60-70% and GS is 65-75%, VU is 50-55% all times.

       

(02-04-2014, 05:14 PM)hellbringer616 Wrote: Try looking here:
http://wiki.pcsx2.net/index.php/Dragon_Q...ursed_King

Someone with weaker everything than you got a full 50FPS (PAL, NTSC would be 60)

I'd say the biggest thing is to adjust the speed hacks.
Definitely enable MTVU, and see if that alone doesn't fix your issue.

Also make sure you're using the latest stable PCSX2 release (free 10% performance boost and all)
trying this setting now, seems to be running stable havent seen any intensive slowdowns.
Reply
#6
Use the newest version of the emulator and use OpenGL instead of DX11. I can not begin to describe how immensely fast OGL is compared to DX11. I know you card supports it as its a better card than what I have.
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply
#7
As already stated here that is not correct. Stay at DX10/11 if possible.

I think it is better not to use the preset and set it to aggressive... I would recommend to find the best settings by yourself.

1. enable all recommended speedhacks (only tickboxes but not 'fast cd' and not 'MTVU')
2. Check framerate in an intense unstable area.
3. Enable 'MTVU'
4. Check again at the same spot. If it you gain some fps it is good. If not than this might be one of the few games where mtvu does not help.
5. Slowly increase the sliders (step-by-step)
6. Check again at the same spot. One of the slider can increase the displayed fps value. So you better should keep an eye on the output itsself and not on the fps-display.
7. Find best combination of sliders. Too high values can lead to crashes, slowdowns, graphical issues,... So use the lowest values that are fine for you.
8. Profit!

(I have never seen that somebody really used 'fast cd'...)
Reply
#8
DQ8 is a very demanding game, but async mix audio setting helps a lot to make the game more enjoyable during slowdowns.

On my PC, Direct3D9 runs a little bit faster than Direct3D11 and Direct3DD11 will lead to reproducible crashes every 1-2 hours while Direct3D9 seems to run stable.

Also make sure to use the correct AVX version of the gsdx plugin and try to play around with your GPU driver performance settings and to set pcsx2 windows process priority to high in task manager.
Reply
#9
Have you tried setting the IR to native? This game is VERY demanding on a GPU. Since you are only at 2x this probably isnt the issue, but if you have tried everything else Smile
Cooler Master HAF X Full Tower
ASRock Z97 Extreme4
EVGA GeForce GTX 970 4GB
EVGA SuperNOVA 850W
Intel Core i5-4690K - OC'ed to 4.5GHz
G.SKILL Ripjaws X 8GB DDR3 1600
CORSAIR Hydro H105
Indigo Xtreme 115X-XS Metallic TIM
Windows 7 SP1 64-bit
PCSX2 1.4.0 unless otherwise specified
Reply
#10
(02-04-2014, 11:05 PM)fade2black001 Wrote: Use the newest version of the emulator and use OpenGL instead of DX11. I can not begin to describe how immensely fast OGL is compared to DX11. I know you card supports it as its a better card than what I have.

OGL slows mine down.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply




Users browsing this thread: 1 Guest(s)