Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Black Screen issue
#1
Hello....been a user of the old PCSX and now with this its looking real nice to be able to emulate the PS2. If I can get it to work. I'm pretty good with a lot of stuff so this has me stumped. I have all the BIOS files from my PS2 and even tried renaming them to .rom1, rom2 etc. The issue is a black screen when running an ISO of a game. One thing I noticed is when I click on Config-->Plugin\Bios selector I see the following error appear on the console window:

Path: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll

I have installed PCSX2 on my D: drive to avoid rights issues and have also tried running it as admin. I read somewhere about compatability issues with Intel chips and Graphics cards using GSDX. I switched to SSE2, SSE41 and SSSE3 and same issue. Now I'm thinking it may be the BIOS files.

I run Win7 64. Here's a copy of the log:

PCSX2 1.0.0.r5350 - compiled on Aug 1 2012
Savestate version: 0x9a080000

Host Machine Init:
Operating System = Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit
Physical RAM = 16375 MB
CPU name = Intel® Core™ i7 CPU 960 @ 3.20GHz
Vendor/Model = GenuineIntel (stepping 05)
CPU speed = 3.206 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3bd
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Reserving memory for recompilers...

Loading plugins...
Binding GS: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\gsdx32-sse4-r5350.dll
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce GTX 580 (8.17.13.142)
Binding PAD: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\lilypad-r5350.dll
Binding SPU2: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\SPU2-X.dll
Binding CDVD: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\cdvdGigaherz.dll
Binding USB: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\USBnull.dll
Binding FW: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\FWnull.dll
Binding DEV9: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9640 games on record (loaded in 154ms)
Path: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
File is not a valid dynamic library.
Some kinda plugin failure: D:\Library\Video Games\PS2\Emulation\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll

Bios Found: USA v02.20(05/09/2006) Console
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(08-14-2012, 06:48 AM)jesalvein Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

- Win7 64 bit Pro. Direct X updated. Intel® Core™ i7 CPU 960 @
3.20GHz.
- NVIDIA GeForce GTX 580
- 16gb RAM

- PCSX2 1.0.0.r5350 (ran as admin, also tried uninstalling and installing to another drive)

- Default plugins. At this point I dont want anything that may cause an issue.

- ISO ripped copy of Taito Legends 1 and also Capcom Classics collection 1. Used IMG BURN on one and the other I grabbed a copy from a friend (to make sure its not a burning issue. I own both games so I can rip them again). Both show as green and compatable.


Me and a friend of mine on another message board are narrowing it down a bit. He gave me his config log since we both have similar machines. He's on PCSX2 0.9.8.r4600 and I also tried that build but I still get a black screen.

At this point I may redump my BIOS files and also try it out on another PC. Any thoughts you might have though are appreciated.
Reply
#4
I believe a check in just before 1.0 has broken Dx11 on Nvidia hardware

its working in the latest trunk though :\
Reply




Users browsing this thread: 1 Guest(s)