Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Black flicker every 11 seconds or so w/ GSdx 0.1.16
#1
Hello, I'm having an interesting problem. When using GSdx 0.1.16 (hardware, software, dx9, dx10, it doesn't matter) the screen quickly flashes black about every 11 seconds, as if a single black frame is being rendered.

This problem does not exist with version 0.1.14, leading me to believe .16 is responsible and not an external source such as the video card.

I have fiddled with nearly all the video options on a variety of games to no avail.

What's interesting is that I tried to capture a video to show this problem but the video played back without the flickers, even though they were occurring while it recorded. It sounds like an output problem and not something with the actual rendering.

Any help is greatly appreciated. I would just use 0.1.14 but .16 runs much, much better and without any artifacts. Thanks.

Reply

Sponsored links

#2
Make sure Vsync is off in PCSX2's settings (I already presume you use 0.9.7 beta). It's located in Config->Video(GS)->Window Settings. Then make sure it is also disabled from your video card drivers (check the control pane of your video card, it's usually there).
Make sure all speed hacks are off and you are not using Frame skipping
[Image: newsig.jpg]
Reply
#3
Thanks for the fast reply!

And yes, I am using 0.9.7. I have tried vysnc off, I can see the difference visually (tearing) but the flicker remains. It's also worth mentioning that vsync works fine with .14. Speed hacks/frame skipping were never on.

Any more help is appreciated.
Reply
#4
If you're on Windows Vista/7 try disabling Aero. Make sure frame skipping is off by pressing Shift+F4 while playing and checking it on the console log (should say frame skip enabled/disabled).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
(09-22-2010, 03:08 AM)Shadow Lady Wrote: If you're on Windows Vista/7 try disabling Aero.

Wow, you're awesome. Worked like a charm, thanks!
Reply
#6
So here's another case of this. Hmm :/
Reply
#7
Exact same problem here. Disabling Aero only partially fixes the problem, as now i'm getting the flicker on half the screen instead of whole which is just as annoying. happens on all games on most revisions of gsdx 0.1.15 and every gsdx 0.1.16. no problems on versions up to 0.1.14. Any more idea's?
Reply
#8
(04-30-2012, 04:30 PM)Tence Wrote: Exact same problem here. Disabling Aero only partially fixes the problem, as now i'm getting the flicker on half the screen instead of whole which is just as annoying. happens on all games on most revisions of gsdx 0.1.15 and every gsdx 0.1.16. no problems on versions up to 0.1.14. Any more idea's?

make a new thread pal.
better close this 1.5 yo dead thread now.
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#9
(04-30-2012, 04:38 PM)tallbender Wrote: make a new thread pal.
better close this 1.5 yo dead thread now.

Yeah I was gonna make one but I did a search and found this.
I have the exact same problem and it hasn't been fixed so even though it's pretty old, it's still relevant. making a new thread would just prompt the same solutions given in this one, which don't work.
Reply
#10
I guess this thread is kinda dead, but i spent a lot of time to find solution for this problem.

Same story: .0.1.14 - all is ok
.0.1.16 - flickering (tried on FFX)

I'm writing here for 1 reason - this is 1 of 2 threads, that I found via google about this problem, so I decided to spent some time on registration etc.

Tried lots of things - disabling aero, open exe as an admin. etc.


But the only thing that helped is interlasing, try to use AUTO instead of BLEND. (The aero was off and the emu was opened as an admin. But, like i said, both of this options made no changes without interlasing tweaks).

I'm terribly sorry, if there are already some threads with solution to this. Anyways, hope this helps.
Reply




Users browsing this thread: 1 Guest(s)