Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Black runs not quite at fullspeed
#1
This compatibility thread states that Black runs fullspeed on a i7 @ 3,4Ghz
http://forums.pcsx2.net/Thread-Black-SLU...6-U--29028

My PC:
i5 4670k "Haswell" @3,4Ghz (3,8Ghz Turbo)
Radeon HD 7870
8GB DDR3-1600 RAM

PCSX2 Version used: 5732
default settings + all recommended speedhacks enabled

I get 60fps at the beginning of the first level, but then the fps drop to 50 when down on the street and looking along the street. So not quite fullspeed - or maybe PAL fullspeed ;-).

AFAIK the i7 schould be 5-10% faster than my i5 - but this still doesn't explain why he gets fullspeed and I not (I lack ~ 17% speed for fullspeed)

Which Setting to adjust to get more fps?
Are there parts in the game where the performance demand is even greater or will it run with those 50-60fps to the end?
Overclocking is of course an option - but i'd like to tweak the settings first (+ save the environment :-) )

I have not a lot other games for testing, but Tekken 5 runs great
Reply

Sponsored links

#2
Turn on all recommended speedhacks and the MTVU multi-core speed hack in settings. This should net you a good speedup. Might as well set the two sliders (don't remember what they control, not on my PC right now. Vu speed and EE cycle stealing?) to two if that's still not fast enough for you.
Reply
#3
As mentioned above the recommended speedhacks (inclusive MTVU) are enabled

Messing around with VU Cycle stealing yielded some strange effect - I got 60fps shown but the game still "felt" slow, like it was less fps.

But I found out that switching the renderer from DX9 to DX11 did the trick - now the fps stay @ 60.

I'll play a bit further and try to observe how the fps behave
Reply
#4
@TC

Your processor is very fast, but I've never played this game on PCSX2 so I dunno if it's hard to emulate or not. I do know that this game had slowdowns even on the PS2, so even if you get 60fps on this emu, you will have 'natural slowdown' because that's how it was on the actual PS2.

You said you switched the gsdx renderer to DX11 which gave you 60fps constantly, so that's good.

I would say to not mess with the VU and EE sliders unless there's literally nothing else you could do. For example, I would overclock before messing with those. It's best to leave them both at their default values (i.e. '0') and only use the recommended speedhacks and MTVU hack. Though sometimes even the MTVU hack can actually break some games or make them slow down, it varies from game to game so you'll just have to experiment as you go on.
Reply
#5
Agree with above. If you can overclock, you should. It's way better than using software based speedhacks and almost always yields better results.
Reply
#6
(10-12-2013, 12:04 AM)wyndnra1n Wrote: Agree with above. If you can overclock, you should. It's way better than using software based speedhacks and almost always yields better results.

Dunno, this is not my experience from many games which I've tested, including some very popular ones. I think Presets 3 (recommended hacks plus EE cyclerate at 1 click) and 4 (adds VU cycle steal 1 click), and sometimes even 5 (adds yet another EE cyclerate click), usually increase speed without negative effects (per game, of course - the higher the more likely to cause issues).

I'd consider Presets 3/4 to be a good default when trying a new game, and only if it has issues like false fps / slow playback, then turn it down a notch or two.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#7
MTVU actually makes Black run 5-10fps slower, at least on the Q9400 running at 3.3Ghz I tested it on recently.

Personally, you should disable MTVU, then set software threads to 2 or 3, and try running in software rendering mode. (F9). Also, make sure you use DX10/11 mode in Gsdx, and preferably the SSE4.1 version of the plugin. Black's GFX emulation is missing most of the special effects in hardware rendering - even stuff like streetlight beams don't render.
Reply
#8
(10-13-2013, 03:57 AM)Ambient_Malice Wrote: MTVU actually makes Black run 5-10fps slower, at least on the Q9400 running at 3.3Ghz I tested it on recently.

Personally, you should disable MTVU, then set software threads to 2 or 3, and try running in software rendering mode. (F9). Also, make sure you use DX10/11 mode in Gsdx, and preferably the SSE4.1 version of the plugin. Black's GFX emulation is missing most of the special effects in hardware rendering - even stuff like streetlight beams don't render.

ah, thanks for those tips!
I've had a feeling that something was missing! In Software Mode you get the Blur-distance-focus effekt when reloading etc.
So yeah, with MTVU disabled + Softwaremode with 3 threads I get decent performance, lowest value was somewhat 55fps on a critical situation.

So, I belive the Hardware rendering will recieve improvements in die future? Wait and see?
Reply
#9
In general Software mode will produce the most accurate emulation. I don't know if Hardware mode will improve like this in the future, but that is generally the goal of the current coders -- to improve emulation accuracy rather than improving speed/performance.
Reply
#10
The performance and visuals are fine - but the game still has some strange hickup - like i get spawned for no reason randomly on other locations in the first level

basicly the same as reported here
http://forums.pcsx2.net/Thread-Black-NTS...ems?page=2

too bad :-(
Reply




Users browsing this thread: 1 Guest(s)