Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Black screen w/ Sound when running Romancing Saga
#1
I'm having a problem with, I think, PCSX2 in general. I've been trying to play Romancing Saga: Minstrel's Song and I'm able to launch it with the default settings, but the screen remains black regardless of a full or quick start up. I can hear the intro music to the game start playing after a moment.I've thought that it might've been because I'm using the DX9 settings over DX11, but on top of the black screen I haven't been able to load anything without crashing out when selecting any sort of DX11 setting. Its more of a secondary problem that I could live without it working and sticking with DX9 unless it turns out to be the root of my issue.

My computer's specs are:
AMD fx4100 3.6ghz
Sapphire 6870 1gb
16gb RAM
Win7 HomePremium 64bit

I'm using the latest recommended build of PCSX2, 0.9.8 r4600 and I'm currently set to the default settings since all of the alterations I've read of and tried didn't change my problem. Not sure if this would make a difference, but I've tried both, running my game's via ISO and straight from my drive. I don't have any other of my Ps2 discs in a known location or I'd attempt to run other games as well.

Here is the entirety of the log of when I launch it using the full mode.
Code:
PCSX2 0.9.8.r4600  - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
    Operating System =  Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
    Physical RAM     =  16365 MB
    CPU name         =  AMD FX(tm)-4100 Quad-Core Processor
    Vendor/Model     =  AuthenticAMD (stepping 02)
    CPU speed        =  3.623 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  178bfbff 1e98220b
    x86EFlags        =  2fd3fbff

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX
    MMX2  .. SSE4a

Reserving memory for recompilers...

Loading plugins...
    Binding GS    : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 6.1.7601 (Service Pack 1 1.0)
AMD Radeon HD 6800 Series (8.17.10.1124)
    Binding PAD    : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
    Binding SPU2    : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\spu2-x-r4600 (2).dll
    Binding CDVD    : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
    Binding USB    : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\USBnull.dll
    Binding FW    : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\FWnull.dll
    Binding DEV9    : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 314ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
AMD Radeon HD 6800 Series (8.17.10.1124)
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: C:\Users\Taylor\Desktop\RomancingSaga\ROMANCINGSAGA.iso
    Image type  = DVD
    Fileparts   = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2218656 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0: C:\Users\Taylor\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Taylor\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v01.60(07/02/2002)  Console
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
GIFTAG warning, size exceeded VU memory size 400
GIFTAG warning, size exceeded VU memory size 400
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_212.63;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_212.63;1) Game CRC = 0x239CF68A, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_212.63;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_212.63;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_212.63;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(R5900) Re-executed ELF Entry point (ignored) [addr=0x00100008]

Thanks for taking the time to look at this. I hope there's a solution to this issue.
Reply

Sponsored links

#2
tried simply updating directx ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
I ran MS's setup for Directx and it basically said I've got an up to date version. Specifically, I went here and ran it. I couldn't really find much else on downloading/updating Directx. I'm able to run things like SR3/Skyrim/Civ5 without any issues, if that helps with anything. Windows update also didn't contain anything regarding a Directx update, unless they get named as 'general windows 7 updates.' Would having two monitors mess with the way pcsx2 runs?
Reply
#4
Quote:Would having two monitors mess with the way pcsx2 runs?
could be.
see if your Gpu driver has to be configured in some way to handle it
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
The only place I really know to look for driver settings is AMD's vision control stuff, I messed around with the settings checking the game with each change and its still behaving the same. I don't know if the GS displayed on the top of the window of the game is the graphics usage or whatever you'd like to call it, but sitting through the intro cutscene, listening to it, has its percentages ranging from 3-10% or so. I went and downloaded a gpu monitoring gadget that shows it being used at lower values as well, 0-10%ish. I made sure to close out everything before running it.

A common theme in the issues I came across when I was googling my issue was that it wouldn't load without a certain sound plugin in the older pcsx2 versions, but I don't think that could be the issue here since I'm actually getting playback from the game.
Reply
#6
(08-02-2012, 12:22 AM)jesalvein Wrote: could be.
see if your Gpu driver has to be configured in some way to handle it

Unlikely. I have 2 monitors and it runs just fine. But it depends on how its set up.

OP, are the 2 monitors used as 1 wide display or are both separate? Ie. is there a primary monitor or are programs stretched along all monitors?
Reply
#7
My monitors are setup as mirrored displays rather than eyefinity. So yes, there is a primary monitor.
Reply
#8
Could be a bad rip. The game was flawless when I tried it a while ago.
Reply
#9
I often use my HDTV when running PCSX2, in all modes w/o any problem.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#10
I've managed to get it working with pretty much all of the graphics plugins from the 0.9.7 beta (specifically r3878). Its even working when set to dx11. I guess there must be some issue with the combination of hardware I have and the current release's graphics plugins. Would I be fine with using these plugins from this previous version?
Reply




Users browsing this thread: 1 Guest(s)