Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Black screen when loading up time crisis 2 and 3?
#1
So like the title says every time I load up the games, the screen would turn black for minutes without showing anything even after speeding the games up...

So far I ran it using fast boot instead of full

I have tried another game similar, time crisis: crisis zone, which works compared to the other games...Is there possibly some settings that are screwing with the game? All of my other games work except for these two games
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • If you are playing them from ISO or DVD.

Thank You.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Go to Config > Emulation Settings, Speedhacks tab, and set EE Cyclerate to -1 (remove the preset on the bottom left if necessary).
Reply
#4
FWIW, this issue seems to happen on few old Japan bios versions and FlatOut's suggestion is the only way to fix it.
Reply
#5
(11-02-2016, 06:12 PM)refraction Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • If you are playing them from ISO or DVD.

Thank You.

hardware specs:
15 4460
r7 250x
12gb 1600mhz ram (8x4)
Windows 7 OS 64 bit

Version: 1.2.1 

Playing from iso extracted from a copy bought off amazon (not pirated) but may be a wee bit scratched 

(11-02-2016, 06:14 PM)FlatOut Wrote: Go to Config > Emulation Settings, Speedhacks tab, and set EE Cyclerate to -1 (remove the preset on the bottom left if necessary).

I recently found the thread where you solved this solution by that method, will use it if I have time
Reply
#6
Please update pcsx2
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(11-02-2016, 07:27 PM)jesalvein Wrote: Please update pcsx2

Will it overwrite the previous version or do i have to uninstall it?

Also when isntalling it, should I back up my saves?

(11-02-2016, 06:14 PM)FlatOut Wrote: Go to Config > Emulation Settings, Speedhacks tab, and set EE Cyclerate to -1 (remove the preset on the bottom left if necessary).

I see 1 but i don't see -1
Reply
#8
(11-03-2016, 02:20 AM)Themaxedgamer Wrote: Will it overwrite the previous version or do i have to uninstall it?

Also when installing it, should I back up my saves?


I see 1 but i don't see -1

You can keep both versions however I wouldn't recommend keeping 1.2.1.
What I do however recommend is keeping 1.4.0 and the latest 1.5.0 version

You should save your progress in your memory card and then backup the memory card files.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#9
(11-03-2016, 03:11 AM)lightningterror Wrote: You can keep both versions however I wouldn't recommend keeping 1.2.1.
What I do however recommend is keeping 1.4.0 and the latest 1.5.0 version

You should save your progress in your memory card and then backup the memory card files.

I'll backup my memory cards and just update to the latest one
Reply
#10
(11-02-2016, 06:14 PM)FlatOut Wrote: Go to Config > Emulation Settings, Speedhacks tab, and set EE Cyclerate to -1 (remove the preset on the bottom left if necessary).

Okay now I see that option but however, my game looks graphically weird and it is very slowed down?

Is there any way to speed it up and ensure that it doesn't look weird
Reply




Users browsing this thread: 1 Guest(s)