Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Black screen when running game
#1
Hello,

I am using pcsx2 0.9.6 and trying to play Mortal Kombat Armageddon on it. The problem is, whenever I run the game (either from mounted DVD image - mounted with powerISO - or .ELF file on harddrive), I get a black screen and nothing happens.

My system specs are:
Intel Q9550 processor
4GB DDR3 RAM
NVidia GTX 275 Video Card
Windows 7 Ultimate 32 bit (RTM version)
DirectX 10, latest NVidia drivers, running as administrator.

I have tried running with all the possible configurations and it still won't work. Eventual errors are that it can't find rom2 and erom drives and this: "XML Loader returned an error. Trying to load a pnatch... No patch found.Resuming execution without a patch (this is NOT an error). patchnumber: 0". I have also copied the pcsx2 folder from another computer running Windows XP on which the game works, but it will still display a black screen for me. I have also tried the same settings as that computer's, but all I get is a black screen. I can still see the FPS in the title bar varying slightly, but that's it.

I'm not sure what else I should post. If I left something out just ask and I'll post it right way. I really have no idea why this is happening.

Thanks in advance for any help on getting the game to work.
Reply

Sponsored links

#2
You sure the ISO file is fine? what happens when you try to run it from the disc? Try remaking the ISO.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
I tried running it from disk and the same thing happens. I don't think the ISO is damaged or anything, the same one works fine on another computer. Also tried XP compatibility mode, the same thing happens...
Reply
#4
i think i got your solution,got to gsdx tab and check window mode,and that should do
Reply
#5
Was like that by default, still the same. It only pops up a black window.
Reply
#6
(09-22-2009, 09:51 PM)Dorelian Wrote: Was like that by default, still the same. It only pops up a black window.

Dont Use Power/ISO program unless you HAVE to mount to disk to play (such as oblivion for PC that requires the disk)
instead open your PCSX and click config/configure go to the CDVDrom click configure yet again using linuz iso then select ISO button click on your ISO in your computer enable block dump and then click on then exit/reset the PCSX. re-open it click file/CD and your game will work, if it doesnt go to config/CPU then set the frame rates to 0 (for auto) and set frame rate to default (UV will cause games to crash even though it sets the frame rate perfect to ps2 game standards
Reply
#7
Thanks a lot, using linuz iso did it! Works great now!
Reply




Users browsing this thread: 1 Guest(s)