Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Blackscreen / FPS drop / audio stuttering
#1
Hey there,

Sorry that my first post has to be a "help me plawks" thread.

But, I need help Laugh trying to run this game, with it works fine (goes through first cinematic, menus and controls work fine) until I get to the second cinematic, then PCSX2 blackscreens, FPS drops to 15 and sound stutters a LOT.

I fixed the last two things by using the speedhacks but the game still blackscreens at that darn 2nd cinematic.

What can I do?

CPU: AMD II X2 550
GFX Card: NVIDIA GeForce 8400 GS
Memory: 3.2GB DDR RAM
OS: Win7 Ultimate 32-bit SP1

Version: 1.0.0, just downloaded it today.

Settings: All of these: http://puu.sh/1WZ8p the FPS drops / audio stuttering happened without them.

Game: Primal, ISO.

Thanks,
KeepBotting
PCSX2 newbie since Feburary 2013 Blush
Reply

Sponsored links

#2
1st never use vucyclestealing at 3 (or2 for that matter) it does more bad then good.
2nd primal is by my memory a really demanding game and your pc isnt really up to the task of running it decently at playable speeds.

im afraid you are stuck at playing on your ps2 for now Sad
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#3
(02-03-2013, 09:58 PM)WarWeeny Wrote: 1st never use vucyclestealing at 3 (or2 for that matter) it does more bad then good.
2nd primal is by my memory a really demanding game and your pc isnt really up to the task of running it decently at playable speeds.

im afraid you are stuck at playing on your ps2 for now Sad

Shoot.
Problem is, my PS2 broke about 3 months ago Sad

So there's nothing I can do? My PC seems to run the game just fine, except for the blackscreen thing.

I read somewhere else that this is caused by the BIOS, how would I find that out?
PCSX2 newbie since Feburary 2013 Blush
Reply
#4
(02-03-2013, 10:02 PM)KeepBotting Wrote: Shoot.
Problem is, my PS2 broke about 3 months ago Sad

So there's nothing I can do? My PC seems to run the game just fine, except for the blackscreen thing.

I read somewhere else that this is caused by the BIOS, how would I find that out?

it is almost never the bios fault that games dont run,
could you post the emulog after you get the blackscreen? (the big text aside the pcsx2 emu, all of it please, you can copy paste it in here)
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#5
(02-03-2013, 10:04 PM)WarWeeny Wrote: it is almost never the bios fault that games dont run,
could you post the emulog after you get the blackscreen? (the big text aside the pcsx2 emu, all of it please, you can copy paste it in here)
Code:
PCSX2 1.0.0.r5350  - compiled on Aug  1 2012
Savestate version: 0x9a080000

Host Machine Init:
    Operating System =  Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601),
32-bit
    Physical RAM     =  3326 MB
    CPU name         =  AMD Phenom(tm) II X2 550 Processor
    Vendor/Model     =  AuthenticAMD (stepping 02)
    CPU speed        =  3.113 ghz (2 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  178bfbff 00802009
    x86EFlags        =  efd3fbff

x86 Features Detected:
    MMX.. SSE.. SSE2.. SSE3
    MMX2  .. 3DNOW .. 3DNOW2.. SSE4a

Reserving memory for recompilers...

Loading plugins...
    Binding   GS: C:\Program Files\PCSX2 1.0.0\Plugins\gsdx32-sse2-r5350.dll
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce 8400 GS  (9.18.13.623)
    Binding  PAD: C:\Program Files\PCSX2 1.0.0\Plugins\lilypad-r5350.dll
    Binding SPU2: C:\Program Files\PCSX2 1.0.0\Plugins\spu2-x-r5350.dll
    Binding CDVD: C:\Program Files\PCSX2 1.0.0\Plugins\cdvdGigaherz.dll
    Binding  USB: C:\Program Files\PCSX2 1.0.0\Plugins\USBnull.dll
    Binding   FW: C:\Program Files\PCSX2 1.0.0\Plugins\FWnull.dll
    Binding DEV9: C:\Program Files\PCSX2 1.0.0\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9640 games on record (loaded in 216ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
    Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce 8400 GS  (9.18.13.623)
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
    Opening CDVD
isoFile open ok: C:\Users\KeepBotting\Desktop\Primal.iso
    Image type  = DVD
    Fileparts   = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1940464 sectors)
    Opening USB
    Opening FW
    Opening DEV9
McdSlot 0: C:\Users\KeepBotting\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\KeepBotting\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
    Bios Found: USA     v01.60(07/02/2002)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_971.42;1) Game CRC = 0xFCD89DC3, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(R5900) Re-executed ELF Entry point (ignored) [addr=0x00100008]

All of the log text is outputted *while* it's loading the game, and nothing else happens while I'm playing it (watching the cinematic and going through the menus).
PCSX2 newbie since Feburary 2013 Blush
Reply
#6
As the blackscreen happens just after a cinematic (or before, whichever you mean) if could be that causing the hang, so my first suggestion would be to try the skipmpeg gamefix under the config->emulator settings-> gamefixes menu.

If that doesnt help, you could try the EE Timing fix. If that doesn't work, you might be out of luck, but you could as a last ditched attempt try the latest svn version from here: http://pcsx2.net/download/development/svn.html
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(02-04-2013, 12:58 AM)refraction Wrote: As the blackscreen happens just after a cinematic (or before, whichever you mean) if could be that causing the hang, so my first suggestion would be to try the skipmpeg gamefix under the config->emulator settings-> gamefixes menu.

If that doesnt help, you could try the EE Timing fix. If that doesn't work, you might be out of luck, but you could as a last ditched attempt try the latest svn version from here: http://pcsx2.net/download/development/svn.html

Didn't work Sad Skip MPEG only skipped the first cinematic and EE Timing Fix didn't do anything.

Would these have anything to do with my problem?

Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
PCSX2 newbie since Feburary 2013 Blush
Reply
#8
Nope.
Those files arent needed by pcsx2 and will appear only if you decided to copy them from your ps2 with its bios.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
(02-04-2013, 01:19 AM)jesalvein Wrote: Nope.
Those files arent needed by pcsx2 and will appear only if you decided to copy them from your ps2 with its bios.

Dang. I was hoping to relive a bit of my childhood with this game.

So what IS the problem? Just my computer is crappy?
I don't understand how that could be, as I was running 60 FPS right up until the blackscreen.
PCSX2 newbie since Feburary 2013 Blush
Reply
#10
what i am curious about is the following text in his log:

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_971.42;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

why does pcsx2 reads the disk multiple times?
when i play a game not even once does this text apear in the emulog text. :/
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply




Users browsing this thread: 1 Guest(s)