Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Blinking graphics in Prince of Persia: The Sands of Time
#1
I've been trying to get Prince of Persia: The Sands of Time to work for a little while. I've searched the forums, but there doesn't seem to be too much info on SoT. The wiki says it's playable, but that's going all the way back to r1713.

Several parts of the scenery (and even the prince himself at some points) disappears and reappears (blinks on and off) as I move through the start of the game after the intro scene. There are no errors in the logs as I'm moving throughout the level.

Are there any special settings that need to be set for this game?

Current settings (using default plugins and pcsx2 4965):
  • Speedhacks turned off (seemed to improve the situation a bit, though it is still there)
  • GSdx set to Direct3D Software (to troubleshoot) with 4 threads. Interlacing is turned off.
  • All other settings are set to default
Here is the relevant log info:
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_207.43;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_207.43;1) Game CRC = 0x7F6EB3D0, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_207.43;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC

Any info is greatly appreciated. Sorry if this is a known issue or if I've missed something obvious Blush
Reply

Sponsored links

#2
Try setting EE and VU clamps to their max (full and extra and preserve sign). Also keep the rendering threads to 3 since you also need 1 thread to be free for the PCSX2 core Tongue
[Image: newsig.jpg]
Reply
#3
(11-12-2011, 06:04 PM)Bositman Wrote: Try setting EE and VU clamps to their max (full and extra and preserve sign). Also keep the rendering threads to 3 since you also need 1 thread to be free for the PCSX2 core Tongue

Thanks for the suggestions Bositman. I set the rendering threads to 3, and set the clamping modes to Full/Extra + Preserve Sign. This had no effect on the blinking scenery.

In a few more attempts, I also tried setting the round modes to 'Nearest', as well as trying to play directly from the disc. Unfortunately, none of these changes had any effect.

I've attached an image showing a frame at the beginning of the game with missing scenery. Is anyone else having this issue?

   
Reply
#4
Yeah it's pretty much known I'm afraid. Did you try using a software renderer with GSdx? (you can toggle it while running the game with F9). You could also try using superVU in the VU settings but other than these not much else you can do
[Image: newsig.jpg]
Reply
#5
Apologies for bumping this thread, but I wanted to note that this game hangs when using the EE interpreter in case this was worthy information.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#6
hangs or runs really slow? theres a difference Tongue2
Reply
#7
It hangs; it'll report running at about 20 FPS, and the audio will go at about 1/3rd speed for about 2 seconds before dying out completely.

(Unless, of course, it's giving me false FPS).

Edit: I was mistaken, the audio doesn't die out, however it still seems to hang on the same frame. I'll leave it running for about five minutes to see if it budges.

Edit: Yep, left it on for about 5 minutes and the game has not advanced one frame.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#8
I know it an old thread, but I have the exact same problem, I tried everything that was suggested here, max clamps and software more but it doesn't make a difference.

   
Reply
#9
Sorry, the game is still status 'ingame' which means it has bugs which you cannot surpass to play the whole game.
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)