Thread Rating:
  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Blood Omen 2 (PAL) - Textures + widescreen problem
#1
Dear users,

I have started to play Blood Omen 2 (PAL/GER) and I ran into a couple of very minor, yet annoying issues. I'd really appreciate any kind of help. First off, the textures are flickering and changing randomly - as if it's picking any random game texture.
GIF:
http://www.abload.de/image.php?img=ezgif...3t1sua.gif
Any way to fix this?

The other problem is that I can't get the widescreenhack running. I put the correct PAL pnach into the corresponding folder (cheats_ws) and it doesn't work. Is the German version of Blood Omen 2 responsible for this incompability?

Quote:PCSX2 1.3.0-20140828202355 - compiled on Aug 28 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System = Microsoft (build 9200), 64-bit
Physical RAM = 8141 MB
CPU name = Intel® Core™ i7-4720HQ CPU @ 2.60GHz
Vendor/Model = GenuineIntel (stepping 03)
CPU speed = 2.592 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 7ffafbbf
x86EFlags = 2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. FMA

Reserving memory for recompilers...

Loading plugins...
Binding GS: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\plugins\GSdx32-SSSE3.dll
Windows 6.2.9200
Binding PAD: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\plugins\LilyPad.dll
Binding SPU2: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\plugins\SPU2-X.dll
Binding CDVD: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\plugins\cdvdGigaherz.dll
(GameDB) 9653 games on record (loaded in 189ms)
Binding USB: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\plugins\USBnull.dll
Binding FW: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\plugins\FWnull.dll
Binding DEV9: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\plugins\DEV9null.dll
Plugins loaded successfully.

HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.2.9200
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
* SPU2-X: Enumerating PortAudio
*** Device 1: 'Lautsprecher (Realtek High Definition Audio)' (Windows DirectSound)
*** Device 2: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows DirectSound)
*** Device 3: 'Lautsprecher (Realtek High Definition Audio)' (Windows WASAPI)
*** Device 4: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows WASAPI)
*** Device 5: 'SPDIF Out (Realtek HDA SPDIF Out)' (Windows WDM-KS)
*** Device 6: 'Speakers (Realtek HD Audio output)' (Windows WDM-KS)
Opening CDVD
isoFile open ok: E:\PS2 Games\Blood Omen 2 - The Legacy of Kain Series (Germany).iso
Image type = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1251408 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\memcards\Mcd001.ps2
McdSlot 1: E:\pcsx2-v1.2.1-545-g80df352-windows-x86\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe v01.60(04/10/2001) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_508.15;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SLES_508.15;1) Game CRC = 0x1897D0F7, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_508.15;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
Overall 0 Cheats loaded
Overall 0 Widescreen hacks loaded
Trap exception at 0x00461d88
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps

This is my first thread, so I hope I didn't do anything wrong. Unsure

Greetings Smile
Reply

Sponsored links

#2
The texture flicker might be due to GSDX hardware mode not supporting mipmaps - using software mode (press F9 to switch to it) might be the only way to fix it for now. (searched and found this post with info about the issue.)

Someone else might be able to help with the widescreen patch
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#3
Rename the widescreen patch to 1897D0F7 and see if it works.
If it does, let me know so I can archive it.
Reply
#4
Thanks for the quick answers. I guess mipmaps isn't a problem which can be solved anytime soon...

(07-27-2015, 10:37 PM)Devina Wrote: Rename the widescreen patch to 1897D0F7 and see if it works.
If it does, let me know so I can archive it.

Thanks, it finally did get recognized, but now I get m_merge is NULL error messages with an instant crash as soon as the game starts. Turning off interlacing and other options can "run the game" with a black screen and constant m_merge error messages... so not playable anymore.
Reply
#5
PCSX2 1.3.0-20140828202355 - compiled on Aug 28 2014 <-- This is a year old 1.3.0 GIT, either use the stable 1.2.1 or the latest 1.3.1 GIT
[Image: newsig.jpg]
Reply
#6
(07-28-2015, 10:15 AM)Bositman Wrote: PCSX2 1.3.0-20140828202355 - compiled on Aug 28 2014 <-- This is a year old 1.3.0 GIT, either use the stable 1.2.1 or the latest 1.3.1 GIT

Unfortunately this didn't solve my problem. I have used 2.1.1 and a 1.3.1 GIT version. I noticed that deleting everything after the "gameplay fix" section in the pnach file, fixed the m_merge error but the game still doesn't work in widescreen format (stretched image). It says now that 2 widescreen patches have been loaded (or 5 if I don't delete those lines).

Quote:deleting this part fixed my problem but widescreen is still disabled:

//black border fix by nemesis2000
patch=1,EE,002d24cc,word,00000000

//FMV's fix by nemesis2000
patch=1,EE,002e9380,word,240575e0
patch=1,EE,002e9398,word,240a1440
Reply
#7
I'll double check it. It's likely it needs a port job then. I'll try porting it this week.
Please stay tuned to the widescreen patches thread (in my sig).
Reply
#8
Patch is in my latest archive. Give it a try.
Reply
#9
(08-01-2015, 11:25 PM)Devina Wrote: Patch is in my latest archive. Give it a try.
It works perfectly, thank you so much!  Biggrin
Reply




Users browsing this thread: 1 Guest(s)