Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Budokai 3 Error
#1
Hoi,

everytime when i start a battle pcsx2 gives me this error

/build/buildd/pcsx2.snapshot-5327/common/src/Utilities/Linux/LnxHostSys.cpp(64) : assertion failed:
Function: void SysPageFaultSignalFilter(int, siginfo_t*, void*)
Thread: MTGS
Condition: false
Message: Unhandled page fault @ 0x00000000

Stacktrace:
[00] 0x0xf6b381f0
[01] GSDeviceOGL::IASetVertexBuffer(void const*, unsigned int)
[02] GSDeviceOGL:WackotretchRect(GSTexture*, GSVector4 const&, GSTexture*, GSVector4 const&, unsigned int, GSBlendStateOGL*, bool)
[03] GSDeviceOGL:WackotretchRect(GSTexture*, GSVector4 const&, GSTexture*, GSVector4 const&, unsigned int, bool)
[04] GSDeviceOGL:LaughoMerge(GSTexture**, GSVector4*, GSTexture*, GSVector4*, bool, bool, GSVector4 const&)
[05] GSDevice::Merge(GSTexture**, GSVector4*, GSVector4*, GSVector2T<int> const&, bool, bool, GSVector4 const&)
[06] GSRenderer::Merge(int)
[07] GSRenderer::VSync(int)
[08] GSRendererSW::VSync(int)
[09] GSvsync



what to do?
Reply

Sponsored links

#2
Can you post your GSdx.ini, which GPU/drivers ? Did the issue appears with others games (one that may have Tongue2) ?
Reply
#3
gdsx.ini =
ModeHeight = 480
ModeWidth = 640
ShadeBoost = 0
ShadeBoost_Brightness = 50
ShadeBoost_Contrast = 50
ShadeBoost_Saturation = 50
UserHacks = 0
UserHacks_AlphaHack = 0
UserHacks_HalfPixelOffset = 0
UserHacks_MSAA = 0
UserHacks_SkipDraw = 0
UserHacks_SpriteHack = 0
UserHacks_WildHack = 0
aa1 = 1
aspectratio = 1
debug_ogl_shader = 1
dump = 0
extrathreads = 0
fba = 1
filter = 1
fxaa = 0
interlace = 7
logz = 0
mipmap = 1
msaa = 0
nativeres = 1
paltex = 0
renderer = 12
resx = 1024
resy = 1024
save = 0
saven = 0
savez = 0
shadeboost = 1
upscale_multiplier = 1
vsync = 0
windowed = 1


Got me a 560Ti with 302.17 Drivers
Was my first Game.. got myself a Copy of Okami gonna try it today
Reply
#4
Getting the same issue with a different game (same error log).
Reply
#5
I get this issue with all games with GSDX OpenGL plugin from all later 0.9.9 SVN releases and 1.0. That's why I'm using last year's "unofficial build" 0.9.9 r-4920 GSDX with SDL. The older version works perfectly. My graphics card is Nvidia GeForce 220, max of OpenGL 3.3.
Reply
#6
(08-08-2012, 11:44 PM)DaTankAC Wrote: I get this issue with all games with GSDX OpenGL plugin from all later 0.9.9 SVN releases and 1.0. That's why I'm using last year's "unofficial build" 0.9.9 r-4920 GSDX with SDL. The older version works perfectly. My graphics card is Nvidia GeForce 220, max of OpenGL 3.3.

Thanks for the tip, just tried that build and the games I were trying earlier are working great!
Reply
#7
I'm wondering if it has to do with the newest PCSX2 needing OpenGL 4.2 compatible graphics card. I'm not an expert. It's just a hunch.
Reply
#8
Not related to openGL4.2. That not normal. Is someone will be able to build a debug version of GSdx?
Reply
#9
Is everybody have an nvidia card?

Did you activate MTVU speed hack?
Reply
#10
updated auf latest revision (1.0 from paa)

seems to work now.. a little disappointed with the speed but its working
Reply




Users browsing this thread: 1 Guest(s)