Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Another Century's Episode 3 [NTSC-J]
#1
Game runs just fine, usually at 100% (except when doing something intensive like Freedom+METEOR's beamspam attack). However, there is a crash when you start into a video. Oddly enough, it's only if a video follows a loading screen. For instance, if you try to watch an in-game video from the "View Mission Videos" menu, it'll crash every time. If you try to play Mission 2, it'll crash (because there's a movie right after the loading screen). Mission 1 works fine, because immediately following the loading screen is combat. And the movie clip in Mission 1 works fine because it's played in the middle of gameplay, without loading screen interruption.

This bug does not occur in 0.9.4, though the whole game runs at around 75-80% in that older version. The bug happens in 0.9.6, as well as svn791 and svn831. It happens whether I have no speed hacks enabled (and default cycle rate) or all speed hacks enabled (and 1.5 cycle rate). Changing plugins does not seem to solve the issue.

[Image: pcsx2ace3movieerr.jpg]

Current Settings:
svn831
CPU: All Enabled, Limit
Gamefixes: None
Speed Hacks: 1.5 Cycle Rate, All Others (Reverting to default does NOT fix)
Advanced: EE: ChopZero, None, DenZero; VU: ChopZero, None, DenZero

Plugins:
GSdx 834: DX10Hard, 1024x1024, Weave bff
SPU2-X r829 (changing to PEOpS didn't fix)
SSSPSXPAD
LinuzISO 0.8.0
Dev9null
usbnull
firewirenull

Hopefully that helps? If there's any other tests/settings you'd like done, let me know.

Sponsored links

#2
Try in advance option to default first and try with various settings in there. Try to change your plugin cd/cdvd with something else rather than linuzISO, try one by one. Try with various gsdx plugins and directx.9 mode too to eliminate an issue between pcsx2 and plugins issue.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
#3
(03-27-2009, 09:20 AM)Register Wrote: Try in advance option to default first and try with various settings in there. Try to change your plugin cd/cdvd with something else rather than linuzISO, try one by one. Try with various gsdx plugins and directx.9 mode too to eliminate an issue between pcsx2 and plugins issue.

Roger that. I have done as asked, and here are the results.

svn831
Set Advanced back to defaults: Same error, same conditions
Mounted ISO, used Gigaherz: Same error, same conditions
Mounted ISO, used PEOpS CDDA: Same error, same conditions
Advanced Default+FlushToZero (both checked): Same error, same conditions
Advanced Default+AllChecksUnchecked: Same error, same conditions
Advanced Default+ClampFull/ClampExtraPreserveSign: WORKS! Slow, but works.
Advanced Default+ClampFull/ClampNormal: Same error, same conditions

Interestingly, while it does slow down... it doesn't lag horridly like normal. When the emulation slows, it's like the game just waits to catch up. It's very smooth, fluid. Unless the speed drops into the sub-70% range, it's hardly noticeable.

On that note, I discovered another slight issue. In training mode, when using God Gundam, the BGM does not recover after leaving Hyper Mode. That is, Domon's Hyper Mode BGM plays... but after doing a super move, the BGM is supposed to return to normal, and instead becomes a buzzing noise.
#4
i confirm that bugs from pcsx2 emulation and we hope Pcsx2 Team can fix that issue soon. About sound problem i bet you use spu2-x plugin or peopspu2 plugin.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
#5
So,is the bug fully gone with Full and Extra Preserve Sign? If so,I'll close this bug report
[Image: newsig.jpg]
#6
So high Clamping modes like Extra + Preserve Sign seems to help avoid unsuspecting crashes as well?
While it's currently too slow to put as the default, maybe a button can be made (outside of advanced options) to select all the best clamp modes for now?
#7
(03-27-2009, 12:33 PM)Nneeve Wrote: So high Clamping modes like Extra + Preserve Sign seems to help avoid unsuspecting crashes as well?
While it's currently too slow to put as the default, maybe a button can be made (outside of advanced options) to select all the best clamp modes for now?

Sadly, my first thought was, "Ooh! If it fixed crashing for ACE3, let's try Macross!" Unfortunately, no such luck...still crashes on boot.

And yes, now that there's at least a Clamp mode that works for ACE3, this bug report is over. Too bad the cutscenes don't work on the faster modes.




Users browsing this thread: 1 Guest(s)