Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Ar Tonelico 2 [NTSC]
#1
#Pcsx2-r478 and pg-vtlb-708
#All CPU options on, frame limit
#Gsdx890 SSSE3 0.1.14-native, ps3, filter, log. z, alpha | Peops SPU2 1.9.0 default settings | linuz Iso 0.7.0 | ssspsx pad 1.7 | other plugins null
#Advanced on default, no speed hacks or gamefixes
#This is already known but background images will split, this is seen immediately after booting the game and can be found at various points throughout.

ignore this----->Something else that I noticed was that there are sudden slowdowns when walking. It's strange because the emu says 60 fps even though your moving half as fast at most. The areas that are slowed down don't look like they have anything hard to emulate and it only happens in a small section of some maps. One place this happens is in the area one or two sections to the left from the entrance of Souffle Axis, by the wooden sign.

Another bug can make you fall through the floor. This normally occurs next to or when running at crates with items in them. Here is a link to a video of me falling through floor: http://www.youtube.com/watch?v=lZTpTg41Hko =P

As far as I know/have seen, none of these bugs effect you being able to complete the game. Also, as mods have stated before, the screen splitting bug is an IPU issue, not plugin.

Update, I went back to the spot I specified for slowdown to see if I had speedhacks enabled when I found it (i thought I didnt =/). And it seems like I did because, you ONLY get the slowdown with EE sync enabled, other speedhacks are fine, I tired them all. Retested falling bug as well, it still happens with no hacks. (wasn't sure if I had them disabled for that either =x)
Intel C2D E8400@3.0Ghz | 2GB DDR2@800Mhz | NVIDIA GeForce 9800GTX 512MB | Asus P5N-D nForce 750i SLI Chipset | XP Pro SP3 | SuperPI 1.5-1m in 15.5s
Intel C2D T7600@2.3GHz | 2GB DDR2@665MHz | 2xSLI NVIDIA GeForceGo 7950GTX 512MB | XP Pro SP3 | Alienware Laptop | SuperPI 1.5-1m in 23s

Sponsored links

#2
There is a fix for the broken backgrounds ... none for the falling through floors (that only happend on vtlb ... didnt happen in the old vm)

http://forums.pcsx2.net/thread-2518-post...l#pid20412
Fighting for peace is like ***** for virginity ...

Failure is not an option | It is bundled with your Microsoft product
#3
Interesting, I never noticed the bug of falling through floor...
Because 10 billion years' time is so fragile, so ephemeral...
it arouses such a bittersweet, almost heartbreaking fondness.
#4
To clarify, you only fall through the floor when you get near a treasure chest, regardless of if the item is still in them, right? If that's the case, just set the EE rec rounding mode to "Nearest" and that will go away.
#5
ugh should've made that other topic in bug reports too. there's already this thread so I'll just link it


http://forums.pcsx2.net/thread-3838.html
#6
(02-17-2009, 06:08 PM)Cpn. Bravo Wrote: To clarify, you only fall through the floor when you get near a treasure chest, regardless of if the item is still in them, right? If that's the case, just set the EE rec rounding mode to "Nearest" and that will go away.

Yes, you can still fall through even after taking the items. I just said "crates with items in them" because it doesn't happen next to those huge crates, only the small ones that do or have contained items.

And its not like the background fix is actually implemented in pcsx2 yet =x
Intel C2D E8400@3.0Ghz | 2GB DDR2@800Mhz | NVIDIA GeForce 9800GTX 512MB | Asus P5N-D nForce 750i SLI Chipset | XP Pro SP3 | SuperPI 1.5-1m in 15.5s
Intel C2D T7600@2.3GHz | 2GB DDR2@665MHz | 2xSLI NVIDIA GeForceGo 7950GTX 512MB | XP Pro SP3 | Alienware Laptop | SuperPI 1.5-1m in 23s
#7
I encountered the glitch myself, so I knew you could still fall through after you take the item out. Tongue

I didn't know about that Phase 5 thing though... Well, when I get there, I'll just play it on my PS2 if it's not fixed by then. If it really was a problem on the PS2 as well, you'd think more people would have mentioned it.

Edit- Menancewhite, when you say "I've tried using the latest 0.9.4 , 0.9.5 and PG builds" in that thread you made in the 0.9.5 board, do you mean the latest PG beta at whatever point you started playing, which would have been a VTLB version at the time, or what used to be the "official" PG download from the main pcsx2 website?

I remember now that I used to ignore any mention of that glitch because everyone that encountered it was using an old VM version, but I just read your post as if you were using the latest beta. I hope I just read it wrong and I can go back to ignoring it.
#8
Oh by that I meant I've tried:

The 9.4 version on the webpage
and old 9.5 version
the newest 9.5

and the PG build I've tried is the one from the zipfile on the homepage. I don't know where to get the latest PG beta.
#9
.. Playground is no more, get the latest beta here http://forums.pcsx2.net/thread-3716.html
#10
So it was the old VM version. In that case, you have the same problem as everyone else and unfortunately it doesn't look like anyone has found a solution that involves keeping your exact progress intact. You're going to have to use the latest beta, download a save file from Gamefaqs or somewhere else, and import it into a memory card using something like mymc(read this thread) if you want to pick up where you left off.

In the future, you should check the sticky threads in the board that has the latest beta(previously PG, now PCSX2 beta) so that you can stay up to date with any major changes that might occur, like the change from VM to Vtlb or the memory cards getting fixed.




Users browsing this thread: 1 Guest(s)