Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Devil Kings / Sengoku BASARA
#1
Information 
Salutations all. As this is my first post here and I only really started tracking PCSX2 the last couple months, I wanted to say I am amazed and appreciate the hard work that has gone into this project.

I wanted to bring up a graphical problem with Devil KINGS / Sengoku BASARA. I had tried searching for it for quite awhile now and I did see one posting here about it a few months back, but no resolution was ever really found. I wanted to bring it back up since the issue seems to persist. Thankfully the game is still 100% playable, it's more of a quality issue.

When playing the game, there is a weird overlay that covers everything and looks kind of ugly. It almost looks like some kind of shading/bloom/whatever layer that's just being put at the front of the screen instead of behind everything else. It happens on a majority of the stages, but not all of them.

I was able to solve it on some stages by going back to an old gsdx plugin, but this only solved one or two stages and made others unplayble as the screen would then be covered in white. It may just be a similar issue as to what happened with Tales of Legendia (which works great now, nice work).

The good news is that the game is emulated properly using software rendering. With the recent speed hack that was added which allows the emulator to utilize multiple cores, the game will even run at 100% speed using software.

The reason I brought it up is because I have been recording sessions on YouTube and Software mode slows to a crawl when FRAPS is also active on the PC and recording, which means I have to record in Hardware mode.

I have a link to one of the stages that has the issue and the next stage after also has it. My recordings were made using r4873. I tried using r4918 tonight and the issue still persists.

http://www.youtube.com/watch?v=XuClKmyz_...70&index=4

To be honest, the videos here are rather tame, but it gets pretty bad on some stages like High Temple (Honno-ji).
Reply

Sponsored links

#2
Welcome. First you should have read the sticky in this forum, to make a proper bug report. Anyway this does not belong here, since it works in software mode it is a clear GSdx issue, thus should be reported in the GSdx thread: http://forums.pcsx2.net/Thread-GSdx
You might be able to get rid of it in hardware mode using the skipdraw hack ( check the configuration guide in gs plugins->gsdx->hacks section to see how to enable it) and a value of 1 or 2 (or higher if that doesn't do it)
[Image: newsig.jpg]
Reply
#3
(09-20-2011, 01:05 PM)Bositman Wrote: Welcome. First you should have read the sticky in this forum, to make a proper bug report. Anyway this does not belong here, since it works in software mode it is a clear GSdx issue, thus should be reported in the GSdx thread: http://forums.pcsx2.net/Thread-GSdx
You might be able to get rid of it in hardware mode using the skipdraw hack ( check the configuration guide in gs plugins->gsdx->hacks section to see how to enable it) and a value of 1 or 2 (or higher if that doesn't do it)

That was quick. I was actually going back to pick up the information and edit the post, but you beat me to it. Smile I will look into that information and post in the link you provided if needed.

Thank you very much.
Reply
#4
Thanks for the help again, didn't seem to get it to work so I posted in the area you suggested.
Reply
#5
Damn, sorry wrong link.
http://forums.pcsx2.net/Thread-Devil-Kin...hic-glitch
Sorry once again.

You can see on his screens that he had the same bugs.
Reply
#6
as I don't have the game, I can't able to verify it's work or not , so I reopen the thread .
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply




Users browsing this thread: 1 Guest(s)