Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Godzilla - Save the Earth [PAL]
#1
# Pcsx2 version: r947
# Cpu eerec on, vurec0 and vurec1 on, MTGS on.
# Plugins used: Gsdx 887 0.1.14, SPU2-X 1.1.0
# Description: Game goes through the intro and the menu and menufunctions completely work. When starting a game in any gamemode at the end of the loading-screen, when the 3d scenes come, pcsx2 crashes with an acces violation (pcsx2.exe@0x20025aec, 0xC0000005: acces violation while writing to position 0x033d20c0 (ascending)).
Visual Studio points me to SysPrepareExecution( NULL ); (l.638) in WinMain.cpp
It goes ingame with 3 or 4 players but crashes at random.

There is also a problem with the speedhacks.
Default Cycle Rate: results in BlackScreen and the following message in the console:
Quote:Framelimiter rate updated (UpdateVSyncRate): 50.0 fps
vif1.cmd still set 6c
sceGsSyncPath: VIF1 does not terminate
<D1_CHCR=00000055:D1_TADR=01900000:D1_MADR=00000000:D1_QWC=00000000>
<D2_CHCR=00000001:D2_TADR=00000000:D2_MADR=0065ff70:D2_QWC=00000000>
<VIF1_STAT=00000041:GIF_STAT=00000004>
UNKNOWN VifCmd: 34
IOP Recompiler data reset
iR3000A Resetting recompiler memory and structures
x1.5 Cycle Rate: results in black screen without errormessage.
x2 and x3 Cycle Rate: The game works


Attached Files
.txt   emuLog_vif.txt (Size: 42,23 KB / Downloads: 245)
Reply

Sponsored links

#2
There are some informations missing.
Please read the stickies and edit them, we have a template there for reporting bugs
Reply
#3
I already read the stickies and thought i gave all required informations.

I now made it like the example.
If that helps.^^
If you want more information please ask (and please say which).
Reply
#4
O-kay...

Sadly I have to say that what I wrote above is not up-to-date anymore.
Now I tested the game with ZeroGS Playground 0.97.1 and the newest available svn (self-compiled) and it runs the full intro.
After that, there are te following messages (writen in RED):

vtlbDefaultPhyWrite128: 0x2000000
vtlbDefaultPhyWrite64: 0x12FCF0
vtlbDefaultPhyWrite32: 0x12FCF0
vtlbDefaultPhyWrite16: 0x12FCF0
vtlbDefaultPhyWrite8: 0x12FCF0
vtlbDefaultPhyRead128: 0x12FCF0
vtlbDefaultPhyRead64: 0x12FCF0
vtlbDefaultPhyRead32: 0x12FCF0
vtlbDefaultPhyRead16: 0x12FCF0
vtlbDefaultPhyRead8: 0x12FCF0
vtlb bus error : addr 0x12FCF0, mode 0

Maybe I will find out more later.
Reply
#5
Try our new svn snapshot, I posted it just now
Reply
#6
I am already using r478.
Btw. the Debug-version crashes with a mysterious Debug-Error.

Quote:Assertion failed!

Program: pcsx2-dbg-r478.exe
File: ..\..\x86\iVUzerorec.cpp
Line: 2770
Expression: x86regs[s_JumpX86].type == X86TYPE_VUJUMP

[...]

(Please Retry to debug the application - JIT must be enabled)

Edit: I clicked on "Next" in Visual Studio and got it to display some more useless information...
In the pcsx2-console (RED):
Quote:vtlb miss : addr 0x2000000, mode 1
vtlb miss : addr 0x8012FCF0, mode 0
vtlb miss : addr 0x8012FCF0, mode 1
vtlb bus error : addr 0x12FCF0, mode 0

vtlb bus error : addr 0x12FCF0, mode 1

vtlb bus error : addr 0x8012FCF0, mode 0

vtlb bus error : addr 0x8012FCF0, mode 1
after that in VS:
Quote:Unhandled Exception at 0x0040294f in pcsx2.exe: 0xC0000005: Acces violation while writing to Position 0x005991c5.


When I try it with the Devel-version, i am getting an acces violation with function

void __fastcall vtlbUnmappedVWrite128(u32 addr,const mem128_t* data) { vtlb_Miss(addr|saddr,1); }

marked in Visual Studio.
in vtlb.cpp (addr = 1244360, data = 244 'ô')
Reply
#7
OK I talked to the devs. This is an ugly bug, you'll have to wait. Just don't expect it to be fixed very soon
Reply
#8
Now, with r494, the game does not even show the intro anymore. There is nothing as I wrote in my first post. In r478 it still worked.
Reply
#9
I found out, what the problem was.
It is the changing of Vifdma.cpp in r489!
Maybe it would be a good idea to fix this.
With r570 the game works now until the end of the loadingscreen (the beginning of the 3dscene does not show) and then it crashes.

I will find the errormessages out now..
Reply
#10
Typhox:
Are you sure its that change and not the SPR one in the same commit?
(IE: when you put CPU_INT(1, 0); back in, does the game work then? )
Reply




Users browsing this thread: 1 Guest(s)