Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Gran Turismo 3 [PAL]
#1
PCSX2 Playground 1.0.0395 - TLB
Sound: P.E Ops SPU2 1.9.0
Graphics: Various
FPS: limited to 50, otherwise the sound plays too fast.

Problem: When trying to do any license in Gran Turismo 3, I get either graphic corruption or extreme slowdown.

See attached from the graphic corruption from two different Graphic plugins. The slowdown happens even though the FPS is steady at 50FPS

I've tried various plugins & settings and all result in the same issue. Also, I've tried PCSX2 0.9.4 and I had the same issue.

       
Reply

Sponsored links

#2
The game has never worked in pcsx2. Ever since my 1st play test of it in pcsx2 it crashed in the race setup screen.
Old habits die hard - System Shock
Reply
#3
(01-04-2009, 07:54 PM)icemann Wrote: The game has never worked in pcsx2. Ever since my 1st play test of it in pcsx2 it crashed in the race setup screen.

Midfield track works just fine even in 0.9.2. There is at least one more 'playable' track in GT3, but I can't remember its name now.
Reply
#4
(01-04-2009, 08:10 PM)rainbow Wrote:
(01-04-2009, 07:54 PM)icemann Wrote: The game has never worked in pcsx2. Ever since my 1st play test of it in pcsx2 it crashed in the race setup screen.

Midfield track works just fine even in 0.9.2. There is at least one more 'playable' track in GT3, but I can't remember its name now.

Is that in 0.9.2 proper your speaking of or the latest playground version? Asking as after reading your post I went and tested it in playground (r547) and got this screen, which is what happens to me on every race.

If this turns out to be another gsdx9 bug I`m going to be annoyed Tongue2.


Attached Files Thumbnail(s)
   
Old habits die hard - System Shock
Reply
#5
Original PCSX2 0.9.2. And as far as I remember, at some point (times of 0.9.4 and first 0.9.5 public betas) GSDX (or was it GSDX9?) started causing these crashes before every single race.

Try to run GT3 with some old version of GSDX or GSDX9 OR ZeroGS (0.9.6, not sure about 0.9.7(.1)) and at least Midfield track should work.
Reply
#6
I complete B-Lisence tests. Biggrin If you change Hardware to Software mode in GSdx (I used DX10) final b-licence test should work. Smile First two tests (acceleration and braking) buggy but can be completed. You have wait some minute (lags at startline) and use rear view to avoid emulator freezing. Tongue
P.S. Sorry for my terrible English.
PCSX2 r528 (18.02.2009)
Plugins used:
video : GSdx 1.14 r514
sound: ZeroSPU2 0.46 r514
Settings used:
CPU: all enabled, VU Skip.
Speed Hacks: Use x3 Cycle Rate + Enable IOP x2 cycle rate
Advanced: all settings to Nearest/None + Flush to Zero/Denormals are Zero
Hardware: Core 2 Quad Q6600 @3.0Ghz/4Gb/GeForce 8600GTS 256Mb
OS: Windows 7 Beta Build 7000 x86


Attached Files Thumbnail(s)
                   
Reply
#7
A-Licence:
A1 - ok
A2 - works with rear view trick
A3 - ok
A4 - buggy, lags after test selecting. If you quickly after selecting press "X" many times (this is start on next screen) emulator will crash with message on PS2 Output screen "vtlbDefaultPhyRead16: 0x1EEC0539"
A5 - same thing like A4
A6 - ok
A7 - Lags then entering to test and choose "START".


Attached Files Thumbnail(s)
   
Reply
#8
With r713, the GT3(NTSC) is playable even in cup races(well didn't test all but summer cup), but in the start of a race it needs to use the rear view trick for some minutes and then you can change back to front view, otherwise you get garbages like the ss Zeus999 posted in 1st post
[Image: attachment.php?thumbnail=12248]

here's a screen with the game working:
   

ow yeah, it only works with GSdx Software renderer, with hardware render it makes pcsx2 crash when loading the race.
AMD Athlon 64 3000+ @2.2Ghz 754 Newcastle/ASUS K8V-X/GeForce FX 5500 256MB AGP-8X Downclocked/Seagate Sata2 250GB/512MB DDR-400

[Image: psyalemao.jpg]
Reply
#9
There are several tracks in this game that doesn't work in hardware mode with pcsx2 0.9.7 beta revisions. Theese are for sure at the moment:
Trial Mountain Circuit
Trial Mountain Circuit Reverse
Deep Forest Raceway Reverse
Tokyo Route 246: Akasaka
Tokyo Route 246: Akasaka Reverse
Cote D'Azur

the bug looks like it's on the attached screen.


Attached Files Thumbnail(s)
   
AMD Phenom II 550 Black Edition @3.8GHz
4GB DDR2 1066MHz CL5-5-5-15
ASUS Radeon EAH4770 Formula 512MB DDR5
Reply
#10
I don't think it's a good idea to revive +1 years old threads. And you shouldn't be reporting bugs used in non-supported builds (0.9.7). Try the latest official beta (r.1888) and then you can give us some feedback Tongue
[Image: fs.png]
Q9550 @ 3,33GHz Ninja
HD 3850
Reply




Users browsing this thread: 1 Guest(s)