Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] MGS2 PAL (Non-substance)
#1
Hello, this is my first post, i've never felt in the need of posting anithing in two years, but i think you might want to know this bug (i don't know if it has been posted, i've searched for it and i didn't find anything).

The game runs smoothly even at 4x resolution, everithing works fine, blah, blah, blah.

The thing is, in certain areas, when you try to use the first person view to aim the weapon, it looks like Snake were in front of a wall, and it would not let you aim. The same thing happens when you try to drag a body in this areas, Snake picks the body, but inmediatly lefts it on the ground. When guards shoot you, the bullet cases from thair weapons stay freezed in mid air, and even the tranquilizer bullets from your pistol stay in the middle of the air, instead of imacting the target.

Needless to say, this makes the game very unplayable. I just advanced to the Olga fight (here, it's almost impossible to hit Olga, because of this bug)

I've tried with several settings, DX9/10 modes, native res, smooting off, speedhacks on and off, and everything that came to my mind.

I'm using 0.9.7, with the plugins that came packed with it, GSdx 1.16,and so on.

My PC Specs:

CPU: E8400 @ 3.6 Ghz
MoBo: Asus P5K Pro (P38 chipset)
RAM: 3Gb DDR2 @ 800 Mhz, 4-4-4-12 (GEIL)
G.Card: Radeon 5850 (Max OC from Catalyst, not much)
HDD's: 2 x SATAII RAID0

I hope this help you guys for improving this AMAZING piece of software.

Oh yes, i'm running the game from the ISO i ripped from my original (PAL) game.
Reply

Sponsored links

#2
I don't remember correctly but it's either microVU0 or superVU1 causing that problem, either way change the VUs to superVU (VU0) and microVU (VU1) which is the most compatible setting for this game.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
yes, this game is pretty much "play with Svu or don't play at all" (it's the same problem in the NTSC U/c version too by the way)
Reply
#4
Thanks guys, it worked like a charm. PC version suks, BTW LOL.

Thanks again.
Reply
#5
(02-26-2011, 08:25 PM)Saiki Wrote: yes, this game is pretty much "play with Svu or don't play at all" (it's the same problem in the NTSC U/c version too by the way)

Actually no... superVU1 has problems with the game so it's a "play with svu0+mvu1" thing instead Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
(02-26-2011, 08:56 PM)Shadow Lady Wrote: Actually no... superVU1 has problems with the game so it's a "play with svu0+mvu1" thing instead Tongue2
not come across any Svu issues with MGS2, I played through a good 80% on SVu, where mvu couldn't cut it.
Reply
#7
For me, having VU1 set as superVU made certain graphics disappear, like the right half of Snake's body. sVU0 was the only one that needed to be changed to fix the aiming issue.
Reply
#8
has something changed from r4600 to r4875 regarding this? Because I just don't get this problem when both VU0 and VU1 are set to MicroVU.
It's a weapon. It's REALLY powerful, ESPECIALLY against living things.
Reply
#9
(09-20-2011, 05:52 PM)Fezzer Wrote: has something changed from r4600 to r4875 regarding this? Because I just don't get this problem when both VU0 and VU1 are set to MicroVU.

I'm sure it has, but I can't confirm it.
Reply
#10
(09-20-2011, 05:52 PM)Fezzer Wrote: has something changed from r4600 to r4875 regarding this? Because I just don't get this problem when both VU0 and VU1 are set to MicroVU.

It's fixed now yeh, can use microVU0 just fine. Still same problems with superVU tho.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)