Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Metal Gear Solid 2: Sons of Liberty [NTSC]
#1
[Bug Report] Metal Gear Solid 2: Sons of Liberty [NTSC]

# PCSX2 Version: PCSX2 revision 1364
# CPU EErec on, VUrec0 and VUrec1 on, MTGS on (bug still occurs with Micro VU on)
# Plugins used: GSDX 0.1.15 revision 1376 (hardware and software, DX10)or ZeroGS 0.97.1, SPU2-X 1.1.0 revision 1368 or ZeroSPU2 0.4.6 revision 1214
# Description: Cutscenes seem to completely screw this game up for the most part. By that I don't mean there are any graphical glitches, but the cutscenes have extremely sporadic framerates. I could be watching a scene just fine at 60 FPS and then have it go down to 2 FPS or less even when there's hardly anything going on in the scene. Then it can go back up and back down very randomly.

For the first two hours of the game (until you take control of Raiden,) it seems fine. Very few framerate dips. But now it's gotten to the point where I've had to skip every cutscene I've come across (and if you've played a Metal Gear game, you know this is unbearable.) All this came to a head when I got to one cutscene where the game freezes as soon as it starts (or just goes very, very, very, VERY slowly.) I can't skip the scene either as it freezes and thus can't read my inputs.

I would attach a save but the forum isn't letting me.

Sponsored links

#2
if you are trying to attach a memory card, 7zip it then attach, there is a 4mb limit on here (i think) so obviously an 8mb card wont work Tongue2
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#3
Try the latest beta
#4
I got Snake invisible. Anyone know a solution? I have all speedhacks turned off and interlacing modes don't help. I have latest beta+plugins


Attached Files Thumbnail(s)
   
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit
#5
yeh use software mode, its a gsdx bug. he appears as soon as you get out of the rain.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#6
Hmm too bad. I guess I have to wait for fix, because SW mode is always bad.
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit
#7
Just switch to SW mode, then move to a better spot then flick back to HW.

Course it would be better to not have to do that at all, but meh. Have those speed slow down spots been fixed? On all of my tests of MGS2 in the first level in the absolute first bit of the game once you could move my speed always dropped when I would be at certain points outside the ship. Graphically they were no different to other parts, so it made no sense to me.
Old habits die hard - System Shock
#8
I found out that you can fix it by highest clamp mode
Taking my opinion back. It's fixedBiggrin
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit
#9
So... guys is it playable or not on the recent revs? I don't feel like looking for the cd in this mess called "my room"
#10
I guess it is playable. SPS is gone.
Left one is older revision.
Right one is current revision.


Attached Files Thumbnail(s)
       
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit




Users browsing this thread: 1 Guest(s)