Thread Rating:
  • 4 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Metal Gear Solid 2: Sons of Liberty [NTSC-J]
#1
At the end of the tanker mission, you are supposed to take 4 pictures of Metal Gear Ray, it is impossible to take successful pictures on 0.9.7(I have tried many different svn builds with many different settings), however it is working on 0.9.6.

After you submitting those pictures, this game will freeze at certain point of the following cut-scene on 0.9.6(It is impossible to test this cut-scene on 0.9.7 because of the above issue) unless you disable IOP recompiler.

Other issues:
This game is incredibly GPU intensive, my HD 4890 cannot keep 60fps(actually 30fps) at all even in native resolution, nVIDIA cards seem to be working faster.

Thermal goggles are not working with hardware rendering, as well as some 2D overlay effects during cut-scenes.
I think software rendering also has some problems, you can see infrared ray without wearing goggles, the visual of infrared ray will not disappear after you destroyed their control units.
Reply

Sponsored links

#2
Not a valid bug report, moved.

It's better to use microVU1 and superVU0 for this game, superVU0 will fix the issue you have with the camera as it's microVU specific and already reported in the microVU thread.
"Other issues" are GSdx specific, thermal goggles work with software rendering as you mentioned and speed isn't exactly a bug Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Thank you for your help
I have tested superVU0 and it is working, but my 0.9.6 emulator is also using microVU0 and nothing is wrong with photographing

Can I post a report about the "load original" function in many "warriors" games?
Reply
#4
Not sure what bug you mean but follow this thread next time you make a bug report:
http://forums.pcsx2.net/Thread-How-to-us...RE-posting

And make sure to post screenshots if possible of the problems so it's more descriptive.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
hello guys i am having some problems with this game too..

firstly can someone explain what this means please??

microVU0 Warning: Branch, Branch, Branch! [05c8]
cause my fps during videos are cool, but when the game starts
it drops to 21..

thanks a lot

EDIT: problem solved.. there is a pc version of the game.. and making it work on windows 7 seemed easier than messing with branches;p
Reply
#6
Hi I have a similar problem with MGS2. I passed the camera/picture taking part by using superVU0 and started the raiden mision. But the game hangs on the cutscene after Raiden takes off his mask thing. its on 3:02 on this youtube video http://www.youtube.com/watch?v=hAFORAZZymY (I hope that is allowed)

Is there a way I can skip this video. or do I need to reconfigure my settngs somewhat. they are all pretty much default except the Super VU0 and my PC does not support ssse 4.1 so im using SSSE 3. Any help will be greatly appreciated thanks. also if any has a memcard save at this point that would help too I suppose.

[Edit] I have added pics of my settings


Attached Files Thumbnail(s)
           
Reply
#7
You could try posting your memcard instead so someone passes that point for you (you might as well try from your memcard save too if you've been trying with save states), but that part works just fine. Those are not the default settings, disable synchronized MTGS, use microVU1, disable gamefixes, I suppose you have speedhacks too so disable those too.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
Okay I have disabled all those and still same thing. I am going to post my memory card now. Its the save with the longest time running 1 hour save number 01. not 00 or 02 you will know what I mean when you see it.

ok here goes. oh yeah it also said something about EE recompiler last time i tried loading it so yeah.

well heres the memory card if you could by pass that clip for me i would be very grateful.

http://kiddtic.filesharehq.com/download/...c0nULs2XnH please tell me if the link works.
Reply
#9
Is there a speceific thread I need to goto to do this?
Reply
#10
@kidditic

That cutscene uses insanely high Video memory. If I remember correctly you should be able to get past that point by using No GS Output option. Simply enable that option during the codec cnversation before the hang and disable it after you get past the cutscene.
Reply




Users browsing this thread: 1 Guest(s)