Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Project Zero 1 [PAL]
#1
My plugin config was this:
   

A strange bug, because it ONLY happens if you put the PAL version of Project Zero/Fatal Frame with the default 50 Hz in "Tv Mode" (the PAL version of Fatal Frame/Project Zero has a selector by default, I don't have a hacked version), if you put it to 60 Hz the problem is "solved". Blink

This "bug" happens when you pick the third part of the mirror, and a video plays, in some point of the video, the game freezes and show the "red letters" I put in the picture.
   

I forgot to put an image of the exact zone when the "bug" appears... here it is:
   

When you pick the 3º piece of the mirror, then, the video shows.

Angry Well!, I try continue the game in 60hz, BUT when you have to fight (photograph, better) the last boss, the game freezes with no error signal in the console; the game freezes when you try to use your camera to take a photo, but the sound continues. Ohmy

*Note: after the first "bug" if you have saved, you can continue playing using 50 hz, but the freeze bug (in the battle with the "cursed girl") happens "always", no matter if you use 50 or 60hz. Sad

This is the image of my freeze (I also freeze because I can't continue):
   

If this helps, the console says this:
   

I forget to put some "important" thing to make the game run, is this:
   

All my tests are with this FIX activated, because without it, the game crashes or doesn't work. Tongue
i7 920 2'66 Gig; 4 Gigs RAM (Dual); Geforce 9800 GTX+ 1024 RAM; X-Fi Titanium; MB: Asus P6T Deluxe; OS: Windows Vista Ultimate SP2 (32-Bit) and Windows 7 64-bits (Default OS)
Reply

Sponsored links

#2
I put now a "memcard" with the saves of the two "bugs" I find in the PAL version of Fatal Frame (in PAL: "Project Zero").

The first save is for the firt "bug" I mention here, it happens when you pick the third mirror, and a video plays. (Note: this bug only happens in PAL 50 Hz mode)

[Image: attachment.php?aid=22334]

The second save is for the other "bug", you need to pass some ghosts, and arrive to the "Gates of Evil", and when you search in the place for the mirror which is in front of the gates, a video shows, and then the entire screen changes and moves, here is when if you try to attack with the camera, the game freezes (sometimes you have time to use the camera 1 or more times, but usually, it freezes the first time you use the camera in this fight).

[Image: attachment.php?aid=22347]


Attached Files
.zip   Mcd001.zip (Size: 1,62 MB / Downloads: 135)
i7 920 2'66 Gig; 4 Gigs RAM (Dual); Geforce 9800 GTX+ 1024 RAM; X-Fi Titanium; MB: Asus P6T Deluxe; OS: Windows Vista Ultimate SP2 (32-Bit) and Windows 7 64-bits (Default OS)
Reply
#3
If I'm not mistaken there is a bug in Godhand PAL with 50hz mode too, lots of lines gets across the screen. Must be some kind of related graphical issue, who knows.
[Image: pibjimh9rqzvk1yz5kl.jpg]

Reply
#4
(05-14-2010, 07:14 PM)Gentleman Wrote: If I'm not mistaken there is a bug in Godhand PAL with 50hz mode too, lots of lines gets across the screen. Must be some kind of related graphical issue, who knows.

No, in Project Zero 1, the second "bug" I describe is not a graphical issue, the graphics are all correct, the "bug" is a freeze caused in the fight with the ghost when you use the camera to take a photo.
i7 920 2'66 Gig; 4 Gigs RAM (Dual); Geforce 9800 GTX+ 1024 RAM; X-Fi Titanium; MB: Asus P6T Deluxe; OS: Windows Vista Ultimate SP2 (32-Bit) and Windows 7 64-bits (Default OS)
Reply
#5
I wish I could help, but I only have the NTSC version of this game.
Reply
#6
I test the second savegame to confirm the "bug", and I found that:

Changing the option of the game in "Tv. Config": 50 hz - 60 Hz

I found the next results:

If you use 50 Hz, the "bug" of freezing appears almost in the first time you use the camera.

If you use 60 Hz, the "bug" delays to 2 or 3 uses of the camera, but also happens.

Blush

Of course, PAL version (multilingual) of Project Zero 1.

[Image: attachment.php?aid=22332]

If this "helps", the version of the game with the information provided by PCSX2 Beta r1888 is:

SLES_508.21;1; CRC = 22E91837

I hope this would help. Unsure
i7 920 2'66 Gig; 4 Gigs RAM (Dual); Geforce 9800 GTX+ 1024 RAM; X-Fi Titanium; MB: Asus P6T Deluxe; OS: Windows Vista Ultimate SP2 (32-Bit) and Windows 7 64-bits (Default OS)
Reply
#7
I have the test BETA release of PCSX2 (r3113), and I find an interesting information about Project Zero 1 PAL.

Detected PS2 Disc = cdrom0:\SLES_508.21;1
Software version = 1.00
Disc region type = PAL

A picture of the "only" bug that continues, the freeze bug in the fight with Kirie, when you try to photograph her, all freezes but the music continues:

I use in the graphic plugin Software in DX9 mode. All the other options are all at default, with no Speed Hacks activated.

[Image: attachment.php?aid=23944]

*NOTE: in the BETA version r3113 I test, the "freeze bug" continues with the same behaviour that I have described above, all stops and the music continues (the same as in the version of PCSX2 BETA 1888). But, I can confirm this: The "bug" of the video when you pick the third piece of the mirror, played in 50 Hz, is "fixed" in this version, the video continues and you can continue to play. Rolleyes

The "bug" in the first save of the memcard, is "FIXED". Laugh
The "bug" of the second save of the memcard (freeze bug), is not fixed, yet.

** NOTE: ONLY one bug is fixed in the BETA PCSX2 0.9.7 (r3113), and now this Beta release can be found in the official Web of PCSX2. Rolleyes


Attached Files Thumbnail(s)
   
i7 920 2'66 Gig; 4 Gigs RAM (Dual); Geforce 9800 GTX+ 1024 RAM; X-Fi Titanium; MB: Asus P6T Deluxe; OS: Windows Vista Ultimate SP2 (32-Bit) and Windows 7 64-bits (Default OS)
Reply
#8
[New Bug]

I found a new Bug in the PAL version of "Project Zero 1", this new bug "ONLY" happens when I used the Hardware version of the GSDX plugin (is the same with DX9, DX10/11).

I use to test this:

PCSX version 0.9.7.3113 (svn) all to default, with all "Speed Hacks" deactivated.

GSDX plugins: GSDX 1873 and GSDX 3370 (and others between those). Note: the results are the same with all the plugins.

I ONLY use SOFTWARE mode, for this reason I didn't notice this BUG earlier.

The bug causes you were unable to take a Photo of hostile ghosts and hidden ghosts (but in Software mode all is normal).

Picture taken using Software mode in the beginning of the game, a hidden ghost:

   

Picture taken using Hardware mode in the beginning of the game, the same hidden ghost (see the blue light in the camera, but no blue circle to capture it):

   
i7 920 2'66 Gig; 4 Gigs RAM (Dual); Geforce 9800 GTX+ 1024 RAM; X-Fi Titanium; MB: Asus P6T Deluxe; OS: Windows Vista Ultimate SP2 (32-Bit) and Windows 7 64-bits (Default OS)
Reply
#9
[The Freeze Bug]

All other options I didn't show in the picture were all at "Default", with No Speed Hacks activated.

Graphic Plugin is in DX10/11 mode, and in SOFTWARE.

This "bug" is the same as I described above, but in this case, testing the game I find it in another place, but I think is related to the "visual effect" when Kirie appears, like in the final battle (the picture I put now is nearly close to the last save point of the game, near the "Final Corridor" of the game.)

The "bug" only happens, in other words, only freezes the game, when you use the button to show the camera to take a photo, in some places nothing "bad" happens, but in others the game freezes, like in the final battle (I think this is the "same bug" I have talking about before).

Because this, in a "normal" play is hard to freeze the game in this point, because Kirie is "inmortal", and you only have to run from her. But, near the "gates of evil", run is not an option, you MUST fight her, and then, in some places when you pick your camera, the game freezes.

   

Note: the game is COMPLETABLE, but in the last moment, after the video, you have to take the camera and move with it, don't desequip the camera or you may "die" by a freeze "bug", and with this "technique" is possible to finishing the game.

I put a pictures to make this more easy to understand:

This picture is before you activate the video when Kirie attacks you.

   

And this is the same place, but when Kirie attacks you, well, your "safer" place to avoid the "bug" is to take the camera "here" and attack Kirie until you defeat her (in this place you can put or leave the camera, without the punishing "bug", but if the angle of the camera changes, you may activate the "bug" when you try to use the camera to attack). If you move from the scenario, you maybe activate the bug and you cannot complete the game.

   

---

Final Note: With the latest Official Beta: "PCSX2 0.9.7.3113 (svn)", the "Freeze Bug" is the only remaining "Bug" for "Project Zero 1", the other bug I described is now fixed, no problems between 50 or 60 Hz in that part of the game when a video plays when you pick the 3º piece of the mirror.
i7 920 2'66 Gig; 4 Gigs RAM (Dual); Geforce 9800 GTX+ 1024 RAM; X-Fi Titanium; MB: Asus P6T Deluxe; OS: Windows Vista Ultimate SP2 (32-Bit) and Windows 7 64-bits (Default OS)
Reply
#10
(07-04-2010, 02:14 PM)Fjapo Wrote: [New Bug]

I found a new Bug in the PAL version of "Project Zero 1", this new bug "ONLY" happens when I used the Hardware version of the GSDX plugin (is the same with DX9, DX10/11).

I use to test this:

PCSX version 0.9.7.3113 (svn) all to default, with all "Speed Hacks" deactivated.

GSDX plugins: GSDX 1873 and GSDX 3370 (and others between those). Note: the results are the same with all the plugins.

I ONLY use SOFTWARE mode, for this reason I didn't notice this BUG earlier.

The bug causes you were unable to take a Photo of hostile ghosts and hidden ghosts (but in Software mode all is normal).

Picture taken using Software mode in the beginning of the game, a hidden ghost:



Picture taken using Hardware mode in the beginning of the game, the same hidden ghost (see the blue light in the camera, but no blue circle to capture it):

I can still reproduce this bug with official beta release "PCSX2 0.9.7.3113 (svn)" and GSdx 3623.

Only Software mode can solve the problem, but performance is quite bad
Reply




Users browsing this thread: 1 Guest(s)